Package Details: k3d-git r3533.c9cf45cf-1

Git Clone URL: https://aur.archlinux.org/k3d-git.git (read-only)
Package Base: k3d-git
Description: A free 3D modelling and animation software
Upstream URL: http://www.k-3d.org
Licenses: GPL
Conflicts: k3d
Provides: k3d
Submitter: ashman
Maintainer: ashman
Last Packager: ashman
Votes: 0
Popularity: 0.000000
First Submitted: 2016-09-03 15:09
Last Updated: 2017-08-24 08:16

Latest Comments

ashman commented on 2018-01-28 11:17

Thank you for the information Enrico68. This is a linker error and as you suggested probably a problem with the imagemagick package in your installation. This or your cmake does not work as intended and is not able to find and add all required dependencies correctly (my version is 3.10.1). I have checked the K-3D source code for the plug-in in question and was unfortunately not able to identify a problem. The plugin itself uses only the Magick++ high level interface and not the symbol in the error directly.

Enrico68 commented on 2018-01-24 14:37

If this could be useful , during make process I got the following message

[ 37%] Generating ../../lib/k3d/plugins/k3d-imagemagick-io.module.proxy Loading plugin module /tmp/yaourt-tmp-enrico/aur-k3d-git/src/k3d-build/lib/k3d/plugins/k3d-imagemagick-io.module Module k3d-imagemagick-io.module: /tmp/yaourt-tmp-enrico/aur-k3d-git/src/k3d-build/lib/k3d/plugins/k3d-imagemagick-io.module: undefined symbol: _ZNK6Magick5Image4rowsEv

So I think the problem is connected with the imagemagick package

Enrico68 commented on 2018-01-24 10:31

Tried with both k3d and k3d-git and using both imagemagick git and non git. Got the same error. I am on MacBookPro8,1 1.0 with Kernel: 4.9.77-1-MANJARO .

ashman commented on 2018-01-21 14:07

No, my build system has the non git version of the imagemagick package as provided by the official repository. The exact version is 7.0.7.21-1. I tried to install the imagemagick-git package from the AUR to see if this might trigger the reported problem but the build of this package failed due to some missing file still during the download/prepare phase. Maybe you guys could check your installed imagemagick package and see what is exactly installed on your systems. This might give a clue.

test0 commented on 2018-01-21 10:58

I could only speculate that this package is only compatible with git version of imagemagick. Are you using imagemagick git ashman?

ashman commented on 2018-01-21 09:51

Can't reproduce this. I am building on a fresh Arch installation installed from the 2018.01.01 ISO inside a VM and the package builds fine. Maybe someone in the forums can help you out because I have no clue how to fix this specific issue. If someone figures out the problem I will happily integrate a patch and forward it to upstream.

Enrico68 commented on 2018-01-20 02:19

Getting error after finishing compiling package :

CMake Error at modules/imagemagick_io/cmake_install.cmake:61 (file): file INSTALL cannot find "/tmp/yaourt-tmp-enrico/aur-k3d-git/src/k3d-build/lib/k3d/plugins/k3d-imagemagick-io.module.proxy". Call Stack (most recent call first): modules/cmake_install.cmake:68 (include) cmake_install.cmake:51 (include)

ashman commented on 2018-01-07 11:14

To my knowledge there are no prebuild binary packages. Alternativly you could try to download an existing Arch Linux Virtual Box image from osboxes.org (or Docker Hub) and build it within the image. Just ensure to perform a system update first. K-3D explicitly links against a specific Boost so the version of the build system has to be present on the productive system.

I can upload you a binary package but I need a valid contact address since posting temporary links in the comment section should be avoided according to the community rules.

test0 commented on 2018-01-05 17:32

I've rebuild collada-dom package but that doesn't fix it. There's only one single .so file that is missing after compile. I think is has to do with module configuration or something, I'm using gcc7 btw.

-- Set runtime path of "/home/asdasd/.cache/pacaur/k3d-git/pkg/k3d-git//usr/lib/k3d/plugins/k3d-imagemagick-io.module" to "" CMake Error at modules/imagemagick_io/cmake_install.cmake:61 (file): file INSTALL cannot find "/home/asdasd/.cache/pacaur/k3d-git/src/k3d-build/lib/k3d/plugins/k3d-imagemagick-io.module.proxy". Call Stack (most recent call first): modules/cmake_install.cmake:68 (include) cmake_install.cmake:51 (include)

Is there any binary package for arch available somewhere?

ashman commented on 2018-01-03 15:38

Sorry but I cannot reproduce your problem although I got a similar message regarding the collada-dom package. In my case removing the collada-dom package, rebuilding and reinstalling it solved the problem. I am not really sure how to help you with this.

All comments