Package Details: keepassxc-cryptomator 0.0.4-1

Git Clone URL: https://aur.archlinux.org/keepassxc-cryptomator.git (read-only, click to copy)
Package Base: keepassxc-cryptomator
Description: Store Cryptomator vault passwords in KeePassXC
Upstream URL: https://plugin.purejava.org/
Licenses: MIT
Submitter: purejava
Maintainer: purejava
Last Packager: purejava
Votes: 2
Popularity: 0.33
First Submitted: 2021-08-28 06:29
Last Updated: 2021-12-03 04:14

Dependencies (4)

Required by (2)

Sources (1)

Latest Comments

purejava commented on 2021-10-14 09:27

Good idea @SailReal. I adopted your idea. Thanks.

SailReal commented on 2021-10-13 21:22

Hey @purejava,

Thanks for maintaining this awesome package. I have a lot of different JDK's on my system in use so in return, often selected not the required one for building packages. This build errors is no problem if you saw it already but for the first time it looks like an "random" maven build error. That's why I just implemented in the Cryptomator AUR package in the prepare() stage a check if in our case JDK 17 is selected and not only installed.

The output looks like this on my device:

==> Extracting sources...
  -> Extracting cryptomator-1.6.0-rc2.tar.gz with bsdtar
==> Starting prepare()...
You don't have a Java 17 JDK selected but the following installed on your system:
  java-17-adoptopenjdk
  java-17-jdk
  zulu-17
Select a Java 17 JDK using "sudo archlinux-java set [name from the list above]"
If you switched to a JDK 17, please re-run the installation.
==> ERROR: A failure occurred in prepare().
    Aborting...

Here you can find the related code: https://github.com/SailReal/cryptomator-aur/commit/a1bd22a2f31277cbee6354df41990dc6fac77df8

If you feel up to it, you are welcome to adopt or modify it for this package. It would be wonderful if this one also checks the JDK version so that people who don't have to deal with Java or Maven projects all the time would get an understandable message while building the plugin.