Package Details: komodo-edit 11.0.2_18122-2

Git Clone URL: https://aur.archlinux.org/komodo-edit.git (read-only)
Package Base: komodo-edit
Description: Free & Open-Source counterpart of ActiveState Komodo IDE - XUL based
Upstream URL: http://www.activestate.com/komodo-edit
Licenses: MPL
Conflicts: komodo-ide, komodo-ide-nightly, komodoedit
Submitter: max-k
Maintainer: max-k
Last Packager: max-k
Votes: 247
Popularity: 0.155847
First Submitted: 2013-05-24 00:14
Last Updated: 2018-01-06 23:58

Latest Comments

Naatan commented on 2018-01-04 16:33

Please update to latest version (version 11.0.2)

naraesk commented on 2017-12-30 11:42

komodo-ide should be listed as conflict

max-k commented on 2017-12-19 11:26

I forgot to build .SRCINFO since the last release.

Since I use yaourt to install aur packages, I didn't realize I made this mistake.

In my mind, the real point here is that .SRCINFO probably have to be built automatically (perhaps serverside).

It wasn't needed before AUR4.

There is absolutly no added value in launching mksrcinfo manually each time you update a PKGBUILD.

I will probably write a git hook waiting for a better solution

kaputtnik commented on 2017-12-19 10:11

Looks like pacaur was used, at least from user pleycpl. I had also no problem installing komodo-edit with normal pacman steps.

pacaur is not maintaned anymore and relies on 6 year old code. See the posts in the pacaur topic: https://bbs.archlinux.org/viewtopic.php?pid=1755144#p1755144

adlerweb commented on 2017-12-19 10:02

Yes, .SRCINFO is not up to date, this should however not prevent using the package. I just installed 11.0.1_18119-1 without any problem. Are you using any AUR-helpers? If so try calling makepkg directly.

Bachsau commented on 2017-12-19 09:35

I'm having the same problem. :[ Non working packages should be banned from AUR.

pleycpl commented on 2017-12-09 11:57

$ pacaur -S komodo-edit

...

...

==> Leaving fakeroot environment.

==> Finished making: komodo-edit 11.0.1_18119-1 (Sat Dec 9 11:56:35 GMT 2017)

==> Cleaning up...

:: Installing komodo-edit package(s)...

:: komodo-edit package(s) failed to install.

:: ensure package version does not mismatch between .SRCINFO and PKGBUILD

:: ensure package name has a VCS suffix if this is a devel package

$

kaputtnik commented on 2017-03-24 18:57

Dind't had any issues with the files, no integrity failure. I guess user slav had trouble during download/save?

adlerweb commented on 2017-03-06 18:08

Files where modified on 2017-02-21 - current checksums as per their website:

sha256sums_i686=('7b7e8caa90d9d8880449a67d27e9c27a6b3f093247eb03743194dda85e08b3c7')
sha256sums_x86_64=('5e4eb7312c5f07941fcf74766be635f4fbd13fd55453b81427a85d6e1060a24e')

slav commented on 2017-03-06 15:43

-> Found Komodo-Edit-10.2.0-17657-linux-x86_64.tar.gz
==> ERROR: Integrity checks (sha256) differ in size from the source array.

however skipping all source file integrity checks with makepkg -s --skipinteg resolved issue

All comments