Package Details: libcsptr 2.0.4-2

Git Clone URL: https://aur.archlinux.org/libcsptr.git (read-only)
Package Base: libcsptr
Description: A smart pointers library for the C programming language
Upstream URL: http://github.com/Snaipe/libcsptr.git
Licenses: MIT
Submitter: Snaipe
Maintainer: Snaipe
Last Packager: Snaipe
Votes: 3
Popularity: 0.000001
First Submitted: 2015-04-14 19:25
Last Updated: 2017-11-29 14:37

Dependencies (2)

Required by (1)

Sources (1)

Latest Comments

Ethyling commented on 2017-11-30 14:31

@Snaipe: Thanks, you have the same problem on your packet Criterion

Snaipe commented on 2017-11-29 14:37

@Ethyling: fixed in dcec09c. Thanks!

Ethyling commented on 2017-11-28 12:47

Hi,

It does not build on a fresh system:

==> Starting build()...
/home/build/libcsptr/PKGBUILD: line 17: cmake: command not found
==> ERROR: A failure occurred in build().
Aborting...

cmake is not part of the base-devel package group.
Could you please add it as makedepends ?

Snaipe commented on 2016-04-02 09:55

@jetm: Fixed, thanks!

jetm commented on 2016-04-02 09:26

Error when is build:

==> Validating source files with md5sums...
v2.0.4.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build libcsptr.
==> Restart building libcsptr ? [y/N]

Solution by editing PKGBUILD:

- md5sums=('f43cc18338952a69a79e9215033e4279')
+ md5sums=('f55ff517219883f07e748fdc2fc084ed')