Package Details: libdcp-git 0.r1633.a602723-1

Git Clone URL: https://aur.archlinux.org/libdcp-git.git (read-only)
Package Base: libdcp-git
Description: A small C++ library which can create and read Digital Cinema Packages using JPEG2000 and WAV files
Upstream URL: http://carlh.net/software/libdcp
Licenses: GPL
Conflicts: libdcp
Provides: libdcp=1.4.3devel
Submitter: markusk
Maintainer: markusk
Last Packager: markusk
Votes: 1
Popularity: 0.000000
First Submitted: 2014-12-26 19:49
Last Updated: 2018-05-31 18:53

Pinned Comments

markusk commented on 2018-03-26 12:59

dcpomatic-git and it's depend "lib" packages where switched back to "bleeding edge" master branch! Use at own risk!

For production use better switch back to stable package at https://aur.archlinux.org/packages/dcpomatic/

Remember to deinstall all the "dcpomatic libs" when you switch from git to none git versions of my packages.

Latest Comments

markusk commented on 2018-09-10 15:20

@mrpewpew: as said before ... the "xxxxxx-git" versions of my arch linux packages are "bleeding edge" and i'm trying to reduce the need of keeping multiple -git and none-git versions to a minimum. At the moment i'm not supplying a libasdcp-cth-git besides the stable libasdcp-cth which is used by both stable and develop-unstable-bleeding versions of my packages. I usually only use the "xxx-git" packages to do some pre-stable release build testing.

You could try to install the development git version by hand using the development version on http://carlh.net/asdcplib but i advice against using the resulting DCP's from the unstable-bleeding-edge dev versions of dcpomatic for anything else then test purposes.

If you give me a valid reason why i should invest time in supporting a libasdcp-cth-git package i might consider doing so in the future ...

mrpewpew commented on 2018-09-10 14:29

Unfortunately, the package doesn't build anymore. The error message is : ../src/smpte_subtitle_asset.cc:50:10: fatal error: asdcp/KM_log.h: No such file or directory

markusk commented on 2018-03-26 12:59

dcpomatic-git and it's depend "lib" packages where switched back to "bleeding edge" master branch! Use at own risk!

For production use better switch back to stable package at https://aur.archlinux.org/packages/dcpomatic/

Remember to deinstall all the "dcpomatic libs" when you switch from git to none git versions of my packages.

markusk commented on 2018-03-21 07:40

@TilmanV: Thank you for the version info! It's fixed now.

TilmanV commented on 2018-03-20 10:54

PKGVer in PKGBUILD and SRCINFO are different. This causes an infinite updateloop.