Package Details: libqglviewer 2.7.0-2

Git Clone URL: https://aur.archlinux.org/libqglviewer.git (read-only)
Package Base: libqglviewer
Description: C++ library based on Qt that eases the creation of OpenGL 3D viewers
Upstream URL: http://www.libqglviewer.com/
Keywords: OpenGL
Licenses: GPL2, custom, GPL3
Conflicts: libqglviewer-qt4
Submitter: ilpianista
Maintainer: gian
Last Packager: gian
Votes: 13
Popularity: 0.000000
First Submitted: 2009-10-17 21:36
Last Updated: 2017-07-10 08:03

Latest Comments

gian commented on 2017-07-10 08:04

Fixed the md5sum

About the site, I know there is a github page, but as far as i know, the official page is libqglviewer.com.

I will ask to the author if something changed anyway.

thanks
Gianluca

Spharx commented on 2017-07-09 18:51

libQGLViewer-2.7.0.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
The build failed.

New md5sum seems to be e6f1c37d2dc8343b4c74c88d65eb77c6
Unfortunately there is no md5sum on the website to compare.

Also there is now a github page: https://github.com/GillesDebunne/libQGLViewer

with releases. The authors name matches the one from the licensing information from the project website, but there is no mentioning of the github page.

bchretien commented on 2015-12-03 09:29

The prefix should be specified (rather than installing to /usr/local):

qmake PREFIX=/usr ...

gian commented on 2015-07-21 20:39

Thanks, fixed

akobel commented on 2015-07-21 08:49

The PKGBUILD is broken due to an additional comma after 'mesa' in line 12:
depends=('qt5-base' 'glu' 'mesa', 'qt5-tools')
should read
depends=('qt5-base' 'glu' 'mesa' 'qt5-tools')

gian commented on 2015-07-08 15:48

I will update the package to add the dependency.

Qt 4.8.7 is/will be the last release for the 4.8.x series, and the support will end later this year, so I will add an explict conflict, but I am not planning to work on the qt4 version of the package

bo0ts commented on 2015-07-08 09:30

Currently this also requires qt5-tools for the designerPlugin to build correctly. It also has filesystem conflicts with libqglviewer-qt4. It would be nice if those could be fixed, but I understand if you consider that too much work.

bo0ts commented on 2015-06-24 08:42

Upstream released 2.6.2 and broke the link to the 2.6.1 tarball :(

I'm aware of the aur4 transition, so I'll post it there to.

gian commented on 2014-03-05 20:38

I already informed the upstream author of the problem.
Since they are in the examples, I think they can be skipped

I uploaded both packages for qt4 and qt5, but without the examples

bo0ts commented on 2014-03-05 13:47

I fixed parts of the PKGBUILD to use 2.5.1, qmake, and depend on qt5-base but get build errors:

constrainedFrame.cpp:82:88: no matching call for Viewer::setMouseBinding

if I figure out how to fix those, I'll adopt the package and update it.

All comments