Package Details: libreoffice-online 6.4.10-1

Git Clone URL: https://aur.archlinux.org/libreoffice-online.git (read-only, click to copy)
Package Base: libreoffice-online
Description: HTML5-based/cloud-based version of the office suite
Upstream URL: https://www.libreoffice.org/download/libreoffice-online/
Licenses: MPL
Submitter: sergej
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 5
Popularity: 0.27
First Submitted: 2017-11-24 12:10
Last Updated: 2021-08-23 15:28

Latest Comments

andrej commented on 2021-04-12 23:21

This doesn’t build atm.

kit/ChildSession.cpp: In member function ‘bool ChildSession::dialogEvent(const char*, int, const StringVector&)’:
kit/ChildSession.cpp:1487:21: error: ‘using element_type = class lok::Office’ {aka ‘class lok::Office’} has no member named ‘sendDialogEvent’
 1487 |         getLOKit()->sendDialogEvent(nLOKWindowId, tokens.cat(' ', 2).c_str());
      |                     ^~~~~~~~~~~~~~~

simona commented on 2021-04-12 23:01

loolconfig: error while loading shared libraries: libPocoNet.so.64: cannot open shared object file: No such file or directory

wspiegel commented on 2021-01-29 17:58

wopi-discovery give urlsrc="https://cloud.mirrorsoft.at:9980/loleaflet/7.0.1/loleaflet.html but only https://cloud.mirrorsoft.at:9980/loleaflet/dist/loleaflet.html working is there a way to correct this?

Thanks

simona commented on 2020-06-11 22:05

loolconfig: error while loading shared libraries: libPocoNet.so.64: cannot open shared object file: No such file or directory

snafu commented on 2020-01-17 12:55

done.

a specific problem? are you using it with nextcloud?

lahwaacz commented on 2020-01-17 12:52

I don't have a working setup yet...

P.S. sha512sums for libreoffice-online.install has to be updated as well.

snafu commented on 2020-01-17 12:37

Thanks a lot!

Resolved by: d3fce82e1fc5

Does the package actual work? (I've to admit, that I did just a compile test, since it was orphaned, I updated it more along the lines of my gentoo-ebuild)

Do you want to take over maintainer ship?

lahwaacz commented on 2020-01-17 12:17

There are some mistakes in the PKGBUILD:

post_install() {
     loolconfig update-system-template
     setcap cap_fowner,cap_mknod,cap_sys_chroot=ep /usr/bin/loolforkit
}

post_upgrade() {
    post_install
}

jsutton commented on 2017-12-14 15:49

Currently doesn't build with current version of poco (1.8.0). Grabbed older version from...

https://archive.archlinux.org/packages/p/poco/

sergej commented on 2017-11-24 12:12

removed from community. Shows outdated 2.0.3 version, but in git there is pkgbuild for 5.4.2.2