Package Details: libretro-2048-git 122.80d462a-1

Git Clone URL: https://aur.archlinux.org/libretro-2048-git.git (read-only)
Package Base: libretro-2048-git
Description: libretro implementation of 2048
Upstream URL: https://github.com/libretro/libretro-2048
Keywords: games libretro ports retroarch
Licenses: GPL, LGPL
Submitter: BlackLotus89
Maintainer: mictjs
Last Packager: mictjs
Votes: 6
Popularity: 0.000161
First Submitted: 2014-07-20 15:51
Last Updated: 2018-10-26 19:54

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

Neros commented on 2017-12-22 22:17

Can you remove the .info? This file is now in libretro-core-info in the community repo. Thanks!

Neros commented on 2017-10-05 18:34

It should be renamed 2048_libretro (both .so and .info) and the info should be in /usr/share/libretro/info.

ProfessorKaos64 commented on 2016-09-15 14:13

Can you please ad "groups=('libretro')" (sans quotes) so this shows up when installing the "libretro" group package set?

Enverex commented on 2014-12-15 00:50

Can you please keep the proper name? There's no reason to rename the module to 2048-libretro.so (when it should be 2048_libretro.so).

jonki commented on 2014-08-18 18:49

On Arch Linux ARM build exists with:

cc -fPIC -shared -Wl,--no-undefined -L/tmp/yaourt-tmp-root/aur-libretro-2048-git/src/libretro-2048/tmp/lib -o 2048_libretro.so libretro.o game_cairo.o game_shared.o /tmp/yaourt-tmp-root/aur-libretro-2048-git/src/libretro-2048/tmp/lib/libcairo.a /tmp/yaourt-tmp-root/aur-libretro-2048-git/src/libretro-2048/tmp/lib/libpixman-1.a -lpthread -lfreetype -lfontconfig -lm
/tmp/yaourt-tmp-root/aur-libretro-2048-git/src/libretro-2048/tmp/lib/libcairo.a: error adding symbols: Archive has no index; run ranlib to add one
collect2: error: ld returned 1 exit status
Makefile:95: recipe for target '2048_libretro.so' failed
make: *** [2048_libretro.so] Error 1

Do I need some other library?

prettyvanilla commented on 2014-07-30 20:39

License should be GPL3 and you should build from Makefile.libretro, then you won't need the CPPFLAGS override because it doesn't use cairo anymore.