Package Details: libsearpc 2:3.2.0-6

Git Clone URL: (read-only, click to copy)
Package Base: libsearpc
Description: A simple C language RPC framework (including both server side & client side)
Upstream URL:
Licenses: Apache
Submitter: aclindsa
Maintainer: thealchemist (Joffrey)
Last Packager: Joffrey
Votes: 85
Popularity: 0.009038
First Submitted: 2013-01-19 15:50 (UTC)
Last Updated: 2022-05-11 11:46 (UTC)

Latest Comments

urldog commented on 2020-09-18 14:19 (UTC)

This fails to build, even using The "new" hash for the 3.2.0 version :) I understand it's difficult to package something where code changes and version number doesn't, but seafile on arch is broken very often. It's not IME in ubuntu-based distros.

IMars commented on 2020-09-09 05:12 (UTC)

The "new" hash for the 3.2.0 version is


tilx commented on 2020-03-25 15:17 (UTC)

The people making Seafile have a habit of re-releasing different code for the same version numbers - I've seen this happen for different Seafile-related packages. The same version tag and associated downloadable blob will give you different code, invalidating the hashes.

Not only is it annoying, it's also not ideal in terms of security. I stopped using Seafile because of this. Apparently I still get notifications from the AUR package, and I'm sad to hear this practice is still going on. Disabling notifications now. Take care, folks!

languitar commented on 2020-03-25 14:34 (UTC)

And the hash is invalid again :/

sjoerdos commented on 2020-03-24 13:07 (UTC)

Dear maintainer, please update the sha256sum in the PKGBUILD.

If I change it to


the package installs just fine

illspirit commented on 2020-03-21 17:51 (UTC) (edited on 2020-03-21 17:52 (UTC) by illspirit)

==> Making package: libsearpc 2:3.2.0-3 (Sat 21 Mar 2020 12:40:01 PM CDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources... 
  -> Found libsearpc-3.2.0.tar.gz
==> Validating source files with sha256sums...
    libsearpc-3.2.0.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!

matejdro commented on 2020-03-21 10:36 (UTC)

Build fails with:

==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found libsearpc-3.2.0.tar.gz
==> Validating source files with sha256sums...
    libsearpc-3.2.0.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
Failed to build libsearpc

DasGurke commented on 2019-11-15 11:55 (UTC)

Oh, I just recognized that upstream has no issue tracker. Does maybe one of the maintainers here have a possibility to reach upstream?

DasGurke commented on 2019-11-15 11:49 (UTC)

There seems to be a Python 2 incompatability with libsearpc. For me Seahub has stopped working, as described at

There is a proposed workaround at , but monkey-patching the Python 2.7 core libraries doesn't seem like something a sane person should do.

tilx commented on 2019-07-19 20:07 (UTC) (edited on 2019-07-19 20:15 (UTC) by tilx)

The latest update broke the version progression by going back from 3.1.0, pkgrel=2 to ver 3.1, pkgrel=1. Now it looks like my installed version is newer:

-> libsearpc: local (1:3.1.0-2) is newer than AUR (1:3.1-1)

Looking at the current release, we're actually on 3.1-latest, which doesn't seem to be a fixed tag, but might change what commit it references. This means that the same version/rel of this AUR package might point at different code at different times, which will also suddenly break the checksums without notice.

Wouldn't it make sense to wait/push for an official, properly tagged release before updating this package?

eolianoe commented on 2018-12-14 18:52 (UTC)

@flying-sheep: python2 will still be needed to build the package so for now you cannot get rid of it :(

flying-sheep commented on 2018-12-12 14:53 (UTC) (edited on 2018-12-12 15:26 (UTC) by flying-sheep)

Could you please make the python2 deps optional or split off a python-searpc package? I’d like to get rid of python2 on my system.

eolianoe commented on 2017-09-03 14:55 (UTC)

@akhfa & @craftyguy: pkg-config should be already installed as it's from the base-devel group which is an implicit requirement [a] [a]

akhfa commented on 2017-09-03 13:47 (UTC)

@craftyguy You need to install pkg-config first. I don't now how to contribute to aur so I can't add to dependencies.

hillbicks commented on 2017-01-05 18:04 (UTC)

correct sha256sum for libsearpc-v3.1-latest.tar.gz: 83b45fa2f4b7d7ae6dd34ca04d430433551ef493cdaf3cbcc768bd6099377d90

5chdn commented on 2016-12-26 19:43 (UTC)

Validating source files with sha256sums... libsearpc-v3.1-latest.tar.gz ... FAILED libsearpc.pc.patch ... Passed ERROR: One or more files did not pass the validity check!

eolianoe commented on 2016-12-20 14:29 (UTC)

@craftyguy: I cannot reproduce this failure, do you have all the dependencies properly installed?

craftyguy commented on 2016-12-19 02:31 (UTC)

Fails when in configure: checking for WIN32... checking for Mac... ./configure: line 11970: syntax error near unexpected token `GLIB,' ./configure: line 11970: `PKG_CHECK_MODULES(GLIB, gobject-2.0 >= $GLIB_REQUIRED)' ==> ERROR: A failure occurred in build(). Aborting... :: failed to build libsearpc package(s)

noEntry commented on 2016-12-17 12:11 (UTC)

Deleting the cache worked. Never had such a problem... Thanks

alexanderp commented on 2016-12-15 07:19 (UTC)

You've probably got the old version cached: delete ~/.cache/pacaur/libsearpc

eolianoe commented on 2016-12-14 19:52 (UTC)

@noEntry: are you sure that you are using the latest PKGBUILD and source ?

noEntry commented on 2016-12-14 19:14 (UTC)

Issue persists: ==> Validating source_x86_64 files with sha256sums... flash_player_ppapi_linux_24.0.0.186.x86_64.tar.gz ... Passed :: Checking libsearpc integrity... ==> Making package: libsearpc 3.1-2 (Mi 14. Dez 20:12:20 CET 2016) ==> Retrieving sources... -> Found libsearpc-v3.1-latest.tar.gz -> Found libsearpc.pc.patch ==> Validating source files with sha256sums... libsearpc-v3.1-latest.tar.gz ... FAILED

eolianoe commented on 2016-12-14 12:35 (UTC)

@languitar & @jaltek: should be fixed in 3.1-2

languitar commented on 2016-12-13 17:17 (UTC)

Same issue with the validation here

jaltek commented on 2016-12-13 07:48 (UTC)

Hi, the integrity check for "libsearpc-v3.1-latest.tar.gz" actually fails. Maybe they changed the source file?

simontunnat commented on 2015-10-29 16:24 (UTC)

Could someone please take over the seafile packages as maintainer. I just can't find the time to maintain them.

commented on 2015-09-29 12:49 (UTC)

I am unwilling to wait any longer, so the package is now orphaned. I advise anyone willing to pick this up to pick up the whole seafile dependency tree, as it would otherwise become tedious to maintain.

commented on 2015-09-05 15:38 (UTC)

This is the last package update from me. Since I have received mail from one from person interested in maintaining, I will not orphan the packages just yet, but in the next couple of days.

muellerd commented on 2015-08-26 17:13 (UTC)

Hello, python2 needs to be added to Dependencies, without the build will fail.

commented on 2015-08-07 19:01 (UTC)

Since I no longer intend to use distributions with systemd for personal use, I will abandon this package no earlier than 2015-09-01. Should someone be interested in maintaining this package afterwards, he or she can contact me in the interim to become co-maintainer and then sole maintainer once I leave, to ensure a smooth transition. If possible, I would like to hand over the following packages over to a single maintainer, since they comprise a dependency graph: libevhtp-seafile, libsearpc, ccnet, seafile-shared, seafile-client, seafile-client-cli, seafile-server

somniumAeternam commented on 2015-07-31 12:41 (UTC)

autoconf is required, otherwise the build will fail

vahit commented on 2015-07-29 07:26 (UTC)

Hi everyone today wheen i try install this package, i get this error: ==> ERROR: libsearpc.pc.patch was not found in the build directory and is not a URL. what's the problem and how can i resolve it? I need this package! Thanks.

commented on 2015-06-12 09:34 (UTC)

Initial AUR4 import.

commented on 2015-01-31 18:53 (UTC)

@SplitFire: The package has no issues building since 2015-01-24, so I have no idea what your problem is.

commented on 2015-01-31 18:51 (UTC)

@SplitFire: The has no issues building since 2015-01-24, so I have no idea what your problem is.

SplitFire commented on 2015-01-31 10:47 (UTC)

Can someone take care of this package? I think that calrama not handle this package.

senorsmile commented on 2015-01-19 05:06 (UTC)

as already mentioned, there's an error building this. options= needs to be options=() to be valid bash.

mlq commented on 2014-12-19 12:42 (UTC)

option must not be empty if given

rumpelsepp commented on 2014-06-25 05:35 (UTC)

Please rebuild with mkaurball. thanks!

commented on 2014-05-03 07:29 (UTC)

@guilhas: No, they are not. Please read [1] and then look at the members of [2]. This has been discussed in the comments here repeatedly, please read them for further information. [1] [2]

guilhas commented on 2014-05-02 22:37 (UTC)

same as maurice pkg-config and patch missing

rudygotya commented on 2014-04-25 18:56 (UTC)

Misses 'libtool' dependency: / **Error**: You must have `libtool' installed to compile libsearpc. Get (or a newer version if it is available)

aclindsa commented on 2014-04-12 02:53 (UTC)

I have orphaned this package and other seafile dependencies because I haven't used them for quite some time and no longer have the time or motivation to properly maintain them. I have not been able to find a maintainer to take over, but trust that if the package is truly useful someone will take over where I left off.

aclindsa commented on 2014-04-12 02:24 (UTC)

I added the pacman requirement when pacman 4.1 was just being released, because it changed the behavior of the prepare() function in an incompatible way and this seemed the best way to ensure users were using a version compatible with the package. It can probably be removed now. In this case, I don't believe python2 is necessary to have as a requirement as it is implicit in the requirement of python2-simplejson.

pulb commented on 2014-04-11 18:23 (UTC)

Why does this package depend on pacman? Please also add python2 to the dependency list.

aclindsa commented on 2014-03-26 11:14 (UTC)

Thijxx: Which "instructions from the creators" did you follow? Are you saying that my unmodified package built and installed fine when using makepkg directly instead of an AUR helper, or that you had to make changes to it?

Thijxx commented on 2014-03-26 07:28 (UTC)

I followed the instructions from the creators. Finally it was installed in a breeze just using makepkg and pacman -U. Afterwards I could use yaourt to install the rest of seafile-client. Had to initiate the applet by hand, hope it sticks after reboot.

aclindsa commented on 2014-03-26 00:42 (UTC)

Thijxx: I have never seen your error, and am unable to reproduce it on any of my Arch boxes. I can't find a line in my generated ./configure script that looks like the error message you're reporting. If you identify the issue, let me know and I'll gladly update the package. As a sidenote, I see the "./configure: line 11470: test: =: unary operator expected" warning on my side, but it appears to be harmless.

Thijxx commented on 2014-03-26 00:10 (UTC)

After ./ then in ./configure there is this error: checking for WIN32... checking for Mac... ./configure: line 11449: test: =: unary operator expected ./configure: line 11474: syntax error near unexpected token `GLIB,' ./configure: line 11474: `PKG_CHECK_MODULES(GLIB, gobject-2.0 >= $GLIB_REQUIRED)' All dependencies installed; pkg-config patch libtool glib2 jansson pacman base-devel Tried on two machines, same result. uname -a Linux archbeast 3.13.7-1-ARCH #1 SMP PREEMPT Mon Mar 24 20:06:08 CET 2014 x86_64 GNU/Linux

aclindsa commented on 2014-02-02 15:27 (UTC)

@maurice Please read the comment immediately preceding yours.

maurice commented on 2014-02-02 14:23 (UTC)

Some dependencies seem to be missing: pkg-config, patch, libtool.

aclindsa commented on 2013-08-11 12:56 (UTC)

RobertGatstein: According to the PKGBUILD and AUR documentation[1, 2], it is assumed that the base-devel[3] group is installed, so it should not to be included in the makedepends= line. The base-devel group includes all the packages you listed. Hope this helps! [1] [2] [3]

commented on 2013-08-11 10:08 (UTC)

I've had a problem to compile it on my Raspberrry My machine had no "patch, gcc, pkg-config" Would it possible to add this to the depends list.

kevincox commented on 2013-07-20 03:46 (UTC)

I noticed you added armv7h. Would it be possible to add armv6h as well. I have tested it and it works.

kevincox commented on 2013-07-04 01:11 (UTC)

Adding "armv6h" to the "arch" variable allows for use on arm devices such as the raspberry pi.

aclindsa commented on 2013-04-05 14:37 (UTC)

peplin: Ah, I hadn't updated in a few days and hadn't gotten the pacman 4.1 update yet. I'll update the packages.

peplin commented on 2013-04-05 14:21 (UTC)

Follow to the previous comment - prepare is now called automatically in pacman >= 4.1.

peplin commented on 2013-04-05 14:20 (UTC)

The call to prepare() at the top of build() is causing problems because the patch is applied twice. The second time it detects that it's already been applied and you're either given the option to reverse the patch (bad) or skip it, which causes the entire install to fail.

aclindsa commented on 2013-04-04 18:08 (UTC)

Are you doing anything different than downloading the tarball, extracting it, and running makepkg? (If you're installing it with pacaur/yaourt/something can you try doing it manually with makepkg to see if you can reproduce the problem that way?)

aclindsa commented on 2013-04-04 18:06 (UTC)

hobarrera: Interesting - I have never seen that happen before and can't reproduce it now. I'm having trouble thinking of anything that would cause this.

whynothugo commented on 2013-04-04 17:49 (UTC)

Oh, I thought the patch was no longer needed since it looks like it's already applied upstream: ==> Starting build()... patching file Reversed (or previously applied) patch detected! Assume -R? [n]

aclindsa commented on 2013-04-04 11:51 (UTC)

hobarrera: After looking into it, the patch *is* necessary. Without it, auto-configuration does not work properly for packages which have build requirements on libsearpc (i.e. those build scripts will look for header files at the build path, not the installed path).

aclindsa commented on 2013-04-04 11:19 (UTC)

hobarrera: Unfortunately, the developers do not seem to keep download links for older source versions around (if you have found where they do, please let me know). Hmmm, it does appear to work fine without the patch now. I seem to remember an earlier issue where it wouldn't install to the right directory if I didn't patch up that file due to wonkiness with their build scripts.

whynothugo commented on 2013-04-04 10:56 (UTC)

patch does not seem to be necessary.

whynothugo commented on 2013-04-04 10:53 (UTC)

You shouldn't point to file "-latest" for this package, but rather to the proper version. Otherwise the package breaks when upstream releases a new version.