Package Details: lmod 8.7.6-1

Git Clone URL: (read-only, click to copy)
Package Base: lmod
Description: Environment modules system based on Lua that handles MODULEPATH hierarchical problem. Supports also legacy TCL modules
Upstream URL:
Licenses: custom
Conflicts: env-modules, lmod-git
Provides: env-modules
Submitter: wookietreiber
Maintainer: matse
Last Packager: matse
Votes: 8
Popularity: 0.032549
First Submitted: 2017-01-17 13:22 (UTC)
Last Updated: 2022-07-01 14:07 (UTC)

Required by (11)

Sources (1)

Latest Comments

1 2 3 Next › Last »

matse commented on 2021-04-12 13:36 (UTC)

@sogaiu: thanks for the hint! That were indeed the wrong filenames. I've updated the hint with the correct filenames.

sogaiu commented on 2021-04-12 13:22 (UTC)

The current install message has the text (in lmod.install):

In order tu use lmod make sure to source
/etc/profile.d/ or /etc/profile.d/module.csh

May be it's a bit better if and modules.csh were used in that text instead of and module.csh respectively.

matse commented on 2020-09-04 17:23 (UTC)

@berquist: Updated to newest release and done. Thanks for the hint.

berquist commented on 2020-09-04 02:43 (UTC)

Can you change env-modules-tcl to env-modules inprovides and conflicts?

matse commented on 2020-08-06 10:28 (UTC) (edited on 2020-08-06 16:58 (UTC) by matse)

@simonp yes, it's because of the update to lua 5.4 and broken lua-posix at the moment. Since the package was updated today, just reinstall / recompile lua-posix and it will work again.

lahwaacz commented on 2020-08-06 10:14 (UTC) (edited on 2020-08-06 10:14 (UTC) by lahwaacz)

@simonp: you need to rebuild all lua modules and this package for the new lua version.

simonp commented on 2020-08-06 09:32 (UTC)

I'm getting the following error after updating lua this morning:

/usr/bin/lua: version mismatch: app. needs 503.0, Lua core provides 504.0 stack traceback: [C]: in ? [C]: in function 'require' /usr/share/lua/5.3/posix/init.lua:23: in main chunk [C]: in function 'require' /usr/share/lmod/lmod/libexec/lmod:61: in main chunk [C]: in ?

matse commented on 2019-06-19 23:23 (UTC)

lahwaacz: Convinced and thanks for the information! Fixed!

lahwaacz commented on 2019-06-19 05:34 (UTC)

matse: The assumption is for the base-devel group, not for base - see e.g. The wiki was wrong, I just fixed that.

matse commented on 2019-06-18 23:11 (UTC) (edited on 2019-06-18 23:12 (UTC) by matse)

lahwaacz: procps-ng belongs to the base group, which is assumed to be installed on systems, on which you build your own packages, see: