Package Details: logmein-hamachi 2.1.0.198-1

Git Clone URL: https://aur.archlinux.org/logmein-hamachi.git (read-only)
Package Base: logmein-hamachi
Description: A zero-configuration VPN service
Upstream URL: https://www.vpn.net/linux
Licenses: custom
Conflicts: hamachi
Replaces: hamachi
Submitter: Xavion
Maintainer: Xavion (RazZziel)
Last Packager: Xavion
Votes: 223
Popularity: 0.088232
First Submitted: 2010-07-10 01:04
Last Updated: 2018-08-18 21:15

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Xavion commented on 2018-03-13 23:08

Thanks for doing that. Anyone else experiencing this problem should switch to the "logmein-hamachi-beta" package. If enough people are affected by it, we can look at updating this PKGBUILD as well.

blinx commented on 2018-03-13 20:05

@Xavion I got this error after upgrading some packages "/opt/logmein-hamachi/bin/hamachid: relocation error: /usr/lib/libc.so.6: symbol __tunable_get_val, version GLIBC_PRIVATE not defined in file ld-linux-armhf.so.3 with link time reference" So made the beta package based on your PKGBUILD.

Xavion commented on 2018-01-18 21:26

It might be best to wait until it goes stable. Perhaps someone could create a "logmein-hamachi-beta" package for now.

ztefn commented on 2018-01-18 19:55

LogMeIn has released beta version 2.1.0.189 with glibc 2.26 compatibility: https://www.vpn.net/linux#lb_new_beta

RazZziel commented on 2018-01-06 07:01

@Coyoteerex are you sure your PKGBUILD is up to date? glibc=2.25 dependency was removed in 2017-09-13 (https://aur.archlinux.org/cgit/aur.git/commit/?h=logmein-hamachi&id=df565c75c4a7)

Coyoteerex commented on 2018-01-06 06:16

Failed to build package

warning: downgrading package glibc (2.26-8 => 2.25-7)

resolving dependencies...

looking for conflicting packages...

error: failed to prepare transaction (could not satisfy dependencies)

:: binutils: installing glibc (2.25-7) breaks dependency 'glibc>=2.26'

:: gcc-libs: installing glibc (2.25-7) breaks dependency 'glibc>=2.26'

:: lib32-glibc: installing glibc (2.25-7) breaks dependency 'glibc=2.26'

Xavion commented on 2017-09-18 03:51

Thanks for pointing that out. I've had a go at making the PKGBUILD work for everyone again.

blinx commented on 2017-09-17 11:30

I had some issues compiling it for RaspberryPi (armv6h), here is the fix I found:

logmein-hamachi source arm works well on armv6h:

[ "${CARCH}" == "armv6h" ] && _filearch_=armel && sha1sums=('328ea87a2f371163a90b9d7518417e5acbcb2da5' 'c0d5b67ba0a938cef9742568fd09bb2a4b85b513')

but glibc-2.25-7 depends of the arquitecture, so here is the source I used (Its the only archlinuxarm archive I found, if there is an official, please correct me):

source+=("http://tardis.tiny-vps.com/aarm/packages/g/glibc/glibc-2.25-7-armv6h.pkg.tar.xz")
sha1sums+=("1bd5602cebd4393f804128319cceb98244906b05")

Also added this line to package() because ld-linux.so.3 is a reference to a file inside the package which caused troubles at packaging.

rm "${srcdir}"/usr/lib/ld-linux.so.3

Here is the full pkgbuild: https://pastebin.com/r1tNvrad

I know a better solution would be to make a pkgbuild that get the source according to the arquitecture but my knowledge doesnt go that far..

RazZziel commented on 2017-09-13 10:00

:) great, thanks!

Xavion commented on 2017-09-12 23:36

Yes, we can't keep everyone stranded at 'glibc' v2.25 forever. Your latest build files work well here, so I have set them as the default.

Furthermore, I have added you as a co-maintainer of this package for future updates. Thanks again for your assistance. The Arch community is lucky to have people like you.