Package Details: haguichi 1.4.6-1

Git Clone URL: https://aur.archlinux.org/haguichi.git (read-only, click to copy)
Package Base: haguichi
Description: Provides a user friendly GUI to control the Hamachi client on Linux
Upstream URL: https://haguichi.net
Licenses: GPL3
Submitter: lowfatcomputing
Maintainer: ztefn
Last Packager: ztefn
Votes: 43
Popularity: 0.003927
First Submitted: 2015-08-12 21:40 (UTC)
Last Updated: 2023-06-25 13:53 (UTC)

Latest Comments

1 2 3 Next › Last »

jab416171 commented on 2024-05-20 18:43 (UTC) (edited on 2024-05-20 18:55 (UTC) by jab416171)

ztefn: I have that line in my config. however, when I launch haguichi as my user, it just says "disconnected". I've only gotten it to work when running as root (on x11).

I just realized logmein-hamachi wasn't running. I started it, and now haguichi as my user just says "connecting..."

If I launch haguichi while logmein-hamachi is running, then I do get the "configure" screen, however clicking it doesn't seem to do anything.

Ok, forget all of the above. Apparently there was a space after my username in the config. It's working now.

ztefn commented on 2024-05-19 22:49 (UTC) (edited on 2024-05-20 12:08 (UTC) by ztefn)

jab416171: Haguichi is meant to run as normal user:

https://haguichi.net/faq/#why-is-haguichi-asking-me-to-configure-hamachi-before-i-can-connect

By default Hamachi can only be controlled by the root user on your system. To allow other users (such as yourself) to control Hamachi you need to add the line Ipc.User username to the file /var/lib/logmein-hamachi/h2-engine-override.cfg where username is your actual username. If you click the “Configure” button then Haguichi will add this line for you. However you do need to have (root or super user) privileges to be able to do so.

jab416171 commented on 2024-05-19 17:22 (UTC)

The app crashes on startup on wayland when I try to run as root. Does anyone know of a solution? Or is there a way to run the gui as my user?

Authorization required, but no authorization protocol specified
(haguichi:326283): Gtk-WARNING **: 21:09:22.977: cannot open display: :1

ztefn commented on 2020-08-11 18:41 (UTC)

Hamachi is not (yet) compatible with glibc 2.31 which why the daemon is crashing and you need to restart it.

A representative from LogMeIn has stated that an updated Hamachi version for Linux will be released within the next few weeks: https://community.logmein.com/t5/LogMeIn-Hamachi-Discussions/Hamachi-randomly-disconnects-on-Ubuntu-20-04/m-p/223809#M18605

In short, this problem has nothing to do with Haguichi itself.

Santanic commented on 2020-08-11 14:33 (UTC)

I have the same problem as Darwerft and jamesjon

jomocu commented on 2020-01-29 16:54 (UTC)

Any solution for this?

"darwerft: Haguichi asks for your user (not root) password when it needs to start or restart the hamachi daemon. So if this happens at random its a sign the hamachi daemon is constantly crashing on your system."

ztefn commented on 2019-12-06 21:43 (UTC)

darwerft: Haguichi asks for your user (not root) password when it needs to start or restart the hamachi daemon. So if this happens at random its a sign the hamachi daemon is constantly crashing on your system.

darwerft commented on 2019-12-06 10:02 (UTC)

Running latest manjaro and it keeps asking for root password every 5 minutes on avg. at random intervals, sometimes not for an hour, sometimes every few minutes. It stops working until a root password is given then it resumes.

I know of other manjaro users with the same problem.

Otherwise the package works perfectly.

ztefn commented on 2017-09-27 17:51 (UTC)

carstene1ns: No problem, I think I'll be able to handle this by now!