Package Details: lumina-desktop 1.6.2-1

Git Clone URL: https://aur.archlinux.org/lumina-desktop.git (read-only, click to copy)
Package Base: lumina-desktop
Description: A Lightweight QT5 Desktop for FreeBSD
Upstream URL: https://lumina-desktop.org/
Licenses: BSD
Conflicts: insight-fm
Submitter: crossroads1112
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 23
Popularity: 0.014507
First Submitted: 2015-05-10 15:59 (UTC)
Last Updated: 2023-07-12 12:42 (UTC)

Dependencies (15)

Required by (0)

Sources (1)

Latest Comments

1 2 3 Next › Last »

RislaeD commented on 2024-04-09 18:06 (UTC) (edited on 2024-04-09 18:07 (UTC) by RislaeD)

Also requires 'qt5-declarative' (pacman -S qt5-declarative)

rufous commented on 2022-03-02 07:58 (UTC)

Please add ARM to array "arch"

purpleleaf commented on 2021-11-12 21:59 (UTC)

It does not start without dbus.

The lumina-desktop home page reports: "Written in C++/Qt5 and is not based on any existing desktop’s code-base, and does not use any of the Linux-based desktop frameworks (ConsoleKit, PolicyKit, D-Bus, systemd, etc..)"

pavbaranov commented on 2020-02-20 19:45 (UTC)

If somebody wants almost brand new 1.6.0 version - there's: https://github.com/polaur/aur-rebased/tree/master/lumina-desktop

cyrevolt commented on 2018-11-07 14:12 (UTC)

I'd assume that it's an issue with the current version of the Qt libs. I'll see if I can get it to run. I hope v2 is going to be released soon. You could try out the -git release for now.

billypilgrim commented on 2018-11-07 13:32 (UTC)

I've just installed this package but when I try to go into lumina desktop I'm getting a segfault :-(

[ 2117.078181] lumina-desktop[18965]: segfault at 3000a0029 ip 00007f2984a07285 sp 00007fffc976dd70 error 4 in libQt5Widgets.so.5.11.2[7f2984955000+391000

Anyone have any ideas? I'd love to give lumina a whirl

FredBezies commented on 2017-12-09 06:41 (UTC) (edited on 2017-12-09 06:43 (UTC) by FredBezies)

At least there is a newer PKGBUILD. I'm glad I helped a little here :)

1) Please add qt5-svg in depends... At least makedepends one... Or... Bang :(

2) You made a little mistake in my nick : it is FredBezies. Besides of this, no problems :D

pavbaranov commented on 2017-12-06 23:10 (UTC)

@cyrevolt - First it's not neccessary :) Second: I know, that qt5-svg is shown as not needed, but it is. Not needed is lumina.install because all of this job is realised by pacman hooks. Third: I think, that maybe we should add info that using KDE/Qt apps needs another icons like breeze because both icons included in lumina lacks icons required by those apps.

cyrevolt commented on 2017-12-06 22:40 (UTC)

I have just adopted the package, updated the PKGBUILD and added all of you here as contributors. Would you like to be added as a co-maintainer @pavbaranov?

namcap says we don't need qt5-svg: lumina-desktop W: Dependency included and not needed ('qt5-svg')

pavbaranov commented on 2017-12-06 21:17 (UTC)

@colinkeenan - About "install=" - see: https://wiki.archlinux.org/index.php/Pacman#Hooks and https://wiki.archlinux.org/index.php/DeveloperWiki:Pacman_Hooks Yes, problably in my PKGBUILD is missing qt5-svg. As you can see, there is a new version of 1.4.0 with PKGBUILD by FredBezeies I don't think that it's good idea to duplicate DE only because one is only in English and other with translates.