Package Details: maui-shell-git v0.5.0.r31.g7cfc7c8-1

Git Clone URL: https://aur.archlinux.org/maui-shell-git.git (read-only, click to copy)
Package Base: maui-shell-git
Description: Maui Shell is a convergent shell for desktops, tablets, and phones.
Upstream URL: https://github.com/Nitrux/maui-shell
Keywords: cask maui shell zpace
Licenses: GPL3
Conflicts: maui-shell
Provides: maui-shell
Submitter: cniw
Maintainer: cniw
Last Packager: cniw
Votes: 2
Popularity: 0.067833
First Submitted: 2021-12-27 13:07 (UTC)
Last Updated: 2022-06-09 14:55 (UTC)

Latest Comments

cniw commented on 2022-05-28 01:55 (UTC)

@ManuelBoe I've just push new maui-manager-git to AUR and add it to depends list in this commit, You can test it and hopefully no more error.

ManuelBoe commented on 2022-05-27 21:47 (UTC)

The installation fails since the update to version v0.5.0.r26...

it seems that you need the maui-manager package to compile the maui-shell. The problem is that maui-manager is not yet available in AUR for the x86-64 architecture.

cniw commented on 2022-04-24 06:21 (UTC)

@luntik2012 it's seem you have --noconfirm parameter when use pacman/yay/paru/etc. so it don't prompt you a confirmation when it's try to replace mauikit with mauikit-git and decide it to abort automatically. you should remove that option parameter or add this --confirm parameter as well to override previous parameter

--noconfirm
    Bypass any and all “Are you sure?” messages. It’s not a good idea to do this unless you want to run pacman from a script.
--confirm
    Cancels the effects of a previous --noconfirm.

pacman(8) Options

luntik2012 commented on 2022-04-24 05:05 (UTC)

:: Checking for conflicts...
:: Checking for inner conflicts...
 -> Inner conflicts found:
 -> mauikit-git: mauikit
 -> package conflicts can not be resolved with noconfirm, aborting

cniw commented on 2022-04-15 05:54 (UTC)

@greenbeast thanks, just add it in this commit

greenbeast commented on 2022-04-15 00:34 (UTC)

Does this also work for ARM devices? I figured it should since this is supposed to be convergent but the architecture listed is only x86.

cniw commented on 2022-02-25 14:45 (UTC)

@laichiaheng please do reinstall again, that's error caused by massive update in maui-shell repository in this commit but now i was updated the pkgbuild file so hopefully it's works again.

laichiaheng commented on 2022-02-20 05:08 (UTC)

CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find KF5 (missing: DocTools UnitConversion Init) (found version
  "5.91.0")
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/ECM/find-modules/FindKF5.cmake:93 (find_package_handle_standard_args)
  startcask/CMakeLists.txt:1 (find_package)

cniw commented on 2021-12-29 20:42 (UTC)

@hacker12 @jostgrant please do reinstall again, that's error caused by mess up in maui-shell repository in this commit and now it already fixed in this commit

jostgrant commented on 2021-12-29 20:28 (UTC) (edited on 2021-12-29 22:01 (UTC) by jostgrant)

Same issue @hacker12 reported; libcanberra-0.30+2+gc0620e4-5 confirmed to be installed.

Edit: As @cniw pointed out, it's now working; Compiled and ran cask and is running in-instance on my Plasma host-system. TYVM @cniw for the pkgbuild & response! :^)

hacker12 commented on 2021-12-29 17:43 (UTC)

Package does not build as it complains about the audio plugin:

-- Could not set up the appstream test. appstreamcli is missing.
CMake Error: File /home/kacper/.cache/yay/maui-shell-git/src/maui-shell/plugins/audio/CaskAudioConfig.cmake.in does not exist.
CMake Error at /usr/share/cmake/Modules/CMakePackageConfigHelpers.cmake:342 (configure_file):
  configure_file Problem configuring file
Call Stack (most recent call first):
  plugins/audio/CMakeLists.txt:42 (configure_package_config_file)
-- Checking for module 'libpulse'
--   Found libpulse, version 15.0
-- Checking for module 'libpulse-mainloop-glib'
--   Found libpulse-mainloop-glib, version 15.0
CMake Error at plugins/audio/CMakeLists.txt:107 (add_subdirectory):
  The source directory

    /home/kacper/.cache/yay/maui-shell-git/src/maui-shell/plugins/audio/src

  does not contain a CMakeLists.txt file.
-- The following RUNTIME packages have not been found:

 * CanberraPulse, Pulseaudio backend for libcanberra
   Required for volume feedback sounds
 * SoundThemeFreedesktop, The standard freedesktop sound theme, <https://www.freedesktop.org/wiki/Specifications/sound-theme-spec/>
   Required for volume feedback sounds