Package Details: merlin 4.8-1

Git Clone URL: (read-only, click to copy)
Package Base: merlin
Description: Context sensitive completion for OCaml in Vim and Emacs
Upstream URL:
Licenses: MIT
Conflicts: vim-ocaml-merlin-git
Submitter: condy
Maintainer: condy
Last Packager: condy
Votes: 1
Popularity: 0.000000
First Submitted: 2020-02-07 12:39 (UTC)
Last Updated: 2023-03-01 16:23 (UTC)

Latest Comments

FMB commented on 2024-01-08 09:26 (UTC)

Is there something I can do about this? I am using the standard Arch Linux package.

condy commented on 2024-01-07 15:58 (UTC) (edited on 2024-01-07 15:58 (UTC) by condy)


It seems like ocaml is built with no compression support.

dune build --always-show-command-line
3 | include Compression
Error: Unbound module Compression

FMB commented on 2024-01-07 14:35 (UTC)

Apparently menhir should be added as a dependency. Also, it looks like OCaml > 5.0.0 is not supported:

dune build --always-show-command-line
(cd _build/default && /usr/bin/ocamlc.opt -w @1..3@5..28@30..39@43@46..47@49..57@61..62-40 -strict-sequence -strict-formats -short-paths -keep-locs -g -bin-annot -I src/config/.merlin_config.objs/byte -no-alias-deps -opaque -o src/config/.merlin_config.objs/byte/merlin_config.cmo -c -impl src/config/
File "src/config/", line 8, characters 37-49:
8 |   | `OCaml_4_14_0 | `OCaml_5_0_0 ] = `OCaml_5_1_0
Error: This expression has type [> `OCaml_5_1_0 ]
       but an expression was expected of type
         [ `OCaml_4_02_0
         | `OCaml_4_02_1
         | `OCaml_4_02_2
         | `OCaml_4_02_3
         | `OCaml_4_03_0
         | `OCaml_4_04_0
         | `OCaml_4_05_0
         | `OCaml_4_06_0
         | `OCaml_4_07_0
         | `OCaml_4_07_1
         | `OCaml_4_08_0
         | `OCaml_4_09_0
         | `OCaml_4_10_0
         | `OCaml_4_11_0
         | `OCaml_4_12_0
         | `OCaml_4_13_0
         | `OCaml_4_14_0
         | `OCaml_5_0_0 ]
       The second variant type does not allow tag(s) `OCaml_5_1_0

cdfa commented on 2020-06-02 10:05 (UTC)

Ah, of course. I always forget about this issue. Too bad there is no general solution for this yet (at least AFAIK). Thanks for your help :)

condy commented on 2020-05-31 16:55 (UTC)


Re-installing/compiling ocaml-yojson is the solution.

cdfa commented on 2020-05-31 16:16 (UTC)

Hi, since 3.3.4-1, I'm getting the following error:

==> Starting build()...
      ocamlc src/utils/.merlin_utils.objs/byte/std.{cmi,cmo,cmt} (exit 2)
(cd _build/default && /bin/ocamlc.opt -w -40 -g -bin-annot -I src/utils/.merlin_utils.objs/byte -I /usr/lib/ocaml/yojson -no-alias-deps -o src/utils/.merlin_utils.objs/byte/std.cmo -c -impl src/utils/
File "src/utils/", line 1:
Error: /usr/lib/ocaml/yojson/yojson.cmi
       is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
==> ERROR: A failure occurred in build().

My dune version is 2.3.1. I do have an OCaml project I'm working on on this machine, also using dune, but I don't think that should conflict)