Package Details: min 1.32.1-1

Git Clone URL: https://aur.archlinux.org/min.git (read-only, click to copy)
Package Base: min
Description: A fast, minimal browser that protects your privacy
Upstream URL: https://minbrowser.org
Licenses: Apache-2.0
Submitter: arojas
Maintainer: mhdi
Last Packager: mhdi
Votes: 5
Popularity: 0.042156
First Submitted: 2023-04-01 09:53 (UTC)
Last Updated: 2024-06-08 09:08 (UTC)

Latest Comments

loserMcloser commented on 2024-05-20 01:36 (UTC) (edited on 2024-05-20 01:36 (UTC) by loserMcloser)

I'm not an expert at packaging electron apps, but here's a PKGBUILD for v1.32.1 against electron29.

new PKGBUILD
new min.js
min.sh

adrs commented on 2024-04-08 10:36 (UTC)

dear WSDMatty , kindly ask You to update min browser as release 1.31.2 is the latest dated Feb,23,2024.

Thank You in advance.

3xploiton3 commented on 2024-03-01 09:21 (UTC)

/usr/lib/electron29/electron[17799]: ../../third_party/electron_node/src/node_builtins.cc:328:MaybeLocal<Function> node::builtins::BuiltinLoader::LookupAndCompileInternal(Local<Context>, const char *, std::vector<Local<String>> *, Realm *): Assertion `(this) == (optional_realm->env()->builtin_loader())' failed.
 1: 0x5d10c068ad46  [/usr/lib/electron29/electron /usr/lib/min-browser/app]
 2: 0x5d10c068a9cd  [/usr/lib/electron29/electron /usr/lib/min-browser/app]
 3: 0x5d10c0667e98  [/usr/lib/electron29/electron /usr/lib/min-browser/app]
 4: 0x5d10af32a471  [/usr/lib/electron29/electron /usr/lib/min-browser/app]
 5: 0x5d10af326f75  [/usr/lib/electron29/electron /usr/lib/min-browser/app]
 6: 0x5d10c07621a2  [/usr/lib/electron29/electron /usr/lib/min-browser/app]
 7: 0x5d10b45e1fc7  [/usr/lib/electron29/electron /usr/lib/min-browser/app]
Received signal 6
#0 0x5d10b8cafa13 (/usr/lib/electron29/electron+0xe66da12)
#1 0x5d10b8c8b354 (/usr/lib/electron29/electron+0xe649353)
#2 0x5d10b8caf32b (/usr/lib/electron29/electron+0xe66d32a)
#3 0x75566681b770 (/usr/lib/libc.so.6+0x3c76f)
#4 0x75566686c32c (/usr/lib/libc.so.6+0x8d32b)
#5 0x75566681b6c8 gsignal
#6 0x7556668034b8 abort
#7 0x5d10c068ad55 (/usr/lib/electron29/electron+0x16048d54)
#8 0x5d10c068a9cd (/usr/lib/electron29/electron+0x160489cc)
#9 0x5d10c0667e98 (/usr/lib/electron29/electron+0x16025e97)
#10 0x5d10af32a471 (/usr/lib/electron29/electron+0x4ce8470)
#11 0x5d10af326f75 (/usr/lib/electron29/electron+0x4ce4f74)
#12 0x5d10c07621a2 (/usr/lib/electron29/electron+0x161201a1)
#13 0x5d10b45e1fc7 (/usr/lib/electron29/electron+0x9f9ffc6)
  r8: 0000000000000000  r9: 0000000000000001 r10: 0000000000000008 r11: 0000000000000246
 r12: 0000112000094000 r13: 0000000000000006 r14: 00007556669b86a0 r15: 00001120003de918
  di: 0000000000004587  si: 0000000000004587  bp: 00007556630e8940  bx: 0000000000004587
  dx: 0000000000000006  ax: 0000000000000000  cx: 000075566686c32c  sp: 00007ffdc389d3a0
  ip: 000075566686c32c efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
[1]    17799 IOT instruction (core dumped)  min-browser

YukiElectronics commented on 2023-07-08 21:39 (UTC)

I agree with walkingstickfan, renaming the package to min-browser would be nice.

I also can't help but notice the electron version being incorrect, as min's package.js indicates electron24 ("electronVersion": "24.5.0")

Finally, and this is just personal preference, I think changing the upstream URL to the GitHub repo would make more sense. Just a thought :)

walkingstickfan commented on 2023-06-19 04:38 (UTC) (edited on 2023-06-19 04:39 (UTC) by walkingstickfan)

It would be nice if the package could be renamed to min-browser. Performing commands like yay -Ss min returns too much flotsam.

walkingstickfan commented on 2023-06-19 04:31 (UTC) (edited on 2023-06-19 06:16 (UTC) by walkingstickfan)

Attempted to perform a system update a few minutes ago and received the following error:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (1:25-1) breaks dependency 'electron22' required by min

Update: Issue resolved by removing min installed from the Arch repos, performing a system update, and then installing the AUR version.

loserMcloser commented on 2023-05-10 14:43 (UTC)

No longer in community?