Package Details: mono-addins-git 1.3.3-1

Git Clone URL: https://aur.archlinux.org/mono-addins-git.git (read-only)
Package Base: mono-addins-git
Description: Generic framework for creating extensible applications, and for creating add-ins which extend those applications.
Upstream URL: https://github.com/mono/mono-addins
Licenses: MIT
Provides: mono-addins
Submitter: mrAppleXZ
Maintainer: FryDay
Last Packager: FryDay
Votes: 5
Popularity: 0.000042
First Submitted: 2016-07-27 12:24
Last Updated: 2017-11-07 16:09

Required by (14)

Sources (1)

Latest Comments

FryDay commented on 2017-12-08 14:01

Sounds good. I'm going to hold off for a little bit then and see if either the official repo gets updated and if not I'll start looking into using mono-git. Thanks for bringing all of this to my attention!

poikilos commented on 2017-12-08 02:30

I would think that would be caused by msbuild-stable needing a later version-- the may need to bump up the mono version in their dependencies. Official arch package of mono is flagged outdated (5.0.0.100-2). I made a suggestion on msbuild-stable. There is some work being done to resolve build errors for mono-git so that's something to consider too: (fix is being merged for) SIGABORT during make: https://github.com/mono/mono/issues/6197 and then there is "...assumes default python is python 2": https://github.com/mono/mono/issues/6204

FryDay commented on 2017-12-05 15:14

@axlemedia: msbuild-stable builds fine, but try using it. It throws errors with the official mono.

FryDay commented on 2017-12-04 16:29

I have no issue updating the dependency, but currently msbuild-stable appears to be broken. I experience the same issues as the comments here https://aur.archlinux.org/packages/msbuild-stable/

I'm not sure I want to force people to install mono-git to get this to work but that may be the solution?

poikilos commented on 2017-12-04 16:01

FryDay, please change dependency from msbuild-bin (flagged outdated) to msbuild-stable as per https://aur.archlinux.org/packages/msbuild-bin/ (maybe leave msbuild-bin as alternative?) -- msbuild-stable provides /usr/bin/msbuild (a script which calls /usr/lib/mono/msbuild/15.0/bin/MSBuild.dll) instead of msbuild.exe though, so that will have to be changed in PKGBUILD as well (maybe have a variable to store path to msbuild and boolean to store whether msbuild is a binary or assembly; or just have a different case if the script /usr/bin/msbuild exists).

FryDay commented on 2017-11-07 16:09

This should be all fixed up now. Let me know if you have any issues.

malah commented on 2017-06-22 22:18

Hello, the package seems to be break, many files have been deleted on the git repository as autogen.sh & makefile ...

I've tried to manually update it with the 1.3.3 release but it seems we can't compile it, I got this error: https://github.com/mono/mono-addins/issues/73 or https://github.com/mono/mono-addins/issues/70

If someone has an idea?

targodan commented on 2016-12-04 16:43

I have extra/mono-addins installed already and want to substitute with this package. Upon installing I get tons of file conflicts.
Please add `conflicts=('mono-addins')` to the PKGBUILD, so that pacman knows about the conflict and can ask us if we want to remove mono-addins first.