Package Details: mopidy-iris 3.64.0-1

Git Clone URL: https://aur.archlinux.org/mopidy-iris.git (read-only, click to copy)
Package Base: mopidy-iris
Description: A Mopidy Web client that utilizes the Spotify and EchoNest frameworks. (Formerly Spotmop)
Upstream URL: https://github.com/jaedb/iris
Licenses: Apache
Submitter: MarcinWieczorek
Maintainer: MarcinWieczorek (phijor)
Last Packager: phijor
Votes: 19
Popularity: 0.000089
First Submitted: 2017-01-05 00:05 (UTC)
Last Updated: 2022-06-27 10:10 (UTC)

Dependencies (7)

Required by (0)

Sources (1)

Latest Comments

MarcinWieczorek commented on 2022-03-11 10:37 (UTC)

That's cool. I added you as a co

phijor commented on 2022-03-11 10:35 (UTC)

Oh sorry, I probably did not properly clean my build directory. I thought the source tarball renamed the directory.

I would be happy to co-maintain the package though :)

MarcinWieczorek commented on 2022-03-11 09:18 (UTC)

@phijor thank you for the contribution, but changing the path in cd was not a valid change. Let me know if you're interested in co-maintaining.

phijor commented on 2022-03-10 14:11 (UTC)

I updated the PKGBUILD to build version 3.62.0, would you mind integrating these changes?

You can find the patch here.

MarcinWieczorek commented on 2021-02-26 06:08 (UTC)

Hey guys, I've come up with a solution. The build routine is the same, but the tarball comes from pypi. It should be as fresh as a wheel, right? Please verify latest version and let me know what you think.

MarcinWieczorek commented on 2021-02-14 10:26 (UTC)

I think we should. I'll try to find some time to do that. If you've got a patch ready I'll just push it.

djmattyg007 commented on 2021-02-13 23:37 (UTC)

It's been a month. Can we just switch to PyPI for release tarballs so we can get the latest version?

MarcinWieczorek commented on 2021-01-14 11:46 (UTC)

This package builds from source. pypi PKGBUILD is somewhere in the git history if you want to update it locally. I'll wait for github release, there's rarely big difference in release dates. I'll contact upstream.

robertfoster commented on 2021-01-14 11:02 (UTC)

3.55.4 is out. Pypi seems more updated at least for releases archives

djmattyg007 commented on 2020-12-02 12:46 (UTC)

Could you please bump the pkgrel to force a rebuild for python3.9?

MarcinWieczorek commented on 2020-07-26 13:47 (UTC)

Well I suppose you could use iris without spotify, but does it really have any sense? jeadb/Iris says it's optional.

ruuda commented on 2020-07-26 13:44 (UTC)

The mopidy-spotify dependency could be optional. It is unavailable on ARM, so I removed the dependency from the PKGBUILD, and then the package builds and works fine without further modifications.

MarcinWieczorek commented on 2020-07-11 13:13 (UTC)

I should've noticed that, thanks. Should mopidy-local be an opt-depend?

djmattyg007 commented on 2020-07-11 02:44 (UTC)

@MarcinWieczorek you should also remove the dependency on mopidy-local-sqlite, as it was also rolled into mopidy-local.

MarcinWieczorek commented on 2020-07-10 13:06 (UTC)

@djmattyg007 done. I didn't bump the pkgrel as I think there's no point. Thanks!

djmattyg007 commented on 2020-07-09 11:59 (UTC)

Any chance you could update the dependency on mopidy-local-images to point to mopidy-local? The former has been replaced by the latter, and it would make life easier for those using AUR helpers like aurutils.

fmauNeko commented on 2020-01-30 08:41 (UTC)

Mopidy-Iris 3.44.0 has been released on GitHub today, with support for Mopidy 3. It is not yet released on PyPI tho, but I guess it should be done soon!

MarcinWieczorek commented on 2019-12-30 19:57 (UTC)

We're waiting for upstream fix! Don't update mopidy if you want iris to keep working! Thanks for patience :)

tophost commented on 2019-11-19 13:52 (UTC)

Just downgrade Tornado as @MarcinWiezorek said. Example: sudo pip2 install tornado==4.5.3

denis_oster commented on 2019-03-31 09:31 (UTC) (edited on 2019-03-31 09:33 (UTC) by denis_oster)

http://localhost:6680/iris
404: Not Found
How to solve a problem?

MarcinWieczorek commented on 2018-10-02 07:18 (UTC)

Downgrade Tornado, that's what I did.

runical commented on 2018-10-01 11:53 (UTC)

Is it possible to make this package work somehow? It's been non-functional for quite a while because of the Tornado update.

prior commented on 2018-08-07 05:50 (UTC)

Since yesterday this is no longer starting as "tornado 5.1" is installed, but mopidy-iris depends on "tornado<5":

"Disabled extension iris: tornado<5.0,>=3.2 required, but found tornado 5.1 at /usr/lib/python2.7/site-package".

MarcinWieczorek commented on 2017-09-15 22:15 (UTC)

It is still required. Iris shows an error if it is not present.

hamster commented on 2017-09-14 08:10 (UTC)

The mopidy-spotify package is no longer required, as I can see in dependencies from pip.

bjo commented on 2017-01-18 09:32 (UTC)

Others have also the 404-problem with this PKGBUILD, see https://github.com/jaedb/Iris/issues/39

bjo commented on 2017-01-13 14:09 (UTC)

Thanks for updating to iris! I get a 404 when accessing http://<mopidyip>:6680/iris/

MarcinWieczorek commented on 2017-01-07 15:29 (UTC)

I have renamed it and put the old name in the description so it's easy to find. I've filled a merge request already.

bjo commented on 2017-01-07 08:38 (UTC)

I think renaming would be a good idea.

MarcinWieczorek commented on 2017-01-04 23:11 (UTC)

So this has been renamed to iris. What do you guys think should be done about that? Leave it as it is or rename to (preferably) mopidy-iris?

jan.dietrich commented on 2016-11-08 10:58 (UTC)

Spotmop is not showing up since some versions ago. Did I miss something? I can't access through the mopidy http server

commented on 2016-10-16 04:08 (UTC)

updated mopidy-local-images so installing with AUR helpers should work fine now. might want to add mopidy-local-sqlite as an optional dependency since it adds local library support.

MarcinWieczorek commented on 2016-10-09 00:14 (UTC)

Thanks! It will be updated tomorrow (depends where you live)

commented on 2016-10-08 23:47 (UTC)

new version needs spotipy

commented on 2016-09-10 02:06 (UTC)

thank you for the update. however, it seems that mopidy-local-images is now a dependency of the package, and spotmop will not start without the package. edit: it looks like mopidy-local-images must also be >= 1.0.0, as it doesn't work with the current version on AUR. i've flagged the package out of date, but until then the PKGBUILD can be edited by simply changing the version number (and the md5sum to the new sum or 'SKIP') by the user to fix this issue.

commented on 2016-09-07 01:32 (UTC)

please update to 2.9.1

frangio commented on 2016-08-20 21:23 (UTC) (edited on 2016-08-20 21:23 (UTC) by frangio)

python2-configobj dependency is still missing! The extension doesn't work without that package.

MarcinWieczorek commented on 2016-07-14 09:31 (UTC)

Yeah thanks. The tarballs are accessible for me (I think), but github is always more reliable.

commented on 2016-07-14 06:54 (UTC)

try this new PKGBUILD: https://ghostbin.com/paste/rhxty/raw

commented on 2016-07-14 06:45 (UTC)

it seems you might have to switch to github for the package source, the pypi tars are still probably accessible but not using the URL format you have now.

commented on 2016-07-05 04:44 (UTC)

please disown the package if it is no longer being maintained

j0s commented on 2016-01-27 01:29 (UTC)

Please add python2-configobj to dependencies, otherwise I got "INFO Disabled extension spotmop: Dependency The 'ConfigObj' distribution was not found and is required by the application not found" in the log.