Package Details: movim v0.17.1.92ddd9e71-1

Git Clone URL: https://aur.archlinux.org/movim.git (read-only, click to copy)
Package Base: movim
Description: Movim is a decentralized social network, written in PHP and HTML5 and based on the XMPP standard protocol.
Upstream URL: https://movim.eu
Keywords: im web xmpp
Licenses: AGPL3
Provides: movim
Submitter: Ppjet6
Maintainer: None
Last Packager: PolarianDev
Votes: 4
Popularity: 0.000068
First Submitted: 2016-11-05 02:49 (UTC)
Last Updated: 2022-12-05 15:03 (UTC)

Dependencies (12)

Required by (0)

Sources (5)

Latest Comments

1 2 Next › Last »

PolarianDev commented on 2023-03-31 20:51 (UTC)

dotenv has been released yesterday in the new update, I can now proceed with updating the package, and hopefully it will work!

PolarianDev commented on 2023-03-14 08:07 (UTC)

Awaiting dotenv update to be released, then this will be bumped (otherwise the rewrite would be worthless).

PolarianDev commented on 2023-02-24 00:48 (UTC)

Movim is finally getting updated, I have taken a long time to do this as I have been busy, but please check the following PR for the progress of the update to version 0.20 (latest stable version):

https://onedev.polarian.dev/polarrepo/movim/~pulls/1

PolarianDev commented on 2023-02-24 00:47 (UTC)

If you have any issues with the package, please submit an issue on the following repository:

https://onedev.polarian.dev/polarrepo/movim

It will be easier to manage than commenting on the AUR

PolarianDev commented on 2023-01-24 08:34 (UTC)

I am happy to give the package up to anyone who is willing to maintain it, but considering it was orphaned for over 1 year before I adopted it, I doubt anyone is willing to maintain it.

Ppjet6 (pep.) feel free to message me on XMPP if you would like the package back, or if you want to be added as a co-maintainer.

PolarianDev commented on 2023-01-24 08:31 (UTC)

Hello Antiz,

I will fix the maintainer flag, this was a mistake made on my part (movim was the first Arch Package I adopted/made, so I was bound to make mistakes).

As for all the other issues, these were not done by me, these were done by Ppjet6, I am aware of most of these issues and I will be fixing them, but the bad installation issue is more important right now, the package must at least be functional.

See the pinned comment, this still applies, I have not forgot about this package , I just have been too busy to continue progress on it as of right now.

Antiz commented on 2023-01-24 08:05 (UTC) (edited on 2023-01-24 08:29 (UTC) by Antiz)

Hi,

Here are a list of improvements for the PKGBUILD:
- The former maintainer should be listed as a "Contributor", not "Former-Maintainer" [1]
- There's no need to define _pkgbase as it is equal to the pkgname (which is already done implicitly) [2]
- The pkgver var should not contain the "v" prefix [3]. Also, since this package isn't a VCS package, I wouldn't add the commit code to it nor the pkgver() function since they have no purposes (except potentially trigger useless updates for the end users). Finally, by reading the PKGBUILD, it looks like the pkgver var is actually not used (other than in the pkgver() function). Personally, I would get rid of the _tagname var and replace it by the pkgver var like so: pkgver=0.17.1
- pkgdesc should not include the package name in a self-referencing way [4]. You could stick to the github repo description: "Decentralized social platform"
- The arch array should not be equal to "any" as this is reserved for architecture-independent packages which this package is not (it contains compiled code) [5]. You would need to list all supported architectures.
- There's no need to define provides as it is equal to the pkgname (which is already done implicitly) [6].
- The source should be renamed using a non conflicting name [7]. For instance: ${pkgname}-${pkgver}::git+[...]
- There's no need specifying the "$scrdir" var in the cd and install commands since "cd" into the "$srcdir" is always implicitly done in functions. You could get rid of them like so:

package() {
  cd "$_pkgbase"

  # Systemd files
  install -m755 -d "$pkgdir/etc/default"
  install -Dm640 "movim.env" "$pkgdir/etc/default/$_pkgbase"
  [...]

[1] https://wiki.archlinux.org/title/AUR_submission_guidelines#Rules_of_submission
[2] https://wiki.archlinux.org/title/PKGBUILD#pkgbase
[3] https://wiki.archlinux.org/title/VCS_package_guidelines#Git (I know this is for VCS packages but afaik it applies to regular packages as well).
[4] https://wiki.archlinux.org/title/PKGBUILD#pkgdesc
[5] https://wiki.archlinux.org/title/PKGBUILD#arch
[6] https://wiki.archlinux.org/title/PKGBUILD#provides
[7] https://wiki.archlinux.org/title/PKGBUILD#source

On a side note, as raised by @Tio, this package does not currently build correctly.

I hope this helps :)

PolarianDev commented on 2022-12-14 08:36 (UTC)

For anyone who is still interested in this package,

I have been busy and haven't yet updated the package to v0.20, it is in progress and will be finished shortly, there is just a few issues which need to be fixed before I can push the new package.

Sorry for the delay.

PolarianDev commented on 2022-12-05 01:33 (UTC)

Hello world,

I have now adopted this package due to the package being unmaintained for over a year. I will be updating it to the latest version of movim.

Polarian

Tio commented on 2020-12-26 02:33 (UTC)

I get this error on Manjaro:

You are using the deprecated option "--no-suggest". It has no effect and will break in Composer 3.
Installing dependencies from lock file
Verifying lock file contents can be installed on current platform.
Your lock file does not contain a compatible set of packages. Please run composer update.

  Problem 1
    - Root composer.json requires PHP extension ext-gd * but it is missing from your system. Install or enable PHP's gd extension.
  Problem 2
    - Root composer.json requires PHP extension ext-imagick * but it is missing from your system. Install or enable PHP's imagick extension.
  Problem 3
    - wikimedia/composer-merge-plugin is locked to version v1.4.1 and an update of this package was not requested.
    - wikimedia/composer-merge-plugin v1.4.1 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.

To enable extensions, verify that they are enabled in your .ini files:
    - /etc/php/php.ini
    - /etc/php/conf.d/imagick.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.
==> ERROR: A failure occurred in build().
    Aborting...