Package Details: mumble-git 2019.04.09-1

Git Clone URL: https://aur.archlinux.org/mumble-git.git (read-only)
Package Base: mumble-git
Description: A voice chat application similar to TeamSpeak
Upstream URL: https://www.mumble.info/
Keywords: audio communication multimedia network voip
Licenses: BSD
Conflicts: mumble
Provides: mumble
Submitter: None
Maintainer: Radioactiveman
Last Packager: Radioactiveman
Votes: 49
Popularity: 0.008313
First Submitted: 2009-05-30 19:46
Last Updated: 2019-04-11 16:34

Required by (4)

Sources (6)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

linkmauve commented on 2015-11-05 22:03

Hi, it seems the libxkbcommon-x11 isn’t required to run this program, and is already suggested by qt5-base, it should either be dropped or at least set as an optional dependency, as it is only required for X11 support.

resuni commented on 2015-09-26 02:04

I encountered a problem that may or may not be specific to this AUR package.

The main Mumble window containing the channel list and chat and everything will not show up when Mumble is launched. It will only show up on the initial launch when the Mumble audio wizard also comes up. All that is launched is the Mumble system tray icon, which is pretty useless other than muting yourself, deafening yourself, and quitting Mumble.

Here is how I fixed it:

1. You must get Mumble to prompt you with the audio setup wizard again. To do so, delete the configuration file at ~/.config/Mumble/Mumble.conf (this will reset anything you configured in the audio setup wizard, which you must complete again)

2. Cancel out of the channel list to make the main Mumble window accessible. Go to Configure -> Settings. Go into the "User Interface" section. Change "Theme" to "None". Personally, I also disable "Hide in tray when minimized" because this will cause a similiar problem where the window will disappear when switching workspaces.

3. Click "OK" and re-launch Mumble to test.

I've so far only had this problem when building from this AUR package, but this is also the first time I've seen Mumble try to run with a theme. I assume this is a more likely with Mumble's relatively new theme feature than however the AUR package builds.

cookiecaper commented on 2015-05-14 02:42

FYI, upon completely removing /tmp/makepkg/mumble-git and rebuilding, the error listed below has been rectified. I can now build successfully. Unsure what happened to the tree before, but completely removing it and calling the build again fixed the problem.

cookiecaper commented on 2015-05-13 18:58

#########################################################################
# ARCHITECTURE, COMPILE FLAGS
#########################################################################
#
CARCH="x86_64"
CHOST="x86_64-unknown-linux-gnu"

#-- Compiler and Linker Flags
# -march (or -mcpu) builds exclusively for an architecture
# -mtune optimizes for an architecture, but builds for whole processor family
CPPFLAGS="-D_FORTIFY_SOURCE=2"
CFLAGS="-march=x86-64 -mtune=native -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -funroll-loops -funit-at-a-time"
CXXFLAGS="-march=x86-64 -mtune=native -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -funroll-loops -funit-at-a-time"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro"
#-- Make Flags: change this for DistCC/SMP systems
MAKEFLAGS="-j9"
#-- Debugging flags
DEBUG_CFLAGS="-g -fvar-tracking-assignments"
DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"

Naypam commented on 2015-05-13 08:26

Out of interest cookiecaper what are your makeflags in /etc/makepkg.conf?

I have "MAKEFLAGS="-j5" as I have a quad core processor?
But it seems like your CFLAGS may be messed up too?

cookiecaper commented on 2015-05-13 05:16

Failing here.

g++ -c -include release/mumble -pipe -Wfatal-errors -fvisibility=hidden -Wshadow -Woverloaded-virtual -Wold-style-cast -Wconversion -Wsign-compare -Wall -Wextra -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -Wall -W -D_REENTRANT -fPIC -DPLUGIN_PATH=/usr/lib/mumble -DRESTRICT=__restrict__ -D_FORTIFY_SOURCE=2 -DMUMBLE_VERSION_STRING=1.3.0 -DMUMBLE_VERSION=1.3.0 -DMUMBLE -DNO_CRASH_REPORT -DUSE_OPUS -DUSE_NO_TTS -DUSE_ALSA -DUSE_OSS -DUSE_PULSEAUDIO -DUSE_BONJOUR -DUSE_DBUS -DNO_UPDATE_CHECK -D_REENTRANT -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_DBUS_LIB -DQT_CORE_LIB -I. -I../../src -I. -I../bonjour -I../../3rdparty/celt-0.7.0-src/libcelt -I/usr/lib/oss/include -isystem /usr/include/opus -isystem /usr/include/alsa -isystem /usr/include/avahi-compat-libdns_sd -isystem /usr/include/qt -isystem /usr/include/qt/QtSvg -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtNetwork -isystem /usr/include/qt/QtSql -isystem /usr/include/qt/QtXml -isystem /usr/include/qt/QtDBus -isystem /usr/include/qt/QtCore -Irelease -I. -I/usr/lib/qt/mkspecs/linux-g++ -o release/SocketRPC.o SocketRPC.cpp
In file included from <command-line>:0:0:
/usr/include/stdc-predef.h:59:1: error: one or more PCH files were found, but they were invalid
#endif
^
compilation terminated due to -Wfatal-errors.
In file included from <command-line>:0:0:
/usr/include/stdc-predef.h:59:1: error: one or more PCH files were found, but they were invalid
#endif
^
compilation terminated due to -Wfatal-errors.
In file included from <command-line>:0:0:
/usr/include/stdc-predef.h:59:1: error: one or more PCH files were found, but they were invalid
#endif
^
compilation terminated due to -Wfatal-errors.
Makefile.Release:2642: recipe for target 'release/ConnectDialog.o' failed
make[2]: *** [release/ConnectDialog.o] Error 1
make[2]: *** Waiting for unfinished jobs....
Makefile.Release:3155: recipe for target 'release/Overlay.o' failed
make[2]: *** [release/Overlay.o] Error 1
Makefile.Release:3604: recipe for target 'release/SocketRPC.o' failed
make[2]: *** [release/SocketRPC.o] Error 1
make[2]: Leaving directory '/tmp/makepkg/mumble-git/src/mumble/src/mumble'
Makefile:38: recipe for target 'release' failed
make[1]: *** [release] Error 2
make[1]: Leaving directory '/tmp/makepkg/mumble-git/src/mumble/src/mumble'
Makefile:602: recipe for target 'sub-src-mumble-release_ordered' failed
make: *** [sub-src-mumble-release_ordered] Error 2

Not sure if my mirror just hasn't synced some QT changes or what.

Radioactiveman commented on 2015-05-12 21:16

Why do you think this is needed? All four cores of my CPU are used while compiling Mumble.

Naypam commented on 2015-05-11 22:49

Just wondering if you might add ${MAKEFLAGS} to the make line?

Radioactiveman commented on 2015-05-10 21:27

Thanks for the info, Qt5 is now used.

madmaurice commented on 2015-05-10 18:53

Throws an error that QT4 wont be supported any longer. Either you add a CONFIG flag to use qt4 or compile it with qt5.

i replaced qmake-qt4 with qmake-qt5 in my local PKGBUILD and it built without errors. Not sure though which qt5 packages are required to build as i have the whole qt5 group installed.