Package Details: mycli 1.22.1-1

Git Clone URL: https://aur.archlinux.org/mycli.git (read-only, click to copy)
Package Base: mycli
Description: A Terminal Client for MySQL with AutoCompletion and Syntax Highlighting
Upstream URL: https://github.com/dbcli/mycli
Keywords: cli mariadb mysql
Licenses: BSD
Submitter: aabmass
Maintainer: loonies
Last Packager: loonies
Votes: 26
Popularity: 0.052038
First Submitted: 2015-08-05 15:33
Last Updated: 2020-08-01 15:37

Pinned Comments

loonies commented on 2019-12-06 11:43

Prior to flagging the package out-of-date or reporting build errors please:

  • Make sure that your system is up-to-date (pacman -Syu)
  • Rebuild and reinstall dependencies (especially ones from AUR)
  • Rebuild and reinstall the package

Do not expect AUR packages to trigger rebuild or suggest bumping "pkgrel" number. This is expected behaviour and the way Arch packing is designed to work.

For more information read the official documentation and man pages.

Latest Comments

1 2 3 4 Next › Last »

mgrimes commented on 2020-07-22 16:02

It seems mycli isn't compatible with pymysql v0.10.0. Needs the following patch:

diff -aur a/sqlexecute.py b/sqlexecute.py
--- a/sqlexecute.py     2020-07-22 12:01:23.355002581 -0400
+++ b/sqlexecute.py     2020-07-22 11:59:50.394800925 -0400
@@ -3,7 +3,7 @@
 import sqlparse
 from .packages import special
 from pymysql.constants import FIELD_TYPE
-from pymysql.converters import (convert_mysql_datetime, convert_datetime,
+from pymysql.converters import (convert_datetime,
                                 convert_timedelta, convert_date, conversions,
                                 decoders)
 try:
@@ -99,7 +99,7 @@
         )
         conv = conversions.copy()
         conv.update({
-            FIELD_TYPE.TIMESTAMP: lambda obj: (convert_mysql_datetime(obj) or obj),
+            FIELD_TYPE.TIMESTAMP: lambda obj: (convert_datetime(obj) or obj),
             FIELD_TYPE.DATETIME: lambda obj: (convert_datetime(obj) or obj),
             FIELD_TYPE.TIME: lambda obj: (convert_timedelta(obj) or obj),
             FIELD_TYPE.DATE: lambda obj: (convert_date(obj) or obj),

mercutio commented on 2020-04-29 10:52

I patched the setup.py to allow for prompt_toolkit 3, the library seems to be compatible with that version without an issue: https://gist.github.com/mercutiodesign/8b341a5ca955d62bcb69ce21274f9e23

Chacal_E commented on 2020-04-29 01:19

for those with difficulties, you can download python-prompt_toolkit-2.0.9-1-any.pkg.tar.xz from https://archive.archlinux.org/packages/p/python-prompt_toolkit/ and then use the command pacman -U python-prompt_toolkit-2.0.9-1-any.pkg.tar.xz as root.

note: when upgrading programs, if you update python-prompt_toolkit, you have to downgrade again.

lotia commented on 2020-04-28 17:01

Thanks for maintaining this package.

Currently, the installation of 1.21.1-1 is failing with the following error:

==> Error: Could not find all required packages:
    python-prompt_toolkit<3.0.0 (Wanted by: mycli)

loonies commented on 2019-12-06 11:43

Prior to flagging the package out-of-date or reporting build errors please:

  • Make sure that your system is up-to-date (pacman -Syu)
  • Rebuild and reinstall dependencies (especially ones from AUR)
  • Rebuild and reinstall the package

Do not expect AUR packages to trigger rebuild or suggest bumping "pkgrel" number. This is expected behaviour and the way Arch packing is designed to work.

For more information read the official documentation and man pages.

loonies commented on 2019-12-06 11:42

@deconf Sorry for late response. Try to rebuild python-cli_helpers, python-pymysql, and mycli. This was the minimum required for my mycli installation to start working again after Python 3.8 upgrade.

ccxex29 commented on 2019-12-04 12:16

@deconf I had this problem as well. This is a known problem with AUR updates. If what the python said is sqlparse, then take a look at the dependency list. There is python-sqlparse. Since this is also an AUR package, you need to clean install python-sqlparse.

deconf commented on 2019-11-28 09:54

@loonies Of course, below is my error message using mycli

pkg_resources.Context ual Version Conflict:
 (sqlparse 0.2.4 (/usr/lib/python3.8/site-packages), Requirement.parse('sqlparse<0.4.0,>=0.3.0'), {'mycli'})

pkg_resources.DistributionNotFound: The 'sqlparse<0.4.0,>=0.3.0' distribution was not found and is required by mycli

loonies commented on 2019-11-27 18:06

@deconf Can you be more specific?

deconf commented on 2019-11-27 11:17

@loonies How do I fix if the upgrade breaks dependencies?