Package Details: nethack-qt 3.6.6-1

Git Clone URL: https://aur.archlinux.org/nethack-qt.git (read-only, click to copy)
Package Base: nethack-qt
Description: A single player dungeon exploration game
Upstream URL: http://www.nethack.org/index.html
Licenses: custom
Submitter: None
Maintainer: fsnuker
Last Packager: fsnuker
Votes: 5
Popularity: 0.023204
First Submitted: 2008-10-02 11:28 (UTC)
Last Updated: 2020-11-23 22:24 (UTC)

Latest Comments

1 2 Next › Last »

Wild_Penguin commented on 2023-12-05 18:26 (UTC)

Actually, it would make sense to add nethack-x11 top conflicts, too =).

Provides would be a bit too much since nethack provides other UIs currently, and some (hypothetical or real?) package could use the plain nethack UI. But these packages can not co-exists as it stands.

Wild_Penguin commented on 2023-12-05 18:16 (UTC)

The 3.6.6 version does not compile on current Arch. The 3.6.7 does compile with a little changes to the PKGBUILD. I believe conflict for regular nethack should be added; but I'm not sure about provided -field. It could be added, if the binary supports other UIs.

--- PKGBUILD.old        2023-12-05 20:15:08.155752028 +0200
+++ PKGBUILD    2023-12-05 20:10:06.995174046 +0200
@@ -7,7 +7,7 @@

 pkgname=nethack-qt
 _pkgname=nethack
-pkgver=3.6.6
+pkgver=3.6.7
 pkgrel=1
 pkgdesc='A single player dungeon exploration game'
 arch=('i686' 'x86_64')
@@ -15,14 +15,17 @@
 license=('custom')
 depends=('gzip' 'ncurses' 'qt5-base' 'qt5-multimedia' 'libxaw' 'libxt' 'libx11')
 makedepends=('xorg-mkfontscale' 'xorg-bdftopcf')
+conflicts=('nethack')
+provides=('nethack')
 # 'libxmu' 'libxext'
 source=("https://nethack.org/download/${pkgver}/${_pkgname}-${pkgver//.}-src.tgz")
-md5sums=('6c9a75f556d24c66801d74d8727a602e')
+md5sums=('eef55cf2d94f637386bf9beefdbe44dc')
+_srchome=NetHack-${pkgver}


 prepare() {
   #cd "$_pkgname-$pkgver/"
-  cd NetHack-NetHack-${pkgver}_Released
+  cd $_srchome

   sed -e 's|^/\* \(#define LINUX\) \*/|\1|' \
       -e 's|^/\* \(#define TIMED_DELAY\) \*/|\1|'\
@@ -51,17 +54,17 @@

 build(){
   #cd "$_pkgname-$pkgver/sys/unix"
-  cd NetHack-NetHack-${pkgver}_Released/sys/unix
+  cd $_srchome/sys/unix
   sh setup.sh hints/linux-qt5

   #cd "$_pkgname-$pkgver"
-  cd "${srcdir}/NetHack-NetHack-${pkgver}_Released"
+  cd "${srcdir}/$_srchome"
   make GAME=nethack-qt
 }

 package() {
   #cd "$_pkgname-$pkgver/"
-  cd NetHack-NetHack-${pkgver}_Released
+  cd $_srchome

   install -dm755 "$pkgdir"/usr/share/{man/man6,doc/nethack-qt}
   install -dm775 "$pkgdir"/var/games/

oddDistribution commented on 2023-08-20 18:42 (UTC)

I'm having the same issue as @rev.cressy and I tried installing and running qt5ct. Is there anything else I can try to fix this error?

(process:2388): Gtk-WARNING **: 14:39:52.010: This process is currently running setuid or setgid. This is not a supported use of GTK+. You must create a helper program instead. For further details, see:

http://www.gtk.org/setuid.html

niyanhhhhh commented on 2022-11-05 18:01 (UTC) (edited on 2022-11-07 12:12 (UTC) by niyanhhhhh)

@Tmk, referring to https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1017326 you can modified the file includ/tradstdc.h in src by applying these in PKGBUILD


--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,6 +46,8 @@ prepare() {
       -e '/^DIRPERM\s*=/ s|0755|0775|' -i sys/unix/Makefile.top

   sed -e "/^MANDIR\s*=/s|/usr/man/man6|$pkgdir/usr/share/man/man6|" -i sys/unix/Makefile.doc
+  sed -e '432i\#if !defined(__linux__) || defined(GCC_URWARN)' \
+      -e '438i\#endif' -i include/tradstdc.h

 }

Tmk commented on 2022-02-26 15:17 (UTC) (edited on 2022-02-26 15:18 (UTC) by Tmk)

Hello! The build aborts with:

/usr/include/sys/cdefs.h:405:73: error: macro "__has_attribute" requires an identifier
  405 | #if __GNUC_PREREQ (3,4) || __glibc_has_attribute (__warn_unused_result__)
      |                                                                         ^
make[1]: *** [Makefile:832: unixres.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: *** [<builtin>: dlb.o] Error 1
make[1]: *** [<builtin>: alloc.o] Error 1
make[1]: *** [<builtin>: isaac64.o] Error 1
make[1]: *** [Makefile:656: objects.o] Error 1
make[1]: *** [Makefile:652: monst.o] Error 1
make[1]: Leaving directory '/home/tmk/.cache/yay/nethack-qt/src/NetHack-NetHack-3.6.6_Released/src'
make: *** [Makefile:156: nethack-qt] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: nethack-qt

Is something missing on my end?

Thanks

styrsven commented on 2021-05-07 05:24 (UTC) (edited on 2021-05-07 05:24 (UTC) by styrsven)

@rev.cressy , I had the same issue. It was solved by installing qt5ct and starting it. When you start it, you will probably see "The application is not configured correctly". Press the information button and it will list one or several environment variables that are not set. Set the faulty/missing variables so they are set for your X session. Configure the Qt looks to your liking (you need those variables set to se it), and nethack-qt should start, at least it did for me.

rev.cressy commented on 2021-04-01 14:50 (UTC)

Get this error when I attempt to run nethack-qt:

(process:240542): Gtk-WARNING **: 10:50:03.908: This process is currently running setuid or setgid. This is not a supported use of GTK+. You must create a helper program instead. For further details, see:

http://www.gtk.org/setuid.html

Refusing to initialize GTK+.

fsnuker commented on 2020-11-23 22:34 (UTC) (edited on 2020-11-23 22:36 (UTC) by fsnuker)

bdftopcf: command not found /bin/sh: mkfontdir: command not found make:

Added to make dependencies, thanks.

jfcg commented on 2020-10-04 10:36 (UTC)

On latest Manjaro build fails with:

make[1]: Leaving directory '/var/tmp/pamac-build-serhat/nethack-qt/src/NetHack-NetHack-3.6.6_Released' touch /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/var/games/nethack-qt/perm /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/var/games/nethack-qt/record /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/var/games/nethack-qt/logfile /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/var/games/nethack-qt/xlogfile ( cd /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/var/games/nethack-qt ; true root perm record logfile xlogfile ; \ true games perm record logfile xlogfile ; \ chmod 0664 perm record logfile xlogfile ) true; cp -n sys/unix/sysconf /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/usr/share/nethack-qt//sysconf; true root /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/usr/share/nethack-qt//sysconf; true games /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/usr/share/nethack-qt//sysconf; chmod 0664 /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/usr/share/nethack-qt//sysconf; bdftopcf win/X11/nh10.bdf > /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/usr/share/nethack-qt//nh10.pcf; ( cd /var/tmp/pamac-build-serhat/nethack-qt/pkg/nethack-qt/usr/share/nethack-qt/; mkfontdir -x .lev ); /bin/sh: bdftopcf: command not found /bin/sh: mkfontdir: command not found make: *** [Makefile:333: install] Error 127 ==> ERROR: A failure occurred in package(). Aborting...

TrialnError commented on 2020-01-13 23:39 (UTC)

Using the official build and their qt5 hint file to generate the QT ui. Currently failing in the packaging phase, as not all files were transfered. Maybe still ran into the multithreaded build issue