Package Details: nodejs-nativefier 7.6.4-1

Git Clone URL: (read-only)
Package Base: nodejs-nativefier
Description: Wrap web apps natively
Upstream URL:
Submitter: atnanasi
Maintainer: lostkhaos
Last Packager: lostkhaos
Votes: 19
Popularity: 1.404552
First Submitted: 2016-02-20 05:39
Last Updated: 2018-06-18 14:38

Latest Comments

lostkhaos commented on 2017-11-09 15:57

@balwierz indeed, npm warns you about this at least (although the comment that your version is out-of-date is incorrect). You can watch the issue on github to see when they fix it:

balwierz commented on 2017-11-09 13:24

It won't build with the future nodejs currently in community-testing:

$ npm --version
$ yaourt -Qa nodejs
community-testing/nodejs 9.1.0-1

==> Starting package()...
npm WARN npm npm does not support Node.js v9.1.0
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8.
npm WARN npm You can find the latest version at
WARNING: You are likely using a version of node-tar or npm that is incompatible with this version of Node.js.ock
Please use either the version of npm that is bundled with Node.js, or a version of npm (> 5.5.1 or < 5.4.0) or node-tar (> 4.0.1) that is compatible with Node.js 9 and above.
/usr/bin/node[8608]: ../src/ void node::{anonymous}::ZCtx::Init(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args.Length() == 7 && "init(windowBits, level, memLevel, strategy, writeResult, writeCallback," " dictionary)"' failed.
1: node::Abort() [npm]
2: node::Assert(char const* const (*) [4]) [npm]
3: 0x55f369e0e628 [npm]
4: v8::internal::FunctionCallbackArguments::Call(void (*)(v8::FunctionCallbackInfo<v8::Value> const&)) [npm]
5: 0x55f3696fafaf [npm]
6: 0x55f3696fb4ff [npm]
7: 0x14d0bd5842fd
/tmp/yaourt-tmp-foo/aur-nodejs-nativefier/./PKGBUILD: line 16: 8608 Aborted (core dumped) npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver

atnanasi commented on 2017-05-09 12:54

Sorry for late.
I updated it.

gromain commented on 2017-05-04 14:42

Version 7.3.1 is out! Here and

Could you please update?


gamezelda commented on 2017-04-03 17:59

I had to install extra/gconf for the generated apps to work, should be a dependency.

atnanasi commented on 2016-09-02 08:04

Sorry for being late.
I have updated the PKGBUILD.

tembleking commented on 2016-08-31 14:27

Hey there!
Version v7.0.1 is already out!
Please could you update this package?