Package Details: ntfy-git v2.4.0.r20.gbab1dc8-1

Git Clone URL: https://aur.archlinux.org/ntfy-git.git (read-only)
Package Base: ntfy-git
Description: A utility for sending push notifications to different backends (Pushover, Pushbullet, XMPP and various desktop notification systems)
Upstream URL: https://github.com/dschep/ntfy
Licenses: GPLv3
Conflicts: ntfy
Provides: ntfy
Submitter: teamalpha5441
Maintainer: teamalpha5441
Last Packager: teamalpha5441
Votes: 3
Popularity: 0.000000
First Submitted: 2016-05-19 15:43
Last Updated: 2017-02-12 00:17

Latest Comments

vegarden commented on 2017-10-17 15:45

python-dbus should also be a dependency

teamalpha5441 commented on 2017-02-12 00:16

cannot reproduce this, no file in the package is root read-only, everything 644 like normal

growler commented on 2017-02-11 14:51

Package installs everything only readable by root:

Traceback (most recent call last):
File "/usr/bin/ntfy", line 11, in <module>
load_entry_point('ntfy==2.4.2', 'console_scripts', 'ntfy')()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 560, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2642, in load_entry_point
return ep.load()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2296, in load
return self.resolve()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2302, in resolve
module = __import__(self.module_name, fromlist=['__name__'], level=0)
File "<frozen importlib._bootstrap>", line 961, in _find_and_load
File "<frozen importlib._bootstrap>", line 950, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 655, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 674, in exec_module
File "<frozen importlib._bootstrap_external>", line 780, in get_code
File "<frozen importlib._bootstrap_external>", line 832, in get_data
PermissionError: [Errno 13] Permission denied: '/usr/lib/python3.6/site-packages/ntfy/__init__.py'

teamalpha5441 commented on 2017-01-16 18:07

updated python-ruamel.yaml dependency, thx mrdrogdrog

TilmanV commented on 2017-01-16 07:30

python-ruamel.yaml is now part of the community repo. (python-ruamel-yaml). Please change the dependency.

teamalpha5441 commented on 2017-01-12 13:40

added xorg-xprop dependency, thx pmav99

pmav99 commented on 2017-01-09 09:48

The package also depends on xorg-xprop
https://github.com/dschep/ntfy/issues/130

ForeverYoung commented on 2016-09-12 21:26

Created python-slacker package for ntfy slack backend