Package Details: numix-gtk-theme-git 2.6.7.r52.15923f7-1

Git Clone URL: https://aur.archlinux.org/numix-gtk-theme-git.git (read-only, click to copy)
Package Base: numix-gtk-theme-git
Description: A flat and light theme with a modern look (GNOME, Openbox, Unity, Xfce)
Upstream URL: https://github.com/numixproject/numix-gtk-theme
Keywords: gtk numix theme
Licenses: GPL3
Conflicts: numix-gtk-theme
Provides: numix-gtk-theme
Submitter: alucryd
Maintainer: jonathon
Last Packager: jonathon
Votes: 111
Popularity: 0.001246
First Submitted: 2017-02-26 11:41 (UTC)
Last Updated: 2020-08-18 12:31 (UTC)

Latest Comments

crimson_king commented on 2020-07-26 23:31 (UTC)

Version 2.6.7.r51.b652b19-1 fails to build.

=> Entrando no ambiente de fakeroot...
==> Iniciando package()...
(...)
mkdir: unable to create the directory “src/gtk-3.0/dist”: File exists
make: *** [Makefile:17: css] Error 1
(...)

Also, as Stunkymonkey pointed out, sassc needs to be installed.

Stunkymonkey commented on 2020-07-12 10:22 (UTC)

the ruby-sass dependency is replaced with sassc

ayekat commented on 2019-08-26 17:17 (UTC) (edited on 2019-08-26 19:43 (UTC) by ayekat)

The package should provide=(numix-gtk-theme), not numix-gtk-theme-git.

jogdand commented on 2018-10-18 09:24 (UTC)

The upstream url (numixproject.org) is wrong. It is parked.

A good candidate to act as upstream url would be (numixproject.github.io)

alucryd commented on 2018-01-02 13:40 (UTC)

It builds fine without, why do you say that?

encounter commented on 2017-10-05 03:48 (UTC) (edited on 2017-10-05 03:49 (UTC) by encounter)

The following should be added to makedepends: 'ruby-sass-listen' 'ruby-rb-fsevent' 'ruby-rb-inotify>=0.9.7' Note that the ruby-rb-inotify package is currently out of date (0.9.5), so I had to build it manually.

alucryd commented on 2017-03-10 17:57 (UTC)

Can't add something that's already in there...

macheath commented on 2017-03-10 09:50 (UTC)

add ruby-sass as makedepend

alucryd commented on 2017-02-27 19:40 (UTC)

I made it conflict with the non git version from [community], not itself. As for the conflict with numix-themes-git, I believe replaces should be enough.

GordonGR commented on 2017-02-27 17:33 (UTC)

Thanks for the info. However, you accidentally made the new package conflict with itself instead with numix-themes-git.

alucryd commented on 2017-02-26 11:41 (UTC)

Yup, ruby-sass just needs a rebuild. FYI, I'll be renaming numix-themes to numix-gtk-theme both here and in [community].

txus commented on 2017-02-17 22:41 (UTC)

@GordonGR rebuild ruby-sass, then build numix-themes-git. Chances are you still have it built for 2.3.

GordonGR commented on 2017-02-12 15:19 (UTC)

Alucryd, I have the same as last year and this time ruby-sass is up to date, 3.4.22-1.

alucryd commented on 2016-06-06 08:45 (UTC)

I don't know how pacaur works, please try asking over there.

samkostka commented on 2016-06-05 01:47 (UTC)

What's even weirder is that downloading the pkgbuild and installing it with makepkg -i works just fine, no errors at all. huh.

samkostka commented on 2016-06-05 01:41 (UTC)

Same issue as below; failed to verify numix-themes-git integrity. To get pacaur to upgrade stuff from the AUR, I have to add --ignore numix-themes-git for now.

piedro commented on 2016-05-08 18:46 (UTC)

couldn't verify integrity of numix-themes - installation aborted...

orzogc commented on 2016-04-19 12:26 (UTC)

The git repo of numix theme has been moved to https://github.com/numixproject/numix-gtk-theme.

alucryd commented on 2016-02-14 09:02 (UTC)

That's what happens when you don't keep deps up to date. Update ruby-sass to 3.4.21, et voilà.

GordonGR commented on 2016-02-13 15:35 (UTC)

Building fails :S rm -rf gtk-3.0/dist rm -f gtk-3.0/gtk.gresource scss --update --sourcemap=none gtk-3.0/scss:gtk-3.0/dist /usr/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs': Could not find 'sass' (>= 0) among 11 total gem(s) (Gem::LoadError) Checked in 'GEM_PATH=/home/nikos/.gem/ruby/2.3.0:/usr/lib/ruby/gems/2.3.0', execute `gem env` for more information from /usr/lib/ruby/2.3.0/rubygems/dependency.rb:328:in `to_spec' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:65:in `gem' from /usr/bin/scss:22:in `<main>' Makefile:12: recipe for target 'css' failed make: *** [css] Error 1

commented on 2016-02-08 07:32 (UTC)

==> Starting build()... rm -rf gtk-3.0/dist rm -f gtk-3.0/gtk.gresource scss --update --sourcemap=none gtk-3.0/scss:gtk-3.0/dist /usr/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs': Could not find 'sass' (>= 0) among 11 total gem(s) (Gem::LoadError) Checked in 'GEM_PATH=/home/sigitas/.gem/ruby/2.3.0:/usr/lib/ruby/gems/2.3.0', execute `gem env` for more information from /usr/lib/ruby/2.3.0/rubygems/dependency.rb:328:in `to_spec' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:65:in `gem' from /usr/bin/scss:22:in `<main>' Makefile:12: recipe for target 'css' failed make: *** [css] Error 1

alucryd commented on 2015-09-20 12:29 (UTC)

Right, thex for the heads up. I made it an optdep for those who don't use gtk2.

commented on 2015-09-18 21:22 (UTC)

Awesome! Just a note, without gtk-engine-murrine as a dependency, GTK2 apps don't take on the Numix styling. Thank you for maintaining this package.

alucryd commented on 2015-09-18 12:17 (UTC)

jrahmy: Thx, package updated.

commented on 2015-09-18 07:07 (UTC)

Numix now requires Sass compilation. As such, this package no longer works with the latest git master. The project README contains the latest install instructions, which basically entail a few new dependencies and running make/make install.

alucryd commented on 2014-10-22 08:28 (UTC)

That's what you get when upstream totally breaks their tagging scheme :( Fixed.

rscholer commented on 2014-10-21 18:59 (UTC)

pkgver() is broken: ==> Starting pkgver()... ==> Updated version: numix-themes-git gtk.r3.12-2.5792629-1 ==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.

alucryd commented on 2013-12-13 09:01 (UTC)

Merging into numix-themes-git, as stable release will soon be in [community] as numix-themes.

Diego commented on 2013-06-16 06:26 (UTC)

Added official QtCurve scheme http://half-left.deviantart.com/art/KDE4-QtCurve-Numix-378256536

Diego commented on 2013-06-16 06:25 (UTC)

Added official QtCurve scheme

Diego commented on 2013-06-15 21:15 (UTC)

bump after 1.6 release

Diego commented on 2013-05-03 08:23 (UTC)

fixed

freestyler7 commented on 2013-04-22 13:58 (UTC)

Where does the fb2b47e sha5 comes from? The latest commit is ecdef7e and my package gets this pkgver. Since your's is different, cower always thinks there is an update.

Nierro commented on 2013-04-19 14:11 (UTC)

This package will fix every gtk3.8 related problem (as far as I can see...) Thanks for maintaining it!