Package Details: ocaml-lsp-git r484.d57bd91-1

Git Clone URL: https://aur.archlinux.org/ocaml-lsp-git.git (read-only, click to copy)
Package Base: ocaml-lsp-git
Description: OCaml Language Server Protocol implementation
Upstream URL: https://github.com/ocaml/ocaml-lsp
Keywords: lsp ocaml
Licenses: ISC
Conflicts: ocaml-lsp
Provides: ocaml-lsp
Submitter: condy
Maintainer: dctxmei
Last Packager: condy
Votes: 0
Popularity: 0.000000
First Submitted: 2020-02-24 14:17 (UTC)
Last Updated: 2020-03-22 07:38 (UTC)

Latest Comments

eclairevoyant commented on 2022-12-04 12:57 (UTC)

These dependencies are out of date based on this page.

I tried creating the remaining packages manually, and added them to the PKGBUILD:

depends=('ocaml>=4.14' 'ocaml<4.15' 'ocaml-yojson' 'ocaml-ppx_yojson_conv_lib>=0.14' 'ocaml-stdlib-shims' 'ocaml-ocamlc-loc>=3.5.0' 'ocaml-ppx_inline_test' 'ocaml-re>=1.5.0' 'ocaml-spawn' 'ocaml-pp>=1.1.2' 'ocaml-ocamlformat-rpc-lib>=0.21.0' 'ocaml-omd>=1.3.2' 'ocaml-omd<2.0.0' 'ocaml-octavius>=1.2.2' 'ocaml-chrome-trace>=3.3.0' 'ocaml-csexp>=1.5' 'ocaml-menhir')

However, I ran into another issue:

==> Starting build()...
submodules/lev/lev/vendor/ev.c:2143:31: warning: ‘ev_default_loop_ptr’ initialized and declared ‘extern’
submodules/lev/lev/vendor/ev.c: In function ‘evpipe_write’:
submodules/lev/lev/vendor/ev.c:2817:11: warning: ignoring return value of ‘write’ declared with attribute ‘warn_unused_result’ [-Wunused-result]
submodules/lev/lev/vendor/ev.c: In function ‘pipecb’:
submodules/lev/lev/vendor/ev.c:2852:11: warning: ignoring return value of ‘read’ declared with attribute ‘warn_unused_result’ [-Wunused-result]
File "vendor/lev-fiber-csexp/lev_fiber_csexp.ml", line 1:
Error: The files /usr/lib/ocaml/csexp/csexp.cmi
       and /usr/lib/ocaml/stdune/stdune__Sexp.cmi
       make inconsistent assumptions over interface Csexp
File "ocaml-lsp-server/src/merlin_config.ml", line 1:
Error: The files ocaml-lsp-server/src/.ocaml_lsp_server.objs/byte/ocaml_lsp_server__Import.cmi
       and ocaml-lsp-server/vendor/merlin/src/dot-protocol/.merlin_dot_protocol.objs/byte/merlin_dot_protocol.cmi
       make inconsistent assumptions over interface Csexp
File "ocaml-lsp-server/src/ocamlformat_rpc.ml", line 1:
Error: The files ocaml-lsp-server/src/.ocaml_lsp_server.objs/byte/ocaml_lsp_server__Import.cmi
       and vendor/lev-fiber-csexp/.lev_fiber_csexp.objs/byte/lev_fiber_csexp.cmi
       make inconsistent assumptions over interface Csexp
File "ocaml-lsp-server/src/dune.ml", line 1:
Error: The files ocaml-lsp-server/src/.ocaml_lsp_server.objs/byte/ocaml_lsp_server__Import.cmi
       and vendor/lev-fiber-csexp/.lev_fiber_csexp.objs/byte/lev_fiber_csexp.cmi
       make inconsistent assumptions over interface Csexp
==> ERROR: A failure occurred in build().
    Aborting...

I tried rebuilding the latest ocaml-csexp as well and that did not fix the error. Do you have any ideas of whether this is a packaging issue or should be reported upstrean?

condy commented on 2020-09-28 18:19 (UTC) (edited on 2020-09-28 18:20 (UTC) by condy)

@SkyrisBactera Thanks for reporting.

3 additional packages are required: ocaml-octavius, ocaml-ppx_expect and csexp. Saddly csexp is not on AUR and installing ocaml-ppx_expect failed on my machine. Needs investigation...

git-reset ocaml-lsp-git to c4e668d (4 mon ago) if you're in urgency.

SkyrisBactera commented on 2020-09-27 20:51 (UTC)

Building the package fails, seemingly to missing dependencies:

File "vendor/stdune/dune", line 11, characters 30-35:
11 |  (libraries stdlib-shims unix csexp)
                                   ^^^^^
Error: Library "csexp" not found.
Hint: try:
  dune external-lib-deps --missing @@default
File "vendor/stdune/dune", line 4, characters 16-25:
4 |  (action (run %{bin:cppo} -V OCAML:%{ocaml_version} %{ml} -o %{targets})))
                    ^^^^^^^^^
Error: Program cppo not found in the tree or in PATH
 (context: default)
File "lsp/test/dune", line 64, characters 7-17:
64 |   (pps ppx_expect)))
            ^^^^^^^^^^
Error: Library "ppx_expect" not found.
Hint: try:
  dune external-lib-deps --missing @@default
      menhir lsp/bin/typescript/ts_parser.{ml,mli}

condy commented on 2020-03-22 07:08 (UTC)

@kapheine

Thanks!

I also emailed the dune maintainer a month ago, but he said

I’m no longer the maintainer of dune in Arch Linux since July last year. You can see this information here: https://www.archlinux.org/packages/community/x86_64/dune/.

I’m adding the current maintainer in copy.

sob

kapheine commented on 2020-03-22 07:02 (UTC) (edited on 2020-03-22 07:02 (UTC) by kapheine)

This package seems to now have a dependency on ocaml-menhir.

It also requires dune >= 2.0.0 now. I've emailed the maintainer regarding updating the package, but it can also manually be rebuilt by just bumping the version:

pkgver=2.4.0
8ba200e35c4494d1468d37dfff84b30d1e3f2899cd4122f465d3636674ae8827