Package Details: ocp 0.1.21-7

Git Clone URL: https://aur.archlinux.org/ocp.git (read-only)
Package Base: ocp
Description: Open Cubic Player
Upstream URL: http://stian.cubic.org/project-ocp.php
Licenses: GPL
Submitter: None
Maintainer: miffe
Last Packager: miffe
Votes: 22
Popularity: 0.531892
First Submitted: 2006-09-04 21:20
Last Updated: 2019-05-17 18:54

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

miffe commented on 2011-11-07 13:23

ocp 0.1.21-1
- New upstream release

miffe commented on 2011-10-21 14:13

ocp 0.1.20-3:
- Disabled adplug since it doesn't seem to work anymore. (Thanks skwid for the report)

Binaries available at http://arch.miffe.org/

Anonymous comment on 2011-10-20 00:11

I'm getting this during the build. Any Suggestions?

In file included from oplplay.cpp:37:0:
ocpemu.h:52:2: error: ‘FM_OPL’ does not name a type
oplplay.cpp: In function ‘void oplpGetChanInfo(int, oplChanInfo&)’:
oplplay.cpp:727:2: error: ‘OPL_CH’ was not declared in this scope
oplplay.cpp:727:10: error: ‘ch’ was not declared in this scope
oplplay.cpp:727:21: error: ‘class Cocpopl’ has no member named ‘opl’
oplplay.cpp:728:2: error: ‘OPL_SLOT’ was not declared in this scope
oplplay.cpp:728:12: error: ‘slot’ was not declared in this scope
make[1]: *** [oplplay.o] Error 1
make[1]: Leaving directory `/home/skwid/builds/ocp/src/ocp-0.1.20/playopl'
make: *** [dirs] Error 2

miffe commented on 2011-06-20 16:43

@marcs It has both a curses and a framebuffer drivers in addition to the x11 and sdl ones, so it can run without X if you like.
If you dont want them as dependencies, just remove them from depends and add --without-x11 --without-sdl to the ./configure line and run makepkg.
I'll investigate why it doesn't work with adplug anymore. Thanks for the report.

marcs commented on 2011-06-20 10:54

I've figured out. I was getting an error. I guess it's caused by libbinio that is required by adplug. So I've modified the PKGBUILD file removing the adplug support with the option: --without-adplug. Now works.

marcs commented on 2011-06-20 09:58

Ocp can be installed in a system without Xorg ? Guess not, 'cause i see there's SDL as a dependency. Am i right ?

miffe commented on 2011-01-14 14:57

Repo has been renamed, both for i686 and x86_64.

[miffe]
Server = http://arch.miffe.org/$arch/

miffe commented on 2010-11-01 08:59

I have created a x86_64 repo.

[miffe-x86_64]
Server = http://arch.miffe.org

miffe commented on 2010-11-01 08:24

ocp 0.1.20-2:
- Add desktop-file-utils to makedepends

miffe commented on 2010-09-15 17:55

New URL for my repo:

[miffe]
Server = http://arch.miffe.org/