Package Details: opencpn 5.0.0-3

Git Clone URL: https://aur.archlinux.org/opencpn.git (read-only, click to copy)
Package Base: opencpn
Description: Open Source Chart Plotting / Marine Navigation
Upstream URL: http://opencpn.org
Licenses: GPL2
Submitter: None
Maintainer: ruppor
Last Packager: ruppor
Votes: 31
Popularity: 0.95
First Submitted: 2009-07-08 14:25
Last Updated: 2019-05-15 20:51

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Mr.Elendig commented on 2018-11-12 10:07

  1. Try building in a clean chroot
  2. use LANG=C
  3. If it still fails, put the full output of make -j1 in ptpb/bpaste/gist/similar (not pastebin.com)

kikoloche commented on 2018-11-11 21:32

can't compile this version. This is the error reported during compilation:

during GIMPLE pass: wrestrict En la función ‘double CPLScanDouble(char, int, char)’: en pp_format, en pretty-print.c:1387 double CPLScanDouble( char pszString, int nMaxLength, char pszLocale ) ^~~~~~~~~~~~~

Mr.Elendig commented on 2018-09-17 08:21

Latest update; Nothing new on the western front. https://github.com/OpenCPN/OpenCPN/issues/1132

Mr.Elendig commented on 2018-08-30 08:12

For those of you waiting for a update. It will come when the opencpn devs starts to tag releases again on github instead of just ninjarelease on the download page without providing any valid link to the (signed and/or checksummed)source used for the release.

Mr.Elendig commented on 2017-09-25 14:39

Would if there was a working static download link for the tarball with checksums from upstream, which apparently there isn't anymore, because reasons. I'm going to poke upstream about it.

indianahorst commented on 2017-09-21 21:11

==> Retrieving sources...
-> Found v4.8.0.tar.gz
==> Validating source files with sha1sums...
v4.8.0.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build opencpn.


Would you please fix the checksums? Thanks!

dc46and2 commented on 2016-05-26 18:49

I suggest the following options be added to the cmake command line in PKGBUILD:

-DBUNDLE_GSHHS=CRUDE -DBUNDLE_TCDATA=ON -DBUNDLE_DOCS=ON

Adding these options causes a basic background map, tide & current data, and help files to be included in the package.

gin078 commented on 2016-05-04 11:59

I was seeing a build error like:
CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 message:Could NOT find wxWidgets missing: wxWidgets_LIBRARIES

However, I'm unable to reproduce this error. Thanks!

Mr.Elendig commented on 2016-04-20 08:17

You shouldn't need wxgtk2.8, opencpn have supported wxgtk 3.x since ages ago, what were the errors you were getting during build?

gin078 commented on 2016-04-18 03:44

This package compiled for me by replacing the wxgtk dependency with wxgtk2.8.