Package Details: openwebrx 0.20.3-1

Git Clone URL: https://aur.archlinux.org/openwebrx.git (read-only, click to copy)
Package Base: openwebrx
Description: Open source, multi-user SDR receiver software with a web interface
Upstream URL: https://www.openwebrx.de/
Licenses: AGPL3
Submitter: tjbp
Maintainer: tjbp
Last Packager: tjbp
Votes: 1
Popularity: 0.000687
First Submitted: 2017-12-07 15:58
Last Updated: 2021-03-08 21:43

Latest Comments

ageras commented on 2021-07-31 12:37

i tested the openwebrx version 1.0.0 and it works by changing the pkgver='1.0.0' from pkgver='0.20.3', but there is one problem with the owrx_connector-git pkgbuild because it compiles the 0.5.0 version (develop branch) while openwebrx needs the 0.4.0 version. i made a owrx_connector 0.4.0 PKGBUILD locally and tested it but i have a problem with the openwebrx 1.0.0 made locally because i can't understand where ../sysusers.conf comes from. also i don't know if owrx_connector should provide="owrx_connector0.4.0" instead of just "owrx_connector" and openwebrx depends="owrx_connector0.4.0" instaed of "owrx_connector".

tjbp commented on 2021-03-08 21:43

@Miegl thanks - added and updated to 0.20.3.

Miegl commented on 2021-03-08 21:24

Please add /etc/openwebrx/config_webrx.py into backup=() array.

Refutationalist commented on 2020-12-19 14:24

@tjbp that seemed to do it, but I did have to install python-setuptools to get openwebrx to run. Thanks a bunch for packaging this!

tjbp commented on 2020-12-16 11:56

@Refutationalist I've taken over csdr and pointed at jketterl's repo - so you can use the csdr package now. You were probably missing netcat (nc) too since I've just added that as a dependency.

Refutationalist commented on 2020-12-12 10:50

@tjb: I am building from the most recent csdr-jketterl-git in AUR. When I run makepkg on openwerbrx, it does not see the current version (0.17.0.r14.gc1c47ce) as meeting the "csdr>=0.17" requirement.

Changing the PKGBUILD to just depend on csdr-jketterl-git without a version does allow the package to build, but with the error that I am seeing. This is on a clean VM with very little installed.

tjbp commented on 2020-12-07 12:08

@Refutationalist have just updated it to Python 3.9. Your error is however not related to Python - csdr is in the package dependencies, makepkg shouldn't have built your package without it. It also needs to be >=0.17 of csdr, which currently only csdr-jketterl-git provides.

Refutationalist commented on 2020-12-06 02:29

I'm trying to make this work on a recent Arch Linux install, with Python 3.9. I make the appropriate changes to the PKGBUILD, and it dies with:

ERROR - you are missing required dependencies to run openwebrx. please check that the following core requirements are installed and up to date: ERROR - csdr, nmux, nc


I'm not even close to a python person, who this might be a simple fix that's beyond me. Any ideas?