Package Details: rtl-sdr-git 2.0.1.4.gaf33886-1

Git Clone URL: https://aur.archlinux.org/rtl-sdr-git.git (read-only, click to copy)
Package Base: rtl-sdr-git
Description: Driver for Realtek RTL2832U, allowing general purpose software defined radio (SDR)
Upstream URL: https://osmocom.org/projects/rtl-sdr/wiki
Licenses: GPL
Conflicts: rtl-sdr
Provides: rtl-sdr
Submitter: akurei
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 30
Popularity: 0.005005
First Submitted: 2012-03-28 10:40 (UTC)
Last Updated: 2024-02-17 13:15 (UTC)

Dependencies (4)

Required by (69)

Sources (3)

Latest Comments

1 2 3 4 Next › Last »

fixeria commented on 2023-11-17 12:51 (UTC)

@MarsSeed JFYI, the https://github.com/librtlsdr/librtlsdr.git is an unofficial fork with somewhat questionable changes (among with the good new features). Unfortunately, they never cooperated with the upstream (Osmocom), which was recently brought up in their bug tracker (https://github.com/librtlsdr/librtlsdr/issues/135).

The upstream recently merged some new patches and tagged v2.0.1. IMO, it's better to stick with the upstream (Osmocom) rather than using random forks (GitHub) merging whatever they like and tagging new versions... That being said, I don't want to offend anyone or diminish their work. My concern is mainly about picking the authoritative source.

BTW, I just stumbled upon https://archlinux.org/packages/extra-testing/x86_64/rtl-sdr/, which is reverting back to the upstream's (Osmocom) v2.0.1. Now let's wait for the fork to tag v3.x.x ;)

MarsSeed commented on 2023-09-25 11:23 (UTC) (edited on 2024-02-17 13:52 (UTC) by MarsSeed)

Actually, please kindly use the same source as extra/rtl-sdr:

https://github.com/librtlsdr/librtlsdr.git

EDIT: this comment is no longer relevant, as the original Osmocom/rtl-sdr project became active again, and Arch repo's rtl-sdr* also got switched back to using that source.

MarsSeed commented on 2023-08-13 13:06 (UTC)

Also source URL has changed; please kindly switch to it:

https://gitea.osmocom.org/sdr/rtl-sdr.git

MarsSeed commented on 2023-08-13 13:04 (UTC)

Please add conflicts=(rtl-sdr). Thank you in advance.

EndlessEden commented on 2021-08-27 11:53 (UTC)

Please fix pkgbuild libusb is greater that 1.0 is compatible.

akurei commented on 2017-11-05 19:00 (UTC)

Orphaned.

akurei commented on 2017-07-19 11:47 (UTC)

No, this version is the latest git master version. rtl-sdr from community is a fixed commit (presumably at a stable release).

JohnRobson commented on 2017-07-18 20:45 (UTC)

Is this the same Version than: https://www.archlinux.org/packages/community/x86_64/rtl-sdr/ ?

akurei commented on 2017-07-18 11:31 (UTC)

@falsovsky Done. Thanks.