Package Details: openxcom 1.0-8

Git Clone URL: (read-only, click to copy)
Package Base: openxcom
Description: An open-source reimplementation of the famous X-COM game
Upstream URL:
Licenses: GPL3
Submitter: None
Maintainer: WorMzy
Last Packager: WorMzy
Votes: 45
Popularity: 0.000004
First Submitted: 2012-01-30 07:27 (UTC)
Last Updated: 2019-12-21 00:07 (UTC)

Latest Comments

WorMzy commented on 2022-02-13 23:12 (UTC)

spalf commented on 2022-02-13 19:11 (UTC) (edited on 2022-02-13 19:12 (UTC) by spalf)

also needs automake and autoconf

gonciarz commented on 2019-08-11 22:10 (UTC)

@WorMzy: I created a patch few weeks ago that unify paths for openxcom and openxcom-git.

I copy-paste my comment from openxcom-extended package: gonciarz commented on 2019-07-16 20:49 Hi WorMzy, I understand that the OpenXcom is dead now because guys do not release on github. But on the other hand I don't like disorder and manual steps. I just want to have all packages (openxcom/git, openxcom-extended/git) Still from my point of view the cleanest solution would be to apply a patch to openxcom that would change the 'data' path to 'UFO'. Actually I dig a bit and prepared one. Please accept it.

I'm not familiar how collaboration looks like on AUR git, but I usually create a pull request. I've tested the game and it loads properly. Please take a look here:

I believe that after merging that change to aur repo, we may change path in openxcom-data-steam. What do you think?


WorMzy commented on 2019-01-27 15:55 (UTC) (edited on 2019-01-27 17:17 (UTC) by WorMzy)

Sorry Ultima_12, I completely missed your message. FWIW, I can't reproduce the error you were getting, so hopefully it was just a transient issue with your build environment. EDIT: actually, checking the git update history, I updated the patchset after your message, but must've forgotten to post a message about the change. My bad.

@jenz: There seems to have been a change in the way that GL_GLEXT_VERSION is defined, and this trips over builds using -Werror (which is the default. I'm not sure how to fix this properly, and upstream has long since abandoned the v1.0 release (they recommend using nightly builds, which you can use openxcom-git to reproduce) so I doubt a patch will be made to fix this. Instead, I have disabled -Werror in the build, and checked that the built package still runs. Please give it a go and see if it resolves your issue.

commented on 2019-01-27 11:39 (UTC)

Pinging. This package still fails

Ultima_12 commented on 2018-03-07 20:19 (UTC)

The package fails to build due to an issue with the source, specific output of:

src/Basescape/BaseInfoState.cpp: In member function ‘virtual void OpenXcom::BaseInfoState::init()’: src/Basescape/BaseInfoState.cpp:358:14: error: ‘floor’ was not declared in this scope ss5 << (int)floor(_base->getUsedStores() + 0.05) << ":" << _base->getAvailableStores(); ^~~~~ src/Basescape/BaseInfoState.cpp:358:14: note: suggested alternative: ‘float’ ss5 << (int)floor(_base->getUsedStores() + 0.05) << ":" << _base->getAvailableStores(); ^~~~~ float

WorMzy commented on 2016-05-09 13:54 (UTC)

I've pushed an update that fixes the errors, but I can't guarantee that my fixes won't cause problems in-game. If you could give it a go and let me know if you run into crashes or anything strange, that'd be great.

hollunder commented on 2016-05-09 12:22 (UTC)

Fails to build with this error: src/Geoscape/Globe.cpp:1398:29: error: call of overloaded ‘abs(double)’ is ambiguous seg = abs( sx/(2*M_PI)*96 );

WorMzy commented on 2014-09-05 21:18 (UTC)

You should already have that installed, as it's a member of base-devel:

slick commented on 2014-09-05 21:16 (UTC)

Hi, Today I tried to build the package and got the following error: ./configure: line 4319: syntax error near unexpected token `0.24' ./configure: line 4319: `PKG_PROG_PKG_CONFIG(0.24)' I googled it [1], and it seems that `pkg-config' package is required for the build. So, you should probably add it to makedepends. [1]

Boskote commented on 2014-06-21 00:52 (UTC)

For those who are unable to upgrade openxcom because of the error "yaml-cpp and yaml-cpp0.3 are in conflict" you can uninstall yaml-cpp0.3 using: pacman -Rdd yaml-cpp0.3 And then the upgrade should run without a problem. The -Rdd allows for removing a package even though it is a dependency of another package (which is this case is the old version of openxcom). As Dalrik stated below, it is also possible to manually uninstall and then reinstall openxcom. I didn't want to do this because I made a bunch of changes to the openxcom files that I didn't want risk messing up. So I found the -Rdd way, and thought I would share because it seems like a cleaner solution.

WorMzy commented on 2014-06-14 18:06 (UTC)

That was a superfast update! :D A couple of points: * You can drop the timidity++ dependency as it's no longer needed by default. (though I believe people can still use it if they want to) * The manpage generation is a lot better nowadays too, so you may want to consider re-enabling it (just remove the --without-man and add xmlto, docbook-xml, and docbook-xsl to the makedepends). Good luck with your alien hunting!

Dalrik commented on 2014-06-14 05:20 (UTC)

Due to Openxcom switching to a new version of yaml-cpp, you will need to manually uninstall openxcom before upgrading to v1.0.

gojun077 commented on 2014-05-06 23:17 (UTC)

Please add timidity++ to the dependencies

Dalrik commented on 2014-02-20 07:01 (UTC)

Thanks for the feedback SNCPlay42. I've updated the package to include the .desktop and its associated files.

SNCPlay42 commented on 2014-02-16 19:34 (UTC)

Two small nitpicks: - The install script says to copy the XCOM files to /usr/share/openxcom, but the correct destination is /usr/share/openxcom/data. - The package still doesn't include a .desktop file - there is one with the necessary icons in the source repository's res/linux.

Dalrik commented on 2014-01-13 22:03 (UTC)

This is an AUR package, which means it is supported by the community, not pacman or the Arch developers. To install AUR packages, you either need to build manually (look up 'AUR' on the wiki), or use an AUR helper such as yaourt to build/install it automatically.

athanas commented on 2014-01-13 20:52 (UTC)

Sorry, I am new with Arch... How to install it? I can not see it with pacman (pacman -Ss openxcom). Thanks!

Dalrik commented on 2013-08-19 22:39 (UTC)

The current release (v0.9) is still dependent on yaml-cpp 0.3. openxcom-git, on the other hand, does need to change the dependency to 0.5

Samsagax commented on 2013-08-19 22:35 (UTC)

They updated the game to use yaml-cpp 0.5

giniu commented on 2013-05-19 11:25 (UTC)

Just a note: someone deleted yaml-cpp0.3 package. I've reuloaded it, because there are still packages that require it and do not work with yaml-cpp 0.5.x, including this one. If someone had troubles installing it for some time, now all dependencies are again available.

commented on 2013-05-16 01:37 (UTC)

I've added the changes from Wesley's PKGBUILD, barring the .desktop file. I'll add those shortly when I have time.

Wesley commented on 2013-05-15 18:51 (UTC)

it works if i use this PKGBUILD: and put all files to /usr/share/openxcom/data/ the data files that came with the binary need to be in the same directory like the xcom files

commented on 2013-05-09 03:12 (UTC)

My apologies. I had not thought to build AUR packages in a chroot before, and will be doing so from now on. Thanks for the tip.

miffe commented on 2013-05-08 15:52 (UTC)

g++ -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -Wall -Wextra -O2 -rdynamic -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/SDL -c -o ../obj/AllocatePsiTrainingState.o Geoscape/AllocatePsiTrainingState.cpp In file included from pch.h:37:0, from pch.cpp:1: /usr/include/SDL/SDL_opengl.h:46:60: fatal error: GL/gl.h: No such file or directory #include <GL/gl.h> /* Header File For The OpenGL Library */ ^ compilation terminated. Please add mesa and glu to makedepends. And do build your packages in chroot to catch such simple errors.

xF0E commented on 2013-02-14 14:10 (UTC)

Thanks, but now the game keeps failing to start with error: Failed to load index, after i copied the steam directory to /usr/share/xcom/data.

commented on 2013-02-14 03:32 (UTC)

Changed dependecy 'yaml-cpp' to 'yaml-cpp0.3'. Compilation should run successfully now.

commented on 2013-02-13 09:52 (UTC)

Strange, I'm getting the same error but with Savegame/Region.cpp I'll check with upstream to see what's going on.

xF0E commented on 2013-02-12 23:20 (UTC)

Hello guys! I get this error at compiling: Savegame/CraftWeapon.cpp:48:18: error: no match for ‘operator>>’ in ‘YAML::Node::operator[](const Key&) const [with Key = char [5]]((*"ammo")) >> ((OpenXcom::CraftWeapon*)this)->OpenXcom::CraftWeapon::_ammo’ Savegame/CraftWeapon.cpp:49:22: error: no match for ‘operator>>’ in ‘YAML::Node::operator[](const Key&) const [with Key = char [9]]((*"rearming")) >> ((OpenXcom::CraftWeapon*)this)->OpenXcom::CraftWeapon::_rearming’ make: *** [../obj/CraftWeapon.o] Error 1 How i can bypass it?

commented on 2012-04-15 17:50 (UTC)

Hi, eix6leiz. 'pkg-config' is included in the 'base-devel' group, therefore this package isn't required to be listed in the dependencies. See this wiki page:

commented on 2012-04-14 13:34 (UTC)

Version 0.3 requires pkg-config to build. pkg-config should be added to makedepends: makedepends=('pkg-config')

commented on 2012-01-30 07:33 (UTC)

OpenXcom requires the original X-COM resources. You can find the installation manual on this page: