Package Details: papis 0.8.2-1

Git Clone URL: https://aur.archlinux.org/papis.git (read-only)
Package Base: papis
Description: Papis is a powerful and highly extensible command-line based document and bibliography manager.
Upstream URL: https://github.com/papis/papis
Licenses: GPL
Submitter: JP-Ellis
Maintainer: JP-Ellis
Last Packager: JP-Ellis
Votes: 4
Popularity: 0.597263
First Submitted: 2018-08-13 20:42
Last Updated: 2019-03-03 07:25

Latest Comments

thoth101010 commented on 2018-11-21 18:55

Thank you for your advice, now python-prompt_toolkit is up-to-date.

It seems that python-parse is also required by papis.

( and setup.py wants outdated versions of python-slugify and python-click )

JP-Ellis commented on 2018-11-14 01:26

@darehanl Thanks for the feedback. I've updated the dependencies to reflect exactly what's in setup.py. I've made the changes in the latest version (0.7.4). For earlier versions, you'll have to modify the PKGBUILD yourself unfortunately.

darehanl commented on 2018-11-13 15:58

Thanks for packaging. Seems like there's a few more requirements.

filetype>=1.0.1: No AUR package yet. I just used pip to install this. PyYAML>=3.12: python-pyaml in Community python-slugify==1.2.5: Downgraded AUR python-slugify isbnlib<4.0.0,>=3.9.1: python-isbnlib in AUR

JP-Ellis commented on 2018-11-09 22:53

@thoth101010 Indeed, the latest version of papis requires a more recent version of python-prompt_toolkit than is currently provided (https://www.archlinux.org/packages/community/any/python-prompt_toolkit/). This has been flagged as out of date for a few months now, and I hope they upgrade soon. (Though I suspect the issue is that ipython and jupyter both require v1 of python-prompt_toolkit).

There are a couple of options you can consider:

  1. Modify the papis PKGBUILD to use python-prompt_toolkit-2 from the AUR, but note that you can't have v1 and v2 two of python-prompt_toolkit-2 concurrently installed.
  2. Install v0.6 of papis in the meantime. You can obtain the PKGBUILD for v0.6 of papis at commit 11e476d.

thoth101010 commented on 2018-11-09 14:20

It seems that the version of python-prompt_toolkit available on community is only the version 1.0.15-2, but a version >=2.0.0 is required by the package.

Error: Could not find all required packages:
    python-prompt_toolkit>=2.0.0 (Wanted by: papis)

benneti commented on 2018-09-04 19:54

I additionally needed python-pyaml and then still get a missing library problem: raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'filetype>=1.0.1' distribution was not found and is required by papis

JP-Ellis commented on 2018-08-23 12:39

Thanks for the feedback :) I see that python-prompt_toolkit and python-future are indeed a missed dependencies.

As for python-urwidtrees, I think you mean that python-urwid is necessary; I can't find where urwidtrees comes in, but I do see that urwid is used.

kjvbrt commented on 2018-08-23 12:05

Hello,

the package also depends on: python-urwidtrees python-prompt_toolkit python-future

All the best, Kjvbrt