Package Details: pdfarranger-git r240.fb7758d-1

Git Clone URL: https://aur.archlinux.org/pdfarranger-git.git (read-only)
Package Base: pdfarranger-git
Description: Helps merge or split pdf documents and rotate, crop and rearrange pages.
Upstream URL: https://github.com/jeromerobert/pdfarranger
Licenses: GPL3
Conflicts: pdfarranger, pdfshuffler, pdfshuffler-git
Submitter: alium
Maintainer: alium
Last Packager: alium
Votes: 24
Popularity: 0.008016
First Submitted: 2018-11-11 16:46
Last Updated: 2019-07-30 21:04

Latest Comments

alium commented on 2019-07-30 21:05

@prettyvanilla : of course ;-)

prettyvanilla commented on 2019-07-30 12:53

pdfarranger now defaults to pikepdf over pypdf2, the community package switched to python-pikepdf as a dependency accordingly. May be good to follow this for the git-package as well.

alium commented on 2018-12-03 19:49

@zoe: thanks for info! i switch git version to master branch

For stable version use please package 'pdfarrander' https://aur.archlinux.org/packages/pdfarranger/

zoe commented on 2018-12-01 22:28

Please, replace :

          data/hicolor/$_size/apps/pdfarranger.png

by

          data/icons/$_size/apps/pdfarranger.png

and replace :

          data/hicolor/scalable/apps/pdfarranger.svg"

by

          data/icons/scalable/apps/pdfarranger.svg"

Otherwise, you get the error :

  install: impossible d'évaluer 'data/hicolor/scalable/apps/pdfarranger.svg': Aucun fichier ou dossier de ce type

(Sorry, it is in french)

Thanks for your job !!

TheChickenMan commented on 2018-11-19 02:30

Updated. Sorry was a busy week at work last week

jo-shva commented on 2018-11-13 10:46

this package needs the icons used to install's names changed to pdfarranger.svg .png ....near the end of PKGBUILD. The maintainer can force this package on install to move to the new package listed pdfarranger-git or at the very least leave an info at the end of the build. apreciation for your maintaining this package.

alium commented on 2018-11-11 16:49

@EasyToRemember: Thanks for info, i prepare new package: https://aur.archlinux.org/packages/pdfarranger-git/

please move to new package!!

EasyToRemember commented on 2018-11-10 13:35

The app renamed to pdfarranger in git - need to change the "install" commands in PKGBUILD to reflect the change in icon name.

TheChickenMan commented on 2016-04-16 13:28

I believe you're right. It should no longer need python2-poppler. I updated the dependency list translated as best as I could from the Debian package database. Everything seems to be working fine for me. Let me know if you notice anything else that should be changed. Here is the list of requirements as listed by the PDFShuffler developers: (pypdf2 python-gi python-gi-cairo gir1.2-gtk-3.0 gir1.2-poppler-0.18)

positron commented on 2016-04-16 11:15

python-cairo[extra] must be added to the dependencies.
Thanks for the package!