Package Details: perl-alien-wxwidgets 0.69-1

Git Clone URL: https://aur.archlinux.org/perl-alien-wxwidgets.git (read-only, click to copy)
Package Base: perl-alien-wxwidgets
Description: building, finding and using wxWidgets binaries
Upstream URL: https://metacpan.org/release/Alien-wxWidgets
Licenses: GPL, PerlArtistic
Submitter: giovanni
Maintainer: swiftgeek
Last Packager: swiftgeek
Votes: 72
Popularity: 0.166141
First Submitted: 2010-02-13 04:34
Last Updated: 2017-05-09 14:27

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

not_anonymous commented on 2015-01-04 15:20

Please understand that I wanted to build this against wxgtk 3.X AND I made sure to start this by removing everything concerning perl-wx first and having just wxgtk installed. Moving the wxgtk to makedepends (along with some other subtle changes to the PKGBUILD) prevented BOTH the build stage from trying to recompile WX AND that the makepkg would complete without complaints. IF this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.

*** Perhaps the working solution is to place wxgtk into both the depends and makdepends arrays. This is, of course, your decision to make. I was just sharing some thoughts and some fixes

not_anonymous commented on 2015-01-04 15:18

Please understand that I wanted to build this against wxgtk 3.X AND I made sure to start this by removing everything concerning perl-wx first and having just wxgtk installed. Moving the wxgtk to makedepends (along with some other subtle changes to the PKGBUILD) prevented BOTH the build stage from trying to recompile WX AND that the makepkg woudl complete without complaints. IF this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.

*** Perhaps the working solution is to place wxgtk into both the depends and makdepends arrays. This is, of course, your decision to make. I was just sharing some thoughts and some fixes

not_anonymous commented on 2015-01-04 15:16

Please understand that I wanted to build this against wxgtk 3.X AND I made sure to start this by removing everything concerning perl-wx first and having just wxgtk installed. Moving the wxgtk to makedepends (along with some other subtle changes to the PKGBUILD) prevented BOTH insured that wx-scintilla would both start a build without complaints AND insures that wx-scintilla would build without starting to compile WX itself. IF this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.

*** Perhaps the working solution is to place wxgtk into both the depends and makdepends arrays. This is, of course, your decision to make. I was just sharing some thoughts and some fixes.

not_anonymous commented on 2015-01-04 08:34

Please understand that I wanted to build this against wxgtk 3.X AND I made sure to start this by removing everything concerning perl-wx first. To wit: moving the wxgtk to makedepends insured that it would build (i.e. on a machine without a previous perl-wx installed) AND (along with some other subtle changes to the PKGBUILD) insures that this would build without starting to compile WX itself. IF this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.

*** Perhaps the working solution is to place wxgtk into both the depends and makdepends arrays. This is, of course, your decision to make. I was just sharing some thoughts and some fixes.

not_anonymous commented on 2015-01-04 08:26

Please understand that I wanted to build this against wxgtk 3.X AND I made sure to start this by removing everything concerning perl-wx first. To wit: moving the wxgtk to makedepends insured that it would build (i.e. on a machine without a previous perl-wx installed). If this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.

*** Perhaps the working solution is to place wxgtk into both the depends and makdepends arrays.

not_anonymous commented on 2015-01-04 08:25

Please understand that I wanted to build this against wxgtk 3.X AND I made sure to start this by removing everything concerning perl-wx first. To wit: moving the wxgtk to makedepends insured that it would build (i.e. on a machine without a previous perl-wx installed). If this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.

*** Perhaps the best solution is to place wxgtk into both the depends and makdepends arrays.

not_anonymous commented on 2015-01-04 08:23

Please understand that I wanted to build this against wxgtk 3.X AND I made sure to start this by removing everything concerning perl-wx first. To wit: moving the wxgtk to makedepends insured that it would build (i.e. on a machine without a previous perl-wx installed). If this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.

not_anonymous commented on 2015-01-04 08:22

Please understand that I wanted to build this against wxgtk 3.X AND I made sure to start this by removing everything concerning wx first. To wit: moving the wxgtk to makedepends insured that it would build (i.e. on a machine without a previous perl-wx installed). If this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.

not_anonymous commented on 2015-01-04 08:21

Please understand that I wanted to build this against wxgtk 3.X AND I made sure to start this by removing everything concerning wx first. To wit: moving the wxgtk to makedepends insured that it would build (i.e. on a machine without a previous perl-wx installed). If this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.


not_anonymous commented on 2015-01-04 08:18

When I removed the "useless blobs"/comments it may not have been clear any longer. To wit: moving the wxgtk to makedepends insured that it would build (i.e. on a machine without a previous perl-wx installed). If this makes little to no sense, perhaps this is a due to a bug in the intended way makepkg is suppose to work.

(Please note: I also found it neccessary to put (or leave) in the PERL5LIB='' as an export to complete the makepkg sucessfully.)

Finally, please understand that I wanted to build this against wxgtk 3.X, so I was starting with a "clean slate", so to speak, and hence the changes.