Package Details: petsc 3.19.4-2

Git Clone URL: (read-only, click to copy)
Package Base: petsc
Description: Portable, extensible toolkit for scientific computation
Upstream URL:
Keywords: computing scientific
Licenses: BSD
Provides: petsc4py
Submitter: heitzmann
Maintainer: MartinDiehl
Last Packager: MartinDiehl
Votes: 19
Popularity: 0.007220
First Submitted: 2018-02-24 11:36 (UTC)
Last Updated: 2023-09-26 04:55 (UTC)

Dependencies (22)

Sources (2)

Pinned Comments

MartinDiehl commented on 2022-10-06 10:26 (UTC)


When building PETSc (more specifically, petsc4py), one test (ex100 from ksp) will fail if a previous (major) version is installed. I could not figure out why this happens. The solution would be to build in a clean root (which is a little bit complicated due to dependency on other AUR packages) or simply uninstall the old version before.

Any help to solve this issue is welcomed.

Latest Comments

1 2 3 4 5 6 7 Next › Last »

lahwaacz commented on 2023-09-26 06:14 (UTC)

Still getting the same error due to hypre 2.29.0-1 with petsc 3.19.4-2...

lahwaacz commented on 2023-08-04 05:50 (UTC)

I get the following error trying to build petsc 3.19.4-1 with hypre 2.29.0-1:

In file included from /build/petsc/src/petsc-3.19.4/include/petscsys.h:1086,
                 from /build/petsc/src/petsc-3.19.4/include/petscvec.h:9,
                 from /build/petsc/src/petsc-3.19.4/include/petscmat.h:7,
                 from /build/petsc/src/petsc-3.19.4/include/petscpc.h:7,
                 from /build/petsc/src/petsc-3.19.4/include/petscksp.h:7,
                 from /build/petsc/src/petsc-3.19.4/include/petsc/private/pcimpl.h:5,
                 from /build/petsc/src/petsc-3.19.4/src/ksp/pc/impls/hypre/hypre.c:6:
/build/petsc/src/petsc-3.19.4/src/ksp/pc/impls/hypre/hypre.c: In function ‘PCApply_HYPRE’:
/build/petsc/src/petsc-3.19.4/src/ksp/pc/impls/hypre/hypre.c:446:31: error: incompatible types when assigning to type ‘hypre_Error’ from type ‘int’
  446 |         hypre__global_error = 0;
      |                               ^
/build/petsc/src/petsc-3.19.4/include/petscerror.h:1738:7: note: in definition of macro ‘PetscStackCallExternalVoid’
 1738 |       __VA_ARGS__; \
      |       ^~~~~~~~~~~
/build/petsc/src/petsc-3.19.4/src/ksp/pc/impls/hypre/hypre.c: In function ‘PCApplyTranspose_HYPRE_BoomerAMG’:
/build/petsc/src/petsc-3.19.4/src/ksp/pc/impls/hypre/hypre.c:636:31: error: incompatible types when assigning to type ‘hypre_Error’ from type ‘int’
  636 |         hypre__global_error = 0;
      |                               ^
/build/petsc/src/petsc-3.19.4/include/petscerror.h:1738:7: note: in definition of macro ‘PetscStackCallExternalVoid’
 1738 |       __VA_ARGS__; \
      |       ^~~~~~~~~~~
make[3]: *** [gmakefile:195: arch-linux-c-opt/obj/ksp/pc/impls/hypre/hypre.o] Error 1
make[3]: *** Waiting for unfinished jobs....
         CC arch-linux-c-opt/obj/ksp/pc/impls/mpi/pcmpi.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/vpbjacobi/vpbjacobi.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/jacobi/jacobi.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/mg/fmg.o
         CC arch-linux-c-opt/obj/ksp/ksp/interface/itfunc.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/gamg/geo.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/deflation/deflation.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/gamg/classical.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/is/nn/nn.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/is/pcis.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/hmg/hmg.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/wb/wb.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/gamg/agg.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/mg/gdsw.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/ml/ml.o
         CC arch-linux-c-opt/obj/vec/is/sf/impls/basic/sfpack.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/asm/asm.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/bjacobi/bjacobi.o
         CC arch-linux-c-opt/obj/ksp/pc/impls/gamg/gamg.o
make[3]: Leaving directory '/build/petsc/src/petsc-3.19.4'
make[2]: *** [/build/petsc/src/petsc-3.19.4/lib/petsc/conf/rules.doc:28: libs] Error 2
make[2]: Leaving directory '/build/petsc/src/petsc-3.19.4'
  Error during compile, check arch-linux-c-opt/lib/petsc/conf/make.log
  Send it and arch-linux-c-opt/lib/petsc/conf/configure.log to
make[1]: *** [makefile:45: all] Error 1
make: *** [GNUmakefile:9: all] Error 2

carlosal1015 commented on 2023-07-22 17:10 (UTC) (edited on 2023-08-06 18:43 (UTC) by carlosal1015)

They are fixing compatibility with Cython 3, but probably make a new release soon.

Edited: In 3.19.4, will have the next message

You need Cython == 0.29.36 (you have version 3.0.0)

For petsc-3.20.x or later will support cython 3.

This is a workaround without change the PKGBUILD.

carlosal1015 commented on 2023-06-08 20:20 (UTC)

now is passing the tests with superlu_dist 8.1.2-2

jrohwer commented on 2023-04-08 15:16 (UTC) (edited on 2023-04-08 19:21 (UTC) by jrohwer)


I realize now that I had reported this error previously and that it has been answered here:

Sorry for the noise!

Unfortunately I have not been able to find a workaround other than uninstalling the old version.

Latest version compiles fine but errors out on tests:

==> Starting check()...
Running check examples to verify correct installation
Using PETSC_DIR=/home/jr/.cache/yay/petsc/src/petsc-3.19.0 and PETSC_ARCH=arch-linux-c-opt
C/C++ example src/snes/tutorials/ex19 run successfully with 1 MPI process
C/C++ example src/snes/tutorials/ex19 run successfully with 2 MPI processes
C/C++ example src/snes/tutorials/ex19 run successfully with suitesparse
Possible error running C/C++ Python src/ksp/ksp/tutorials/ex100 with 1 MPI process
[0]PETSC ERROR: --------------------- Error Message --------------------------------------------------------------
[0]PETSC ERROR: WARNING! There are option(s) set that were not used! Could be the program crashed before they were used or a spelling mistake, etc!
[0]PETSC ERROR:   Option left: name:-nox (no value) source: environment
[0]PETSC ERROR:   Option left: name:-nox_warning (no value) source: environment
[0]PETSC ERROR: See for trouble shooting.
[0]PETSC ERROR: Petsc Release Version 3.19.0, Mar 30, 2023 
[0]PETSC ERROR: ./ex100 on a  named jr-xps13 by jr Sat Apr  8 17:12:04 2023
[0]PETSC ERROR: Configure options --prefix=/opt/petsc/linux-c-opt --with-shared-libraries=1 --with-petsc4py=1 --with-mpi-f90module-visibility=0 --with-cc=/usr/bin/mpicc --with-cxx=/usr/bin/mpicxx --with-fc=/usr/bin/mpifort --with-fftw=1 --with-metis=1 --with-suitesparse=1 --COPTFLAGS=-O3 -march=native --CXXOPTFLAGS=-O3 -march=native --FOPTFLAGS=-O3 -march=native
[0]PETSC ERROR: #1 MatPythonSetType() at /home/jr/.cache/yay/petsc/src/petsc-3.19.0/src/mat/impls/python/pythonmat.c:24
[0]PETSC ERROR: #2 RunTest() at ex100.c:24
[0]PETSC ERROR: #3 main() at ex100.c:83
[0]PETSC ERROR: Reached the main program with an out-of-range error code -1. This should never happen
[0]PETSC ERROR: PETSc Option Table entries:
[0]PETSC ERROR: -checkfunctionlist (source: environment)
[0]PETSC ERROR: -nox (source: environment)
[0]PETSC ERROR: -nox_warning (source: environment)
[0]PETSC ERROR: -test (source: command line)
[0]PETSC ERROR: ----------------End of Error Message -------send entire error message to
Fortran example src/snes/tutorials/ex5f run successfully with 1 MPI process
Completed test examples
Error while running make check
make[1]: *** [makefile:123: check] Error 1
make: *** [GNUmakefile:17: check] Error 2
==> ERROR: A failure occurred in check().
 -> error making: petsc

ChrisTX commented on 2023-03-07 07:38 (UTC)

Apparently the build error is caused by a backwards incompatibility in Make, and thus a "bug" in PETSc and not make. They merged a fix, which can be found here:

Could you maybe update the package to apply the fix, so that the package can be built without downgrading Make?

MartinDiehl commented on 2023-03-04 09:54 (UTC)

building PETSc requires to downgrade make (

carlosal1015 commented on 2023-01-22 18:40 (UTC)

According to this log. petsc can not be compiled without scotch. Happily the binaries are available in arch4edu repository. See

MartinDiehl commented on 2023-01-22 17:45 (UTC)

@smp: scotch is now build with cmake, which required some changes on the petsc side. Did you try to update scotch first?