Package Details: petsc 3.21.2-1

Git Clone URL: https://aur.archlinux.org/petsc.git (read-only, click to copy)
Package Base: petsc
Description: Portable, extensible toolkit for scientific computation
Upstream URL: https://petsc.org
Keywords: computing scientific
Licenses: BSD
Provides: petsc4py
Submitter: heitzmann
Maintainer: MartinDiehl
Last Packager: MartinDiehl
Votes: 19
Popularity: 0.000040
First Submitted: 2018-02-24 11:36 (UTC)
Last Updated: 2024-06-06 13:07 (UTC)

Pinned Comments

MartinDiehl commented on 2022-10-06 10:26 (UTC)

@jrohwer

When building PETSc (more specifically, petsc4py), one test (ex100 from ksp) will fail if a previous (major) version is installed. I could not figure out why this happens. The solution would be to build in a clean root (which is a little bit complicated due to dependency on other AUR packages) or simply uninstall the old version before.

Any help to solve this issue is welcomed.

Latest Comments

1 2 3 4 5 6 .. 10 Next › Last »

MartinDiehl commented on 2024-05-19 18:41 (UTC)

@carlosal1915: I get the same error in a non-Python code that uses OpenMPI and PETSc. I think it is an upstream issue in either OpenMPI or PETSc.

carlosal1015 commented on 2024-05-19 13:37 (UTC) (edited on 2024-05-19 13:49 (UTC) by carlosal1015)

Hi, I have the following warning/error? message

>>> from petsc4py.PETSc import ScalarType
[5161bd26d9fc:00008] shmem: mmap: an error occurred while determining whether or not /tmp/ompi.5161bd26d9fc.33333/jf.0/2252865536/shared_mem_cuda_pool.5161bd26d9fc could be created.
[5161bd26d9fc:00008] create_and_attach: unable to create shared memory BTL coordinating structure :: size 134217728 

Maybe related with https://github.com/open-mpi/ompi/issues/12307

jrohwer commented on 2024-04-02 18:40 (UTC)

@lahwaacz Getting the same error.

lahwaacz commented on 2024-03-31 08:15 (UTC)

The tests fail to build:

*******************Error detected during compile or link!*******************
See https://petsc.org/release/faq/
/build/petsc/src/petsc-3.21.0/src/snes/tutorials ex19
*********************************************************************************
/usr/bin/mpicc -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now          -Wl,-z,pack-relative-relocs -flto=auto  -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-protection -fcf-protection -g -ffile-prefix-map=/build/petsc/src=/usr/src/debug/petsc -flto=auto -fPIC  -I/build/petsc/src/petsc-3.21.0/include -I/build/petsc/src/petsc-3.21.0/arch-linux-c-opt/include -I/usr/include/hypre -I/usr/include/suitesparse -I/usr/include/superlu -I/usr/include/superlu_dist -I/usr/include     -Wl,-export-dynamic ex19.c  -Wl,-rpath,/opt/petsc/linux-c-opt/lib -L/opt/petsc/linux-c-opt/lib -Wl,-rpath,/usr/lib/gcc/x86_64-pc-linux-gnu/13.2.1 -L/usr/lib/gcc/x86_64-pc-linux-gnu/13.2.1 -lpetsc /usr/lib/libHYPRE.so -lamd -lbtf -lcamd -lccolamd -lcholmod -lcolamd -lcxsparse -lgraphblas -lklu -lklu_cholmod -llagraph -llagraphx -lldl -lparu -lrbio -lspex -lspqr -lsuitesparse_mongoose -lsuitesparseconfig -lumfpack -ldmumps -lmumps_common -lpord -lpthread -lscalapack -lsuperlu -lsuperlu_dist -lml -lfftw3_mpi -lfftw3 -lkokkoscontainers -lkokkoscore -lkokkossimd -llapack -lblas -lzfp -lzoltan -lptesmumps -lptscotchparmetisv3 -lptscotch -lptscotcherr -lesmumps -lscotch -lscotcherr -lparmetis -lmetis -lnetcdf -lhdf5hl_fortran -lhdf5_fortran -lhdf5_hl -lhdf5 -ltriangle -lm -lz -lgsl -lgslcblas -ljpeg -lyaml -lX11 -lmpi_usempif08 -lmpi_usempi_ignore_tkr -lmpi_mpifh -lmpi -lgfortran -lm -lgfortran -lm -lgcc_s -lquadmath -o ex19
/usr/bin/ld: cannot find -lpetsc: No such file or directory
collect2: error: ld returned 1 exit status
make[4]: *** [<builtin>: ex19] Error 1

It uses -L/opt/petsc/linux-c-opt/lib but of course the package is not installed there yet.

lahwaacz commented on 2024-02-25 11:52 (UTC)

@gpettinello Have you rebuilt trilinos with openmpi version 5? See what ldd /usr/lib/libml.so shows.

gpettinello commented on 2024-02-25 11:46 (UTC)

Same problem to compile as written below about ml libraries. Only solution was to pecify --with-ml = 0 in test_optdepens.sh

lahwaacz commented on 2024-02-24 06:46 (UTC)

You can also remove export OMPI_MCA_plm_rsh_agent=sh, since openmpi has had a hard dependency on openssh since 4.1.5-1 and it will be solved in a better way by https://gitlab.archlinux.org/archlinux/packaging/packages/prrte/-/merge_requests/2

lahwaacz commented on 2024-02-23 17:17 (UTC)

The tests should behave as before with openmpi 5.0.2-4 where the warnings were disabled (by default): https://gitlab.archlinux.org/archlinux/packaging/packages/openmpi/-/commit/ca64cda9e8dcf1460936132eb73e666741a5c38e

So you might want to remove the following from the PKGBUILD:

export OMPI_MCA_opal_warn_on_missing_libcuda=0
if [ -z "$(ldconfig -p | grep libamdhip64.so)" ] || [ -z "$(ldconfig -p | grep libucc.so)" ]; then
  echo "skipping tests"
else

The petsc check target is still bad though, treating all warnings as errors is very naive...

MartinDiehl commented on 2024-02-23 10:13 (UTC)

@Alad: That was my mistake, installing CUDA should not be necessary. It's fixed now.