Package Details: petsc 3.9.2-2

Git Clone URL: (read-only)
Package Base: petsc
Description: Portable, extensible toolkit for scientific computation
Upstream URL:
Licenses: BSD
Submitter: heitzmann
Maintainer: heitzmann
Last Packager: heitzmann
Votes: 0
Popularity: 0.000000
First Submitted: 2018-02-24 11:36
Last Updated: 2018-05-21 16:47

Dependencies (18)

Required by (4)

Sources (2)

Latest Comments

heitzmann commented on 2018-05-21 16:50

@mcovalt setting PETSC_ARCH messes up slepc... I don't have the time to figure out a fix right now, so I'll leave it as it is. Let me know if you can help with that.

mcovalt commented on 2018-05-15 18:46

Looks like my first comment didn't make it. Consider exporting PETSC_ARCH in addition to PETSC_DIR since many programs look for both environment variables to indicate a valid petsc installation is available.

mcovalt commented on 2018-05-15 18:45

Also, adding hypre and suitesparse to the list of optional dependencies could be considered since looks for them.

linux_dream commented on 2018-05-09 18:51

Thank you @heitzmann. I've rebuilt scalapack, I think it was the culprit. I could upgrade petsc without any problem.

heitzmann commented on 2018-05-08 13:45

linux_dream, have you recompiled all your locally compiled dependencies after upgrading gcc-libs? That's probably the reason.

linux_dream commented on 2018-05-08 13:40

I can't seem to be able to upgrade 3.9.0-1 -> 3.9.1-1. I get:

UNABLE to CONFIGURE with GIVEN OPTIONS (see configure.log for details):

Unable to find scalapack in default locations! Perhaps you can specify with --with-scalapack-dir=<directory> If you do not want scalapack, then give --with-scalapack=0 You might also consider using --download-scalapack instead</directory>

Any idea on how to fix the problem?