Package Details: photini-git 2019.10.1.r21.gf7d6901-1

Git Clone URL: (read-only, click to copy)
Package Base: photini-git
Description: An easy to use digital photograph metadata (EXIF, IPTC, XMP) editing application
Upstream URL:
Licenses: GPL
Submitter: dracorp
Maintainer: dracorp
Last Packager: dracorp
Votes: 5
Popularity: 0.000178
First Submitted: 2014-07-26 19:15 (UTC)
Last Updated: 2020-02-11 18:57 (UTC)

Latest Comments

rkelly commented on 2022-06-19 17:30 (UTC) (edited on 2022-06-19 17:56 (UTC) by rkelly)

My package manager is hanging up during downloading:

:: Downloading the latest sources for a devel package photini-git...
:: error: failed to retrieve latest dev sources:
==> Making package: photini-git 2019.10.1.r21.gf7d6901-1 (Sun 19 Jun 2022 10:26:25 AM PDT)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
  -> Cloning Photini git repo...
Cloning into bare repository '/home/user/.cache/pikaur/build/photini-git/Photini'...
fatal: unable to connect to[0:]: errno=Connection timed out

==> ERROR: Failure while downloading Photini git repo

Updating this line seems to fix this issue: source=('') But then more issues appear. I have not been able to build this. Does anyone have any luck with it?

ilario commented on 2020-02-05 08:53 (UTC)

Upstream code supports Python3, the PKGBUILD should be updated accordingly.

crowjake commented on 2018-12-07 12:22 (UTC)

Installs fine but then when trying to launch:

File "/usr/lib/python2.7/site-packages/pkg_resources/", line 578, in _build_master ws.require(requires) File "/usr/lib/python2.7/site-packages/pkg_resources/", line 895, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python2.7/site-packages/pkg_resources/", line 781, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'requests>=2.4.0' distribution was not found and is required by Photini

dracorp commented on 2016-10-10 17:51 (UTC)

@GI_Jack: thx, but I've just added python2-sip and removed pyqt.

GI_Jack commented on 2016-07-11 04:31 (UTC)

bad deps: change pyqt - > python2-pyqt4 add python2-sip

MightyPork commented on 2015-04-18 08:37 (UTC)

this pkgbuild doesn't work. adding this in PKGBUILD partially fixes it: sed '140 s/#/ /' -i sed '142 s/^ /#/' -i but the app is still broken it seems (also missing python2-six as a dependency)

dracorp commented on 2014-09-22 17:32 (UTC)

Thx Thah

Thah commented on 2014-09-22 11:02 (UTC)

Two problems: 1. version mismatch: $ makepkg ==> Making package: photini-git Windows.14.09.r4.gad637d1-1 while PKGBUILD and .AURINFO announce version 14.07.0.r2.gf5f5327-1 2. (probably upstream) installing bug but potentially fixable in PKGBUILD [DIR]/photini-git/pkg/photini-git/usr/lib/python2.7/site-packages/photini/photini.desktop": Failed to create file '/usr/share/applications/photini.desktop.JAPGMX': Permission denied error: command 'desktop-file-install' failed with exit status 1 ==> ERROR: A failure occurred in package(). Aborting... Workaround: Remove/comment out line 140 ("self.spawn(['desktop-file-install', '--delete-original', temp_file])" in src/Photini/ and repackage with makepkg -R. A PKGBUILD fix could use sed or a patch on and install photini.desktop through the package() function.