Package Details: plover_plugins_manager 0.7.2-1

Git Clone URL: (read-only, click to copy)
Package Base: plover_plugins_manager
Description: Plugins manager for Plover.
Upstream URL:
Licenses: GPL2
Submitter: bpierre
Maintainer: SammyPoot
Last Packager: SammyPoot
Votes: 1
Popularity: 0.000000
First Submitted: 2021-04-16 23:47 (UTC)
Last Updated: 2024-02-18 15:32 (UTC)

Latest Comments

linduxed commented on 2023-08-29 17:58 (UTC)

I'm very new to plover and plover_plugins_manager, but could it be that this PKGBUILD is missing a chmod or a chown for some folder somewhere?

I'm asking because attempting to install any plugin results in the following:

usr/lib/python3.11/site-packages/plover_plugins_manager/ DeprecationWarning: pkg_resources is deprecated as an API. See
  from pkg_resources import load_entry_point
error: externally-managed-environment

× This environment is externally managed
╰─> To install Python packages system-wide, try 'pacman -S
    python-xyz', where xyz is the package you are trying to

    If you wish to install a non-Arch-packaged Python package,
    create a virtual environment using 'python -m venv path/to/venv'.
    Then use path/to/venv/bin/python and path/to/venv/bin/pip.

    If you wish to install a non-Arch packaged Python application,
    it may be easiest to use 'pipx install xyz', which will manage a
    virtual environment for you. Make sure you have python-pipx
    installed via pacman.

note: If you believe this is a mistake, please contact your Python installation or OS distribution provider. You can override this, at the risk of breaking your Python installation or OS, by passing --break-system-packages.
hint: See PEP 668 for the detailed specification.

gustaphe commented on 2022-04-27 03:38 (UTC)

It seems the problem goes the other way around now, python-readme-renderer needs python-cmarkgfm>=0.8

bpierre commented on 2021-09-22 20:00 (UTC)

@wuggen: nothing I can do about this on the plugins manager' side; the latest version of python-cmarkgfm is not supported by python-readme-renderer. I've made a PR to the project (

wuggen commented on 2021-09-22 03:26 (UTC) (edited on 2021-09-22 03:27 (UTC) by wuggen)

This is currently broken with plover-git. Starting Plover brings up the following error notification:

ERROR: error loading gui.qt.tool plugin: plugins_manager (from plover_plugins_manager.gui_qt.manager)
pkg_resources.ContextualVersionConflict: (cmarkgfm 0.6.0 (/usr/lib/python3.9/site-packages), Requirement.parse('cmarkgfm=0.5.0'), {'readme-renderer'})

I can manually downgrade the python-cmarkgfm package to get past this error, but if possible it would be nice for it to work with the current repo version.