Package Details: psychopy 2021.2.3-1

Git Clone URL: (read-only, click to copy)
Package Base: psychopy
Description: An experiment builder for neuroscience, psychology and psychophysics
Upstream URL:
Keywords: experiment experiment-control experimental-design linguistics neuroscience psycholinguistics psychology psychophysics psychopy python science
Licenses: GPL3
Submitter: daniel_shub
Maintainer: None
Last Packager: daniel_shub
Votes: 5
Popularity: 0.000000
First Submitted: 2015-08-20 20:24 (UTC)
Last Updated: 2021-10-26 21:39 (UTC)

Latest Comments

1 2 3 Next › Last »

daniel_shub commented on 2022-06-05 19:00 (UTC)

@MarSeed I have no doubt that it should work, but I just tried again and I cannot get it to work. I am still cannot even get it to spit out a useful error message. If you can get it to work or have some ideas, I would be happy for the help.

MarsSeed commented on 2022-06-05 10:43 (UTC) (edited on 2022-06-05 10:43 (UTC) by MarsSeed)

PsychoPy v2022.1.4 should work with Python 3.10. (v22.1.1 earlier this year has already indicated that it does.)

Also I suggest you don't use python-gitpython-211 from 2016. Instead, use python-gitpython which is now at v3.1.27 (Feb 20, 2022).

daniel_shub commented on 2022-02-14 21:30 (UTC)

I have had no luck getting PsychoPy to work with Python 3.10 or even with early python versions in a virtual environment and using pip. I cannot even get PsychoPy to give me an error message that I can start to debug from.

daniel_shub commented on 2021-10-26 20:33 (UTC)

I just upgraded the package. A couple of notes:

1) The package python-gitpython is bugged and requires the package python-typing_extensions ( Just install that package.

2) The package python-moviepy is bugged (

sudo sed -i 's/^decorator.*/decorator/' "/usr/lib/python3.9/site-packages/moviepy-1.0.3-py3.9.egg-info/requires.txt"

3) The package python-gitdb is bugged but should be fixed soon ( In the meantime

sudo sed -i 's/^smmap.*/smmap/' "/usr/lib/python3.9/site-packages/gitdb-4.0.7-py3.9.egg-info/requires.txt"

31415926 commented on 2021-10-26 00:10 (UTC)

Initially, /usr/bin/py.test /usr/lib/python3.9/site-packages/psychopy/tests/ gave this: After installing python-xmlschema it goes as far as this:

daniel_shub commented on 2021-10-23 18:39 (UTC)

Passing the unit tests means that if the PsychoPy developers did their job, then there are not any missing dependencies and/or version conflicts. In my experience with the package, failed unit tests likely means a missing dependency that needs to be packaged.

@31415926 what happens when you try and start the app or when you install python-pytest and run

/usr/bin/py.test /usr/lib/python3.9/site-packages/psychopy/tests/

31415926 commented on 2021-10-22 23:16 (UTC)

Do unit tests need to be done manually? Are passed unit tests the responsibility of AUR packaging? Updating pkgver and sha512sums is enough to make psychopy-2021.2.3 build successfully with makepkg on my computer.

daniel_shub commented on 2021-05-07 16:42 (UTC)

I am having trouble getting version 2021.1.4 to pass the unit tests. There is an issue with moviepy and the decorator version that I am ignoring. I fail a bunch of tests that I did not used to. There are errors on other tests and when I run the tests, I get a seg fault. If anyone has work arounds that lets the package pass the tests, I am happy to take the help.

igord commented on 2020-10-17 19:17 (UTC)

@daniel_shub Thanks. Yup, removing from requires files does the job. BTW, I looked at the PsychoPy code. opencv is used as cv2 import for MovieStim2 only. Since cv2 is provided by opencv package it should work fine (haven't tested as I don't have any experiment that use movie2 simuli). So, I guess just patching setup.cfg to remove opencv-python during build should do the trick.

daniel_shub commented on 2020-10-17 17:51 (UTC)

@igord thanks. Not sure how I missed that. I am not sure if the problem is in this package or the opencv package. An easy work around is to simply remove the opencv-python line from the requires.txt file. I have asked what the best way forward is (

NB, you also need to install the python-certifi package which appears to be a missing dependency of matplotlib (