Package Details: python-audible-cli 0.3.1-1

Git Clone URL: (read-only, click to copy)
Package Base: python-audible-cli
Description: Command line interface (cli) for the audible package.
Upstream URL:
Licenses: AGPL3
Conflicts: python-audible-cli
Provides: python-audible-cli
Submitter: mattski
Maintainer: mattski
Last Packager: mattski
Votes: 0
Popularity: 0.000000
First Submitted: 2022-10-25 07:18 (UTC)
Last Updated: 2024-05-04 15:52 (UTC)

Latest Comments

mattski commented on 2024-05-04 16:00 (UTC)

@dreieck Thanks for the pointers - updated and seems to be working correctly now

Note: Latest stable release is 0.3.1

dreieck commented on 2024-04-28 10:16 (UTC)

This package needs maintanance.

  • Version 0.3.2b3 is available.
  • Dependency python-rfc3986<2.0.0 does not exist (all versions are >=2.0.0).

Regards, please fix your package!

dreieck commented on 2024-03-26 13:01 (UTC)

Build with should no longer be used.

Please, add to makedepends 'python-build' 'python-installer' 'python-wheel', and then use in build():

python -m build --wheel --no-isolation

and in package():

python -m installer --destdir="${pkgdir}" dist/*.whl

instead of the calls to

Regards and thanks for maintaining!

dreieck commented on 2024-03-26 12:51 (UTC)

Version 0.3.2b1 is available.

dreieck commented on 2023-04-26 10:54 (UTC)

Tab completion files are available. Can you install them, too?


dreieck commented on 2023-04-26 10:47 (UTC) (edited on 2023-04-26 10:47 (UTC) by dreieck)

Can you please rename your package to audible-cli, since it provides end-user executable? (And you might want to add replaces=("python-audible-cli"), provides=("python-audible-cli=${pkgver}"), conflicts=("python-audible-cli").)


dreieck commented on 2023-04-26 10:45 (UTC)

To make this work with newer versions of python-httpx, the upper version restriction needs to be removed.

A patch that does it: remove-httpx-upper-version-restriction.patch:

diff -U0 -r audible-cli-0.2.4.orig/ audible-cli-0.2.4/
--- audible-cli-0.2.4.orig/ 2023-04-26 12:35:55.889734682 +0200
+++ audible-cli-0.2.4/  2023-04-26 12:36:56.759732778 +0200
@@ -52 +52 @@
-        "httpx>=0.20.0,<0.24.0",
+        "httpx>=0.20.0",
diff -U0 -r audible-cli-0.2.4.orig/src/audible_cli.egg-info/requires.txt audible-cli-0.2.4/src/audible_cli.egg-info/requires.txt
--- audible-cli-0.2.4.orig/src/audible_cli.egg-info/requires.txt    2023-04-26 12:35:55.899734681 +0200
+++ audible-cli-0.2.4/src/audible_cli.egg-info/requires.txt 2023-04-26 12:36:43.309733198 +0200
@@ -4 +4 @@

And the following to be added to the PKGBUILD:


prepare() {
  cd $srcdir/${_name}-$pkgver
  patch -N -p1 --follow-symlinks -i "${srcdir}/remove-httpx-upper-version-restriction.patch"


dreieck commented on 2023-04-26 10:32 (UTC)

It is the python-httpx package that does the version restriction on python-rfc3986.

python-audible-cli does not need python-rfc3986 directly.

But on the other hand, the has a version restriction on python-httpx: >=0.20.0, <0.24.0.

dreieck commented on 2023-04-26 10:20 (UTC)

Dependency version requirement python-rfc3986<2.0.0 cannot be fulfilled, as the version in the repositories is 2.0.0.


gypaetus commented on 2022-11-17 10:43 (UTC)

Is python-rfc3986<2.0.0 required?