Package Details: python-questionary 2.0.1-2

Git Clone URL: (read-only, click to copy)
Package Base: python-questionary
Description: Python library to build pretty command line user prompts
Upstream URL:
Licenses: MIT
Submitter: chrisjbillington
Maintainer: chrisjbillington
Last Packager: chrisjbillington
Votes: 1
Popularity: 0.000006
First Submitted: 2020-02-04 20:10 (UTC)
Last Updated: 2024-01-06 23:45 (UTC)

Latest Comments

jkhsjdhjs commented on 2024-01-07 01:03 (UTC)

@chrisjbillington Thanks, this fixes the issue! The version requirements seem to be enforced by the script entrypoint, that is generated when building a python package that contains an entrypoint, such as maubot does. But I don't know enough about how python modules are packaged to elaborate any further.

chrisjbillington commented on 2024-01-06 23:47 (UTC) (edited on 2024-01-06 23:47 (UTC) by chrisjbillington)

@jkhsjdhjs done, thanks for the pointer, let me know if it works.

Under what circumstances were you actually getting that error? I was able to makepkg -i and install and import python-questionary despite the version mismatch, which no part of the build process for this package appears to have actually enforced.

jkhsjdhjs commented on 2023-12-20 01:46 (UTC)

Hey, thanks for creating this package and maintaining it! I'm using a package that depends on this package (maubot), which currently doesn't work because upstream questionary is pinning the versions of its dependencies, specifically:

pkg_resources.DistributionNotFound: The 'prompt_toolkit<=3.0.36,>=2.0' distribution was not found and is required by questionary

Arch Linux currently packages prompt_toolkit 3.0.42-1.

A solution would be to strip all required versions from the packages' pyproject.toml:

This has also been done for other packages such as tensorflow in the past:

While questionary currently isn't entirely compatible with prompt_toolkit 3.0.42 (, the only two options we have are that it doesn't work at all or that it at least partially works if the version requirement is removed, because Arch Linux won't downgrade the prompt_toolkit package anyway.

Thus it would be great if you could add an sed line or similar to the PKGBUILD which removes the version requirement from the pyproject.toml. Thanks in advance!