Package Details: python-gdbgui

Git Clone URL: (read-only)
Package Base: python-gdbgui
Description: browser-based gdb frontend using Flask and JavaScript to visually debug C, C++, Go, or Rust
Upstream URL:
Licenses: GPL
Submitter: zwindl
Maintainer: zwindl
Last Packager: zwindl
Votes: 19
Popularity: 0.582339
First Submitted: 2017-03-01 14:03
Last Updated: 2019-04-02 12:45

Latest Comments

1 2 3 Next › Last »

zwindl commented on 2018-11-03 00:29

@gyscos Sorry, I don't know, I'm not very familiar with python. But you could ask the author whether it could be omitted or not.

gyscos commented on 2018-10-30 18:42

This package installs /usr/lib/python3.7/site-packages/tests/, which is unfortunately conflicting with a lot of local tests packages.

Does this package needs to be installed? Could it be omitted?

dos1 commented on 2018-07-28 12:43

python-flask-git installs Flask 1.0.2.r81.g7d9dcfa2-1 which reports itself as If this package depends on Flask < 1.0, a new package for Flask should be created on which this package will depend.

zwindl commented on 2018-05-11 02:06

@richli Well, seems like a big issue, I've replaced the python-flask with an aur package python-flask-git which is an older version :P (totally not "gitty"), tha's an temporory patch, I'm going to waiting for the author's new version. Hope this fixing would work.

richli commented on 2018-05-09 22:53

Although it builds, it fails with an exception:

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 574, in _build_master
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 892, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 783, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (Flask 1.0.2 (/usr/lib/python3.6/site-packages), Requirement.parse('Flask<1.0,>=0.12.2'), {'gdbgui'})

It looks like it's not compatible with the recent release of Flask 1.0. The version ceiling was implemented recently:

zwindl commented on 2017-12-26 04:14

@MarcinWieczorek Thanks a lot, and merry xmas. Very subtle issue, I didn't even notice that.

MarcinWieczorek commented on 2017-12-24 13:33

Hello. Please rename the tarball to "${pkgname}-${pkgver}.tar.gz". Thank you and merry xmas!

zwindl commented on 2017-12-21 10:04

@Svenstaro Thanks for your advice, fixed. The reason I use -git version is the older version of gdbgui needs python-flask newer than the package in community, and I have to package the -git version my own.

Svenstaro commented on 2017-12-20 10:16

Requiring python-flask-git is not a good fix! The package should be patched if there is a problem here. A sed oneliner will be good enough. Please use python-flask instead as it's definitely compatible.

zwindl commented on 2017-08-08 14:42

@muttleyxd OK, I'll change it to flask-git. that makes me confused.