Package Details: python-gdbgui 0.13.0.0-3

Git Clone URL: https://aur.archlinux.org/python-gdbgui.git (read-only)
Package Base: python-gdbgui
Description: browser-based gdb frontend using Flask and JavaScript to visually debug C, C++, Go, or Rust
Upstream URL: https://github.com/cs01/gdbgui
Licenses: GPL
Submitter: zwindl
Maintainer: zwindl
Last Packager: zwindl
Votes: 16
Popularity: 0.462221
First Submitted: 2017-03-01 14:03
Last Updated: 2018-08-01 10:25

Latest Comments

1 2 3 Next › Last »

dos1 commented on 2018-07-28 12:43

python-flask-git installs Flask 1.0.2.r81.g7d9dcfa2-1 which reports itself as 1.1.dev. If this package depends on Flask < 1.0, a new package for Flask should be created on which this package will depend.

zwindl commented on 2018-05-11 02:06

@richli Well, seems like a big issue, I've replaced the python-flask with an aur package python-flask-git which is an older version :P (totally not "gitty"), tha's an temporory patch, I'm going to waiting for the author's new version. Hope this fixing would work.

richli commented on 2018-05-09 22:53

Although it builds, it fails with an exception:

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 574, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 892, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 783, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (Flask 1.0.2 (/usr/lib/python3.6/site-packages), Requirement.parse('Flask<1.0,>=0.12.2'), {'gdbgui'})

It looks like it's not compatible with the recent release of Flask 1.0. The version ceiling was implemented recently: https://github.com/cs01/gdbgui/issues/190

zwindl commented on 2017-12-26 04:14

@MarcinWieczorek Thanks a lot, and merry xmas. Very subtle issue, I didn't even notice that.

MarcinWieczorek commented on 2017-12-24 13:33

Hello. Please rename the tarball to "${pkgname}-${pkgver}.tar.gz". Thank you and merry xmas!

zwindl commented on 2017-12-21 10:04

@Svenstaro Thanks for your advice, fixed. The reason I use -git version is the older version of gdbgui needs python-flask newer than the package in community, and I have to package the -git version my own.

Svenstaro commented on 2017-12-20 10:16

Requiring python-flask-git is not a good fix! The package should be patched if there is a problem here. A sed oneliner will be good enough. Please use python-flask instead as it's definitely compatible.

zwindl commented on 2017-08-08 14:42

@muttleyxd OK, I'll change it to flask-git. that makes me confused.

muttleyxd commented on 2017-08-07 16:04

@zwindl

Using python-flask-git fixes this - package version is equal to 0.13.dev0 and it works currently.

For me it seems like an issue with Python (version comparing) or Python-flask (poor versioning scheme).

zwindl commented on 2017-08-07 09:07

@muttleyxd What? ... ok, I don't know much about python, and I'm going to wait for the author's reply.