Package Details: python-gym 0.26.2-1

Git Clone URL: https://aur.archlinux.org/python-gym.git (read-only, click to copy)
Package Base: python-gym
Description: A toolkit for developing and comparing reinforcement learning algorithms.
Upstream URL: https://gym.openai.com/
Licenses: MIT
Submitter: leomao
Maintainer: imlonghao
Last Packager: imlonghao
Votes: 4
Popularity: 0.000000
First Submitted: 2018-12-14 04:10 (UTC)
Last Updated: 2022-10-22 01:33 (UTC)

Latest Comments

1 2 Next › Last »

imlonghao commented on 2022-06-17 03:24 (UTC)

@vfbsilva LICENSE fixed, please try again

@MarsSeed python-ale-py added

vfbsilva commented on 2022-06-16 22:55 (UTC)

Can I just remove the license file and its checksum from the PKGBUILD and rebuild locally?

MarsSeed commented on 2022-06-16 14:41 (UTC)

The license file should not point to the master branch version, because that is not a fixed file, can change with any new commit.

vfbsilva commented on 2022-06-16 14:32 (UTC)

The package checksum is failing to me. Anyone managed to build it?

MarsSeed commented on 2022-06-11 15:17 (UTC)

@benallard has already created a new python-ale-py package! You can also switch the atari-py optdepend to it, as now ale-py is the recommended plugin for Gym.

MarsSeed commented on 2022-06-10 18:24 (UTC) (edited on 2022-06-10 18:35 (UTC) by MarsSeed)

python-atari-py is deprecated and is not supported by python-gym.

Instead, it seems it optionally requires depends=('python-ale-py>=0.7' 'python-ale-py<1') according to requirements.txt.

Ale-Py is the successor of Atari-Py.

acxz commented on 2022-05-25 01:48 (UTC)

thx for the fixes, I can also build in a clean chroot now!

huyz commented on 2022-03-27 02:52 (UTC)

Today I can build this package with the same command. Strange.

imlonghao commented on 2022-03-27 02:29 (UTC)

@huyz can you try again? I can build with extra-x86_64-build today.

huyz commented on 2022-03-24 06:45 (UTC)

I got this error even when I build this package in a clean chroot:

error in gym setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers; slice indices must be integers or None or have an __index__ method