Package Details: python-sip-pyqt4 4.19.25-1

Git Clone URL: https://aur.archlinux.org/python-sip-pyqt4.git (read-only, click to copy)
Package Base: python-sip-pyqt4
Description: Python 3.x SIP bindings for C and C++ libraries (PyQt4 version)
Upstream URL: https://www.riverbankcomputing.com/software/sip/intro
Licenses: custom:"sip"
Submitter: graysky
Maintainer: LaughingMan
Last Packager: LaughingMan
Votes: 32
Popularity: 0.69
First Submitted: 2019-01-06 15:57 (UTC)
Last Updated: 2021-03-18 02:11 (UTC)

Pinned Comments

Latest Comments

GI_Jack commented on 2020-08-30 18:58 (UTC)

4.19.24 is latest

mikewalk commented on 2020-08-22 21:19 (UTC)

It seems version 4.19.22 is no longer available from the riverbankcomputing source url given, I found I needed to use version 4.19.24 instead. I editted the PKGBUILD file in two places:

--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@

 pkgbase='python-sip-pyqt4'
 pkgname=('python-sip-pyqt4' 'python2-sip-pyqt4')
-pkgver=4.19.22
+pkgver=4.19.24
 pkgrel=1
 arch=('x86_64')
 url='https://www.riverbankcomputing.com/software/sip/intro'
 license=('custom:"sip"')
 makedepends=('python' 'python2')
 source=("https://www.riverbankcomputing.com/static/Downloads/sip/$pkgver/sip-$pkgver.tar.gz")
-sha256sums=('e1b768824ec1a2ee38dd536b6b6b3d06de27b00a2f5f55470d1b512306e3be45')
+sha256sums=('edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5')

 prepare() {
   mkdir -p build-pyqt4{,-py2}

I was trying to install m4baker-git when I encountered the problem, and this change seemed to do the trick for me.

(p.s. I'm a very new Manjaro user, not sure what proper procedure for raising these issues with the maintainers in AUR, so that's the reason I'm just leaving this comment here.)

morgenstern commented on 2020-04-22 10:18 (UTC)

While sip-4.19.19 is still very much available, sip-4.19.22 is also available and should be the actual reason for flagging this package as out-of-date.

dmp1ce commented on 2019-09-16 16:53 (UTC)

@Mechanical_Man python-pyqt4 has a "make" dependency on python-sip-pyqt4 and python2-sip-pyqt4. I think you just install the one you need.

Mechanical_Man commented on 2019-09-10 19:25 (UTC)

I'm not super familiar with internal package stuff at this point, so forgive me if I'm missing something obvious. :)

I'm trying to install a package (python-pyqt4) that depends on both python-sip-pyqt4 and python2-sip-pyqt4. However, it appears both of these packages install some of the same files:

/usr/lib/python2.7/site-packages/PyQt4/sip.pyi exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'
/usr/lib/python2.7/site-packages/PyQt4/sip.so exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'
/usr/lib/python2.7/site-packages/PyQt4_sip-4.19.16.dist-info/INSTALLER exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'
/usr/lib/python2.7/site-packages/PyQt4_sip-4.19.16.dist-info/METADATA exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'
/usr/lib/python2.7/site-packages/PyQt4_sip-4.19.16.dist-info/RECORD exists in both 'python-sip-pyqt4' and 'python2-sip-pyqt4'

buzo commented on 2019-05-25 09:10 (UTC)

quequotion: fixed, thanks

quequotion commented on 2019-05-24 17:49 (UTC) (edited on 2019-05-24 17:49 (UTC) by quequotion)

==> ERROR: pkgbase should not be an array

pkgbase can only have one value, so it doesn't need the parenthesis (they define the variable as an array, even if it only contains a single value).

pkgbase='python-sip-pyqt4'

buzo commented on 2019-05-01 10:54 (UTC)

Morganamilo, jvandrew: Sorry, I didn't notice that – fixed.

jvandrew commented on 2019-04-30 14:07 (UTC)

@buzo Understood. What caused the issue (according to yay maintainers) was changing the pkgbuild without bumping the pkgrel.

At any rate, if anyone reading this is having the same issue with yay, the fix is to do a "clean build".

Morganamilo commented on 2019-04-30 13:09 (UTC)

I do try to tell people not to seek support on the AUR if they are not just using makepkg.

But just for reference, yay bugs out because you never updated the pkgrel: https://aur.archlinux.org/cgit/aur.git/commit/PKGBUILD?h=python-sip-pyqt4

rezaarifandee commented on 2019-04-28 07:04 (UTC) (edited on 2019-04-28 07:19 (UTC) by rezaarifandee)

i can't download from riverbankcomputing, heck i cant even open their website. Anybody got a mirror for sip-4.19.16.tar.gz?

Edit: Found a mirror on https://src.fedoraproject.org/lookaside/pkgs/sip/sip-4.19.16.tar.gz/sha512/6a4e3e8580e914544c9037db61ab9cf05e2460cf2dbdeb67d30c949aa150952d2bb337061f7c7a9222251b04f83a1db1554ff576c3e83b8f60851b442133befa/sip-4.19.16.tar.gz

buzo commented on 2019-04-20 18:49 (UTC)

jvandrew: Please note that AUR helpers are not supported. You should try to get help from the yay developers, or just learn how to build manually (which works fine, btw).

jvandrew commented on 2019-04-20 18:08 (UTC) (edited on 2019-04-20 18:09 (UTC) by jvandrew)

Installing with yay, I get this error:

Could not find PKGDEST for: python2-sip-pyqt4

I assume this has something to do with the merger of this package into python-sip-pyqt4? This prevents updating pyqt4-common as well.

buzo commented on 2019-04-02 15:37 (UTC)

Sorry, I have been busy lately. I have updated it now.

dmp1ce commented on 2019-03-30 18:35 (UTC) (edited on 2019-03-30 18:36 (UTC) by dmp1ce)

I agree. This package should be updated. It is breaking pybitmessage at the moment because it hasn't been updated. Fix is here:

diff --git a/PKGBUILD b/PKGBUILD
index de7f094..d577e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
 # based on https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/sip

 pkgname=('python2-sip-pyqt4')
-pkgver=4.19.13
+pkgver=4.19.15
 pkgrel=1
 arch=('x86_64')
 url='http://www.riverbankcomputing.com/software/sip/intro'
 license=('custom:"sip"')
 makedepends=('python2')
-source=("http://sourceforge.net/projects/pyqt/files/sip/sip-$pkgver/sip-$pkgver.tar.gz")
-sha256sums=('e353a7056599bf5fbd5d3ff9842a6ab2ea3cf4e0304a0f925ec5862907c0d15e')
+source=("https://www.riverbankcomputing.com/static/Downloads/sip/$pkgver/sip-$pkgver.tar.gz")
+sha256sums=('2b5c0b2c0266b467b365c21376d50dde61a3236722ab87ff1e8dacec283eb610')

 prepare() {
   mkdir -p build-pyqt4-py2

jheinz commented on 2019-03-25 14:37 (UTC)

The download URL is wrong or has changed. The valid one is: https://www.riverbankcomputing.com/static/Downloads/sip/4.19.15/sip-4.19.15.tar.gz

eschwartz commented on 2019-03-20 17:46 (UTC)

Why not update this package in the meantime, and discuss with graysky the possibility of merging them?

Has graysky ever been contacted about it? Do you know whether he knows about the proposal at all, or whether he considers it desirable?

fbrennan commented on 2019-03-09 23:39 (UTC)

Hello world:

User alexei flagged the package and buzo filed an orphan request.

alexei wrote, among other things, that:

Btw, could you please merge the python-sip-pyqt4 and python2-sip-pyqt4 into one split package?

This is impossible as the counterpart package is already owned by someone else, graysky. So I decided it would be prudent to wait for them to request deletion of this package, presumably when they have a split package available.

That hasn't happened. This package should not be orphaned, it should be deleted. But it shouldn't be deleted until graysky requests as such because only he can make a split package. Alternatively, he can add me as a comaintainer to his package, then I can push the split package.