Package Details: python2-jsmin 2.2.2-2

Git Clone URL: https://aur.archlinux.org/python-jsmin.git (read-only, click to copy)
Package Base: python-jsmin
Description: JavaScript minifier
Upstream URL: https://pypi.org/pypi/jsmin
Licenses: MIT
Submitter: rafaelff
Maintainer: rafaelff
Last Packager: rafaelff
Votes: 19
Popularity: 0.022126
First Submitted: 2016-05-27 12:04
Last Updated: 2018-06-16 17:02

Latest Comments

rafaelff commented on 2019-12-09 12:24

@djmattyg007: I don't think "the whole point of the pkgrel flag is to trigger rebuilds". Its main use is to implement "fixes and additional features" to the PKGBUILD, according to https://wiki.archlinux.org/index.php/PKGBUILD#pkgrel; Devs/TUs from official repositories use pkgrel bump with rebuild to force update because users of those binary packages wouldn't have this fix available with the new dependencies otherwise, which is a different scenario.

Have you tried using --rebuild flag of aur sync? It forces a package currently available in the repository to be rebuilt and added to the local customrepository.

djmattyg007 commented on 2019-12-09 10:03

Literally the whole point of the pkgrel flag is to trigger rebuilds in cases such as these. It's honestly disappointing to see such a high level of pushback against changing a single character in a single file.

djmattyg007 commented on 2019-12-09 09:57

@rafaelff I use aurutils as my AUR helper. It involves running a full package repository recognised by pacman on my machine.

https://github.com/AladW/aurutils

Rebuilding packages with the same version number isn't really something it was built to do. It relies on AUR maintainers properly playing their part in maintaining a package, and that includes bumping the pkgrel to automatically trigger a rebuild for things such as C library changes or new editions of python, just like what would happen in the official repositories.

The fact is that it probably takes a lot less effort for maintainers to change a single character in their PKGBUILDs, rather than making every single person who's built and installed your package manually check their python library files to see if anything has been left behind during the upgrade.

rafaelff commented on 2019-12-08 10:15

In time, I recommend users of Python packages in AUR to check "/usr/lib/python3.7/site-packages/" for directories. Directories in there might be from Python packages that were built with Python3.7, which should present problems with Python3.8. If anything is found under that directory, package rebuild is recommended.

rafaelff commented on 2019-12-08 10:13

@djmattyg007: Why don't you just rebuild python-jsmin? I mean, it is not like in official repositories, that pkgrel bumping is mandatory to provide users a binary package with new dependencies. Bumping or not pkgrel, building the package do the job.

djmattyg007 commented on 2019-12-08 02:42

Please could you bump the pkgrel to force a rebuild for python3.8.

djmattyg007 commented on 2019-11-17 02:15

Please bump the pkgrel to force a rebuild for python3.8.

rafaelff commented on 2016-08-16 10:25

Thanks, AlesTes. It should be fixed now.

AlexTes commented on 2016-08-15 21:14

Broken for me
==> Starting build()...
running build
running build_py
Traceback (most recent call last):
File "setup.py", line 1, in <module>
from setuptools import setup
ImportError: No module named setuptools
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build python2-jsmin package(s)