Package Details: python2-lineprofiler 1.0-2

Git Clone URL: https://aur.archlinux.org/python2-lineprofiler.git (read-only)
Package Base: python2-lineprofiler
Description: Line-by-line profiler.
Upstream URL: http://pypi.python.org/pypi/line_profiler
Licenses: BSD
Submitter: lestb
Maintainer: lestb
Last Packager: lestb
Votes: 7
Popularity: 0.000000
First Submitted: 2013-07-19 14:53
Last Updated: 2015-06-11 08:40

Latest Comments

diegoM commented on 2014-10-29 14:54

Hi, exist a conflict with python-lineprofiler , because both try to install /usr/bin/kernprof.

error: failed to commit transaction (conflicting files)
python-lineprofiler: /usr/bin/kernprof exists in filesystem

The solution I found is to add this line at the end of the function package():

mv "${pkgdir}"/usr/bin/kernprof{,2}

Regards,
Diego

lestb commented on 2013-07-19 14:55

Package moved here: https://aur.archlinux.org/packages/python2-lineprofiler

MaggotBrain commented on 2013-05-05 08:45

When built creates empty package, can somebody fix this, thx!

bins commented on 2013-04-10 18:56

feel free to pick up this package (I don't have any use for it)

csousa commented on 2013-04-10 18:43

# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
# Maintainer: Sebastien Binet <binet@lblbox>
pkgname=python2-lineprofiler
pkgver=1.0b3
pkgrel=1
pkgdesc="Line-by-line profiler."
url="http://pypi.python.org/pypi/line_profiler"
arch=('i686' 'x86_64')
license=('BSD')
depends=( 'python2' )
makedepends=('cython2')
conflicts=()
replaces=()
backup=()
install=
source=(http://pypi.python.org/packages/source/l/line_profiler/line_profiler-$pkgver.tar.gz)
md5sums=('63fc2a757192eb5e577559cfdff5b831')

build() {
cd $srcdir/line_profiler-$pkgver
python2 setup.py build || return 1
}

package() {
cd $srcdir/line_profiler-$pkgver
python2 setup.py install --prefix=/usr --root=$pkgdir
}

rpodgorny commented on 2013-02-23 16:32

...it also should be renamed to python2-lineprofiler as python 3 is now default.

bins commented on 2011-04-28 06:29

done.
thanks for the reminder.

ayr0 commented on 2011-04-27 18:43

This package needs to be updated to work correctly with python2

namely
change python to python2 in PKGBUILD.