Package Details: python2-pyrenamer 0.6.1-3

Git Clone URL: https://aur.archlinux.org/python2-pyrenamer.git (read-only, click to copy)
Package Base: python2-pyrenamer
Description: Application for mass renaming files.
Upstream URL: https://gitlab.com/patlefort/pyrenamer
Licenses: GPL2
Conflicts: pyrenamer
Provides: pyrenamer
Submitter: patlefort
Maintainer: patlefort
Last Packager: patlefort
Votes: 2
Popularity: 0.000115
First Submitted: 2021-05-09 08:26 (UTC)
Last Updated: 2021-09-29 14:31 (UTC)

Latest Comments

patlefort commented on 2021-09-29 14:34 (UTC)

I added !buildflags since it doesn't actually need to compile anything.

G4Zz0L1 commented on 2021-09-29 08:02 (UTC) (edited on 2021-10-06 22:40 (UTC) by G4Zz0L1)

Ok, found the culprit, it was an error with my /etc/makepkg.conf, the configure steps checks with some build flags that conflicts with mine. I've solved it adding to the PKGBUILD the following line to ignore my build flags

options=(!buildflags)

G4Zz0L1 commented on 2021-09-29 07:21 (UTC)

I've compiled a lot of packages from the aur written in C without problems. Can you guess why this returns that error, or try to point me to something specific I can check?

patlefort commented on 2021-09-27 17:18 (UTC)

That error indicate that there is a problem with your C compiler (gcc). Can you check if you can compile anything with it?

G4Zz0L1 commented on 2021-09-27 16:55 (UTC) (edited on 2021-09-27 16:55 (UTC) by G4Zz0L1)

The package fails to build with yay with these lines:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for python version... 2.7
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for PYGTK... yes
checking for gconf... yes
Using config source xml:merged:/etc/gconf/gconf.xml.defaults for schema installation
Using /usr/share/gconf/schemas as install directory for schema files
checking for gconftool-2... /usr/bin/gconftool-2
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... 
configure: error: C compiler cannot create executables
See `config.log' for more details.

jester commented on 2021-05-30 13:27 (UTC)

You were true, now it installs ok.

Thanks.

patlefort commented on 2021-05-30 13:17 (UTC)

Works for me. Can you try a clean build? (make sure pyrenamer-v0.6.1.tar.gz is redownloaded).

jester commented on 2021-05-30 13:14 (UTC)

Yes I know, don't worry for the authority. Seems that the checksum is not correct.

Validando los archivos source con sha256sums... pyrenamer-v0.6.1.tar.gz ... HA FALLADO

patlefort commented on 2021-05-30 10:23 (UTC)

Yes I didn't update the version in the sources. I just corrected it. To be clear I'm not the original author of this application, I forked it and made very minor changes. The original is abandoned.

jester commented on 2021-05-30 09:14 (UTC)

I have installed the application but the version installed seems to be the 0.6.0. Is it possible?