Package Details: qarte 3.1.1-1

Git Clone URL: https://aur.archlinux.org/qarte.git (read-only)
Package Base: qarte
Description: Allow you to browse into the archive of arte+7 & arteLiveWeb sites and to record your prefered videos.
Upstream URL: https://launchpad.net/qarte
Licenses: GPL3
Submitter: ktalog
Maintainer: colundrum
Last Packager: colundrum
Votes: 39
Popularity: 0.848563
First Submitted: 2012-04-02 21:43
Last Updated: 2016-07-11 00:42

Latest Comments

kroogy commented on 2016-11-27 13:54

Modify PKGBuild for a working install:

pkgver=3.5.0
md5sums=('6ddc441695dd41f5b6a50bb04819a2af')

cousinm commented on 2016-11-21 15:23

Hi, this package is obsolete for a while now. Could you please upgrade it ? or disown it so someone else can continue from here ?

SkizoRutabaga commented on 2016-09-09 08:01

Here is a working pPKGBUILD for v3.2 :
- changed version, md5sum
- added new dependency qt5-svg

pkgname=qarte
pkgver=3.2.0
pkgrel=1
pkgdesc='Allow you to browse into the archive of arte+7 & arteLiveWeb sites and to record your prefered videos.'
url='https://launchpad.net/qarte'
arch=('i686' 'x86_64')
license=('GPL3')
source=(http://ppa.launchpad.net/vincent-vandevyvre/vvv/ubuntu/pool/main/q/qarte/${pkgname}_${pkgver}.orig.tar.gz)
depends=('qt5-translations' 'python-pyqt5', 'qt5-svg')
optdepends=('cronie: for differed download')
md5sums=('f4a966e888efa9e74936db0a1a585a2a')

package() {
cd $srcdir/${pkgname}-${pkgver}

# Man compression
gzip qarte.1

bin_dir="$pkgdir/usr/bin"
man_dir="$pkgdir/usr/share/man/man1"
application_dir="$pkgdir/usr/share/applications"
pixmaps_dir="$pkgdir/usr/share/pixmaps"
qarte_dir="$pkgdir/usr/share/${pkgname}"

mkdir -p $bin_dir
mkdir -p $man_dir
mkdir -p $application_dir
mkdir -p $pixmaps_dir
mkdir -p $qarte_dir

mv qarte $bin_dir
mv qarte.1.gz $man_dir
mv q_arte.desktop $application_dir
mv qarte.png $pixmaps_dir
chmod 0644 $pixmaps_dir/qarte.png
mv * $qarte_dir
}

elelay commented on 2016-08-18 13:21

3.1.1 is no more available in the ubuntu repo.
Change it to 3.2.0.

pgennere commented on 2016-07-09 13:49

pkgver=3.0.4 replace by pkgver=3.1.1
md5sum qarte_3.1.1.orig.tar.gz
5f8a304d0e5d4a4589788443a0362639 qarte_3.1.1.orig.tar.gz

pgennere commented on 2016-07-04 07:13

Work with manjaro 16 netinstall with Mate , Why ??? I don't know . I don't know Python . Problem with the langage of my laptop (100% English with french keyboard). I add fr_FR language packages. In the center "Language Package' I have a line "Package: qt5-translations , Parent Package : Qt5 translations " . Now Qarte 3.04 work fine . Thanks.

pgennere commented on 2016-07-03 19:16

same problem with linux mint 18 and the package qarte_3.0.4_all.deb
Error :
File "/usr/bin/qarte", line 117, in <module>
main = Core()
File "/usr/share/qarte/core.py", line 48, in __init__
self.set_environment()
File "/usr/share/qarte/core.py", line 75, in set_environment
self.cfg = self.get_config()
File "/usr/share/qarte/core.py", line 95, in get_config
cfg = self.create_config()
File "/usr/share/qarte/core.py", line 107, in create_config
idx = [None, 'fr', 'de'].index(LANG)
ValueError: 'en' is not in list

pgennere commented on 2016-07-03 10:14

Hello,
A little problem with the new version 3.0.4-1 , perhaps a mistake with my configuration . Thanks
$ qarte -d
12:03:55: INFO - core Set workspace
12:03:55: INFO - core Config not found, use default
Traceback (most recent call last):
File "/usr/bin/qarte", line 117, in <module>
main = Core()
File "/usr/share/qarte/core.py", line 48, in __init__
self.set_environment()
File "/usr/share/qarte/core.py", line 75, in set_environment
self.cfg = self.get_config()
File "/usr/share/qarte/core.py", line 95, in get_config
cfg = self.create_config()
File "/usr/share/qarte/core.py", line 107, in create_config
idx = [None, 'fr', 'de'].index(LANG)
ValueError: 'en' is not in list

t0mab commented on 2016-06-29 07:51

Hi Colundrum, I succeed installing and using qarte 3.0.4 (with 3.0.3 I had coredump) http://ppa.launchpad.net/vincent-vandevyvre/vvv/ubuntu/pool/main/q/qarte/qarte_3.0.4.orig.tar.gz

changing a little bit your pkbuild md5 : e82e60fcc62f683a6e561b4bd4ab6cb9 and dependency to python-pyqt5 for now I can download stuff the only thing not working is goind on top menu arte-concert / reload close the app and the config settings are not saved (I removed old .Qarte but no new config file ).

Have a nice day !

colundrum commented on 2016-06-13 09:00

Sorry but I can't update it now due to an issue :

Traceback (most recent call last):
File "/tmp/qarte-3.0.2/gui/mainui.py", line 516, in mouseDoubleClickEvent
self.move_item(self.itemAt(event.pos()))
File "/tmp/qarte-3.0.2/gui/mainui.py", line 548, in move_item
idx = self.main.apl.items.index(item)
AttributeError: 'ArteTVVideoList' object has no attribute 'main'
[1] 19412 abort (core dumped) LC_ALL=fr_FR.UTF-8 ./qarte

All comments