Package Details: qgis-git 2.99-5

Git Clone URL: https://aur.archlinux.org/qgis-git.git (read-only)
Package Base: qgis-git
Description: Geographic Information System (GIS) that supports vector, raster & database formats - Development master
Upstream URL: http://qgis.org/
Keywords: GIS Qt5
Licenses: GPL
Conflicts: qgis
Submitter: saultdon
Maintainer: gaelic
Last Packager: gaelic
Votes: 8
Popularity: 1.099877
First Submitted: 2015-08-20 03:06
Last Updated: 2017-02-06 10:31

Required by (0)

Sources (1)

Latest Comments

gaelic commented on 2017-02-15 14:37

Can you try to compile it again, and if not working again in a few days. This is (in my opinion) not a package problem, but some upstream hickup on the qgis side. I (and others) had the same problem some weeks ago and it just disapeared ... and unfortunately appeared again.

Please keep me updated on that.

PS: please also install: qgnomeplatform-git , this should resolve the gtk warnings

ingleandrobarros commented on 2017-02-13 14:27

Bro, Qgis-git don't run correctly. Check that:

using qt5ct plugin

(qgis-git:24665): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

(qgis-git:24665): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
Warning: loading of qgis translation failed [/opt/qgis-git/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/share/qt/translations/qt_en_US]
D-Bus system tray: no
QGIS died on signal 11Aborted (core dumped)

gaelic commented on 2017-02-10 08:49

Well, this seems to be a problem on your side (unstable internet connection?). Please clear your pacaur cache for qgis-git and try again.

zottelef commented on 2017-02-10 08:42

I get this error:
-> Cloning qgis git repo...
Cloning into bare repository '/home/fabio/.cache/pacaur/qgis-git/qgis'...
remote: Counting objects: 486889, done.
remote: Compressing objects: 100% (231/231), done.
remote: fatal: unable to read 33e8c840abbcec03105874a6f904d298e14c3751
remote: aborting due to possible repository corruption on the remote side.
fatal: early EOF
fatal: index-pack failed
==> ERROR: Failure while downloading qgis git repo
Aborting...

gaelic commented on 2017-02-06 10:35

I've just recompiled. Works fine at the moment.

kikislater commented on 2017-02-03 11:28

For a temporary workaround, I use a docker for qgis desktop until sip problem solved

gaelic commented on 2017-02-03 11:02

Hi.

I get the same error when I recompiled the package. I have not found a solution yet, but I guess there is some error because of:

- uppkg of qt to 5.8
- pyqt is still at 5.7.1

I've tried to install the development version of pyqt 5.8.dev, but it needs also the development version of sip, etc. A bunch of new construction sites opening ...

jinja & pygments are in the package

@lazyboy: I don't know why you get this error, is it still happening?

---

Additionally: the new version of the package now installs into /opt/qgis-git and symlinking the binary to /usr/bin/qgis-git

So it is possible to install qgis and qgis-git side by side. But I have not tested it yet, because the stable branch of qgis fails to built because of sip.

Quite a bummer at the moment.

Geotig commented on 2017-01-31 20:39

Hi gaelic, as lazyboy reported, I needed to install python-jinja and python-pygments, but the program crashes with a QGIS died in signal 11 too. This is the terminal info in case it's useful:

using qt5ct plugin
Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/share/qt/translations/qt_en_US]
Warning: inotify_add_watch("/home/username/.qgis3//project_templates") failed: "No such file or directory"
D-Bus system tray: no
QGIS died on signal 11Aborted (core dumped)

lazyboy commented on 2017-01-31 16:29

I've installed qca-qt5 2.1.1-7 but I get:

CMake Error at cmake/FindQCA.cmake:89 (message):
Could not find QCA >= 2.0.3

lazyboy commented on 2017-01-30 12:58

Hi gaelic,

thanks for advice, my last build was indeed intermitted.

Please add python-jinja and python-pygments to the dependency list.

After successful installing I get a program crash "QGIS died on signal 11".

gaelic commented on 2017-01-30 09:05

Hi.

Can you please try to make a new built from scratch and delete all previous files generated beforehand:

http://stackoverflow.com/questions/5713894/file-not-recognized-file-truncated-gcc-error

I hope this will resolve this error.

lazyboy commented on 2017-01-29 18:33

[ 20%] Linking CXX shared library ../../output/lib/libqgis_core.so
CMakeFiles/qgis_core.dir/qgssnappingutils.cpp.o: file not recognized: File truncated
collect2: error: ld returned 1 exit status
make[2]: *** [src/core/CMakeFiles/qgis_core.dir/build.make:13538: output/lib/libqgis_core.so.2.99.0] Error 1
make[1]: *** [CMakeFiles/Makefile2:209: src/core/CMakeFiles/qgis_core.dir/all] Error 2
make: *** [Makefile:150: all] Error 2

gaelic commented on 2016-12-29 21:29

the error should be resolved now, please try again.

sikmir commented on 2016-12-24 14:17

Compiling /tmp/yaourt-tmp-sikmir/aur-qgis-git/pkg/qgis-git/usr/share/qgis/python/qgis/core/__init__.py ...
File "/tmp/yaourt-tmp-sikmir/aur-qgis-git/pkg/qgis-git/usr/share/qgis/python/qgis/core/__init__.py", line 228
def fromFunction(description, function, *args, on_finished=None, flags=QgsTask.AllFlags, **kwargs):
^
SyntaxError: invalid syntax

gaelic commented on 2016-10-25 10:59

Thx.

I've included spatial index as dependency, it is not expicitely listed as a dependency in INSTALL.md found on qgis github. Although when looking into debian or fedora package examples libspatialindex is installed. Same goes for txt2tags which seems to be only makedep.

If you find any bugs regarding missing dependencies please keep me informed.

jouke commented on 2016-10-24 16:55

this depends on spatialindex and txt2tags might be a build dependency

gaelic commented on 2016-09-22 14:15

Adapted the package for Qt5 and Python3

It runs, but do not expect it to be stable in any way.

Scimmia commented on 2016-07-19 14:48

WARNING:

The master branch is now headed toward QGIS 3.0. This means some major code churn, a complete switch to py3/pyqt5/qt5, and multiple API breaks. Expect instability.

gaelic commented on 2016-02-03 11:42

Small information.

I've updated the PKGBUILD to compile again. For simplcity reasons I've taken the stable qgis PKGBUILD and modified it. So qgis-git is not installing into /opt anymore and also the binary is simply qgis and not qgis-git ... this package is now conflicting with qgis from aur.

If someone wants to revert these changes and/or modify it further for a parallel install please let me know and I'm vacating the package.

----
EDIT: the new qgis (2.14) will be aweseome :)