Package Details: qstlink2-git 1:1.3.0.r263.b0d2fb8-1

Git Clone URL: https://aur.archlinux.org/qstlink2-git.git (read-only, click to copy)
Package Base: qstlink2-git
Description: A ST-Link V2 (Debugger/Programmer) client graphical user interface (git version)
Upstream URL: https://github.com/fpoussin/QStlink2
Licenses: GPL3
Conflicts: qstlink, qstlink2, qstlink2-svn
Provides: qstlink2
Submitter: SpotlightKid
Maintainer: None
Last Packager: SpotlightKid
Votes: 13
Popularity: 0.000151
First Submitted: 2015-02-12 15:37 (UTC)
Last Updated: 2022-12-02 15:38 (UTC)

Dependencies (4)

Required by (0)

Sources (2)

Latest Comments

1 2 Next › Last »

drws commented on 2023-07-26 17:52 (UTC)

Then the description is apparently off, it reads as this being only the GUI. Thank you for the information and of course for maintaining it in the first place.

SpotlightKid commented on 2023-07-26 11:06 (UTC)

@drws: no qstlink does not rely on stlink to do the flashing, AFAICS it includes its own implementation of it.

The project doesn't seem to be really maintained anymore, it doesn't recognize many newer MCUs (see issues), so I don't really see a reason for maintaining this package anymore. I'm orphaning it now.

drws commented on 2023-07-26 09:14 (UTC)

stlink is listed only as an optional dependency and described as "udev rules". It's an explicit dependency since the actual flasher comes from there and the dependency description should also reflect that (change the "udev rules" description please).

SpotlightKid commented on 2022-12-02 15:41 (UTC)

@df8oe: yeah, had to fix that in a quite a few packages, but hadn't come around to this one yet. thanks for the heads up! fixed now.

df8oe commented on 2022-12-02 15:18 (UTC)

Does not build because of a change in submodules on Github. Please look here: https://wiki.archlinux.org/title/VCS_package_guidelines#Git_submodules

SpotlightKid commented on 2020-05-06 20:01 (UTC)

@Yinameah: Fixed. Thanks for reporting!

Yinameah commented on 2020-05-06 17:10 (UTC)

I just installed this package. The build wouldn't succeed without an extra dependency : community/hidapi

Not sure if it's build dep only on needed to run, but should be added somewhere I belive.

Best regards and big up to the maintainer

SpotlightKid commented on 2017-03-06 09:19 (UTC)

You're right, it seems that I uploaded a .SRCINFO file with a wrong version number for the previous package release, sorry. I'm not sure how that happened. I fixed this by setting the package epoch to 1.

korken89 commented on 2017-03-06 08:39 (UTC)

Hi, the version of the package seems of, no matter how may times I update it does not go to 1.3.0, after compile it is 1.2.4 again. Please have a look, a snip from the install: ........ ==> Making package: qstlink2-git 1.3.0.r228.8e30cfa-1 (mon mar 6 09:32:33 CET 2017) ........ ==> Finished making: qstlink2-git 1.2.4.r244.24a687a-1 (mon mar 6 09:32:48 CET 2017)

SpotlightKid commented on 2016-08-16 04:13 (UTC)

@kyb: fixed